Bug 327796 - Kontact Crashes while polling unstable CALDAV-source
Summary: Kontact Crashes while polling unstable CALDAV-source
Status: RESOLVED DUPLICATE of bug 327878
Alias: None
Product: korganizer
Classification: Applications
Component: agendaview (weekview) (show other bugs)
Version: 4.11.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
: 323433 329099 332620 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-19 09:02 UTC by jacob.becker
Modified: 2014-03-29 07:44 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jacob.becker 2013-11-19 09:02:54 UTC
Application: kontact (4.11.2)
KDE Platform Version: 4.11.2
Qt Version: 4.8.2
Operating System: Linux 3.2.0-55-generic x86_64
Distribution: Ubuntu 12.04.3 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Using Kontact with SOGo with several Shared Calendars.
Sometimes the SOGo-Sever doesn't respond very fast (timeouts possible).

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa64df387c0 (LWP 5353))]

Thread 5 (Thread 0x7fa6310d1700 (LWP 5354)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa648dc3dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fa648dc3f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fa645bd4e9a in start_thread (arg=0x7fa6310d1700) at pthread_create.c:308
#4  0x00007fa64b4723fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fa6307b8700 (LWP 5355)):
#0  __pthread_mutex_lock (mutex=0x7fa628000a60) at pthread_mutex_lock.c:87
#1  0x00007fa6457435b1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa645707bf6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa645708060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa645708124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa64bbe8926 in QEventDispatcherGlib::processEvents (this=0x7fa6280008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fa64bbb7e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fa64bbb80b7 in QEventLoop::exec (this=0x7fa6307b7dc0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fa64bab7077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fa64baba09b in QThreadPrivate::start (arg=0x14235e0) at thread/qthread_unix.cpp:307
#10 0x00007fa645bd4e9a in start_thread (arg=0x7fa6307b8700) at pthread_create.c:308
#11 0x00007fa64b4723fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa5dbfff700 (LWP 5361)):
#0  0x00007fa64b466a43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fa645707ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa645708124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa64bbe8926 in QEventDispatcherGlib::processEvents (this=0x7fa5d40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fa64bbb7e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fa64bbb80b7 in QEventLoop::exec (this=0x7fa5dbffed90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fa64bab7077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fa64bb97b6f in QInotifyFileSystemWatcherEngine::run (this=0x1acd0f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fa64baba09b in QThreadPrivate::start (arg=0x1acd0f0) at thread/qthread_unix.cpp:307
#9  0x00007fa645bd4e9a in start_thread (arg=0x7fa5dbfff700) at pthread_create.c:308
#10 0x00007fa64b4723fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa5da1e6700 (LWP 3972)):
#0  0x00007fff4ed8a8de in ?? ()
#1  0x00007fa643f3815d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007fa64bb10c84 in do_gettime (frac=0x7fa5da1e5b58, sec=0x7fa5da1e5b50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fa64bbe908d in QTimerInfoList::updateCurrentTime (this=0x7fa5c801d550) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fa64bbe93c3 in QTimerInfoList::timerWait (this=0x7fa5c801d550, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fa64bbe7e7c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fa5da1e5c2c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fa64bbe7f25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fa645707806 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fa645707f1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fa645708124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fa64bbe8926 in QEventDispatcherGlib::processEvents (this=0x7fa5c8019f60, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fa64bbb7e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fa64bbb80b7 in QEventLoop::exec (this=0x7fa5da1e5d90, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fa64bab7077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007fa64bb97b6f in QInotifyFileSystemWatcherEngine::run (this=0x9134d00) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fa64baba09b in QThreadPrivate::start (arg=0x9134d00) at thread/qthread_unix.cpp:307
#17 0x00007fa645bd4e9a in start_thread (arg=0x7fa5da1e6700) at pthread_create.c:308
#18 0x00007fa64b4723fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa64df387c0 (LWP 5353)):
[KCrash Handler]
#6  KCalCore::Incidence::hasRecurrenceId (this=0x0) at ../../kcalcore/incidence.cpp:1035
#7  0x00007fa5d07d6907 in EventViews::AgendaView::displayIncidence(Akonadi::Item const&, bool) () from /usr/lib/libeventviews.so.4
#8  0x00007fa5d07d8675 in EventViews::AgendaView::fillAgenda() () from /usr/lib/libeventviews.so.4
#9  0x00007fa5d07a98b0 in EventViews::EventView::onCollectionChanged(Akonadi::Collection const&, QSet<QByteArray> const&) () from /usr/lib/libeventviews.so.4
#10 0x00007fa64bbcd781 in QMetaObject::activate (sender=0x15270210, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4ec704d0) at kernel/qobject.cpp:3547
#11 0x00007fa62e4e04c7 in Akonadi::ETMCalendar::collectionChanged (this=<optimized out>, _t1=..., _t2=...) at ./etmcalendar.moc:108
#12 0x00007fa62e4e0a4c in Akonadi::ETMCalendarPrivate::onCollectionChanged (this=0x14748f90, collection=..., attributeNames=...) at ../../../akonadi/calendar/etmcalendar.cpp:133
#13 0x00007fa62e4e468d in Akonadi::ETMCalendarPrivate::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fff4ec707c0) at ./etmcalendar_p.moc:198
#14 0x00007fa64bbcd781 in QMetaObject::activate (sender=0x13e06ea0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4ec707c0) at kernel/qobject.cpp:3547
#15 0x00007fa64a485d5a in Akonadi::Monitor::collectionChanged (this=<optimized out>, _t1=..., _t2=...) at ./moc_monitor.cpp:300
#16 0x00007fa64a48ab25 in Akonadi::MonitorPrivate::emitCollectionNotification (this=0x14893af0, msg=..., col=..., par=..., dest=...) at ../../akonadi/monitor_p.cpp:811
#17 0x00007fa64a48b463 in Akonadi::MonitorPrivate::emitNotification (this=0x14893af0, msg=...) at ../../akonadi/monitor_p.cpp:403
#18 0x00007fa64a3e5441 in Akonadi::ChangeRecorderPrivate::emitNotification (this=0x14893af0, msg=...) at ../../akonadi/changerecorder_p.cpp:55
#19 0x00007fa64a48c356 in Akonadi::MonitorPrivate::flushPipeline (this=0x14893af0) at ../../akonadi/monitor_p.cpp:600
#20 0x00007fa64a48c3e9 in Akonadi::MonitorPrivate::dataAvailable (this=0x14893af0) at ../../akonadi/monitor_p.cpp:609
#21 0x00007fa64bbcd781 in QMetaObject::activate (sender=0xea75160, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#22 0x00007fa64a3ee97d in Akonadi::EntityCache<Akonadi::Collection, Akonadi::CollectionFetchJob, Akonadi::CollectionFetchScope>::processResult (this=0xea75160, job=<optimized out>) at ../../akonadi/entitycache_p.h:200
#23 0x00007fa64bbcd781 in QMetaObject::activate (sender=0x14bf2e80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4ec70e80) at kernel/qobject.cpp:3547
#24 0x00007fa64c045e72 in KJob::result (this=<optimized out>, _t1=0x14bf2e80) at ./kjob.moc:208
#25 0x00007fa64c045eb0 in KJob::emitResult (this=0x14bf2e80) at ../../kdecore/jobs/kjob.cpp:318
#26 0x00007fa64bbd2946 in QObject::event (this=0x14bf2e80, e=<optimized out>) at kernel/qobject.cpp:1195
#27 0x00007fa64c5b87b4 in notify_helper (e=0x1d51c020, receiver=0x14bf2e80, this=0x128ec40) at kernel/qapplication.cpp:4556
#28 QApplicationPrivate::notify_helper (this=0x128ec40, receiver=0x14bf2e80, e=0x1d51c020) at kernel/qapplication.cpp:4528
#29 0x00007fa64c5bd583 in QApplication::notify (this=0x7fff4ec71810, receiver=0x14bf2e80, e=0x1d51c020) at kernel/qapplication.cpp:4417
#30 0x00007fa64d2f0e36 in KApplication::notify (this=0x7fff4ec71810, receiver=0x14bf2e80, event=0x1d51c020) at ../../kdeui/kernel/kapplication.cpp:311
#31 0x00007fa64bbb932c in QCoreApplication::notifyInternal (this=0x7fff4ec71810, receiver=0x14bf2e80, event=0x1d51c020) at kernel/qcoreapplication.cpp:915
#32 0x00007fa64bbbd10a in sendEvent (event=0x1d51c020, receiver=0x14bf2e80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x12552e0) at kernel/qcoreapplication.cpp:1539
#34 0x00007fa64bbe8493 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#35 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#36 0x00007fa645707d13 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007fa645708060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007fa645708124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007fa64bbe88bf in QEventDispatcherGlib::processEvents (this=0x12567a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#40 0x00007fa64c660cde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007fa64bbb7e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007fa64bbb80b7 in QEventLoop::exec (this=0x7fff4ec717a0, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007fa64bbbd407 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#44 0x00000000004035c9 in ?? ()
#45 0x00007fa64b39f76d in __libc_start_main (main=0x402ae0, argc=1, ubp_av=0x7fff4ec71e38, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff4ec71e28) at libc-start.c:226
#46 0x0000000000403b31 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 323433.

Possible duplicates by query: bug 323433.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-11-19 14:18:02 UTC
*** Bug 323433 has been marked as a duplicate of this bug. ***
Comment 2 Jekyll Wu 2013-11-21 01:07:27 UTC

*** This bug has been marked as a duplicate of bug 327878 ***
Comment 3 Jekyll Wu 2013-12-22 01:31:50 UTC
*** Bug 329099 has been marked as a duplicate of this bug. ***
Comment 4 Jekyll Wu 2014-03-29 07:44:33 UTC
*** Bug 332620 has been marked as a duplicate of this bug. ***