Bug 328425 - Korganier crash just after insert google calendar event
Summary: Korganier crash just after insert google calendar event
Status: RESOLVED DUPLICATE of bug 327878
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.11.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-04 16:34 UTC by Filippo Ruggeri
Modified: 2013-12-06 01:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filippo Ruggeri 2013-12-04 16:34:11 UTC
Application: kontact (4.11.2)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-14-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed: i just inserted 2 new event in a google calendar, pressing the button "previous week" and krash!

- Custom settings of the application: using a google calendar

The crash can be reproduced sometimes.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f26e0bae800 (LWP 3561))]

Thread 6 (Thread 0x7f26c0afc700 (LWP 3562)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f26db9971cd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f26db997209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f26d80c1f6e in start_thread (arg=0x7f26c0afc700) at pthread_create.c:311
#4  0x00007f26de1249cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7f26801f9700 (LWP 3563)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f26db6d7bbd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f26db9c6a76 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f26d80c1f6e in start_thread (arg=0x7f26801f9700) at pthread_create.c:311
#4  0x00007f26de1249cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f2670a0f700 (LWP 3569)):
#0  __GI___pthread_mutex_lock (mutex=0x7f265c000a60) at pthread_mutex_lock.c:50
#1  0x00007f26d7c293a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f26d7be9286 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f26d7be9708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f26d7be97ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f26de89da76 in QEventDispatcherGlib::processEvents (this=0x7f265c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f26de86f5ef in QEventLoop::processEvents (this=this@entry=0x7f2670a0ed30, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f26de86f8e5 in QEventLoop::exec (this=this@entry=0x7f2670a0ed30, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f26de76e88f in QThread::exec (this=this@entry=0x31e9810) at thread/qthread.cpp:542
#9  0x00007f26de850d13 in QInotifyFileSystemWatcherEngine::run (this=0x31e9810) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f26de770f2f in QThreadPrivate::start (arg=0x31e9810) at thread/qthread_unix.cpp:338
#11 0x00007f26d80c1f6e in start_thread (arg=0x7f2670a0f700) at pthread_create.c:311
#12 0x00007f26de1249cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f266f083700 (LWP 3577)):
#0  0x00007f26de117f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f26d7be96a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f26d7be97ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f26de89da76 in QEventDispatcherGlib::processEvents (this=0x7f26540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f26de86f5ef in QEventLoop::processEvents (this=this@entry=0x7f266f082d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f26de86f8e5 in QEventLoop::exec (this=this@entry=0x7f266f082d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f26de76e88f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f26de770f2f in QThreadPrivate::start (arg=0x288c610) at thread/qthread_unix.cpp:338
#8  0x00007f26d80c1f6e in start_thread (arg=0x7f266f083700) at pthread_create.c:311
#9  0x00007f26de1249cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f266953c700 (LWP 6140)):
#0  0x00007f26d7c293c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f26d7be8fbb in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f26d7be9612 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f26d7be97ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f26de89da76 in QEventDispatcherGlib::processEvents (this=0x7f265801d4e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f26de86f5ef in QEventLoop::processEvents (this=this@entry=0x7f266953bd30, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f26de86f8e5 in QEventLoop::exec (this=this@entry=0x7f266953bd30, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f26de76e88f in QThread::exec (this=this@entry=0x10b7a9d0) at thread/qthread.cpp:542
#8  0x00007f26de850d13 in QInotifyFileSystemWatcherEngine::run (this=0x10b7a9d0) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f26de770f2f in QThreadPrivate::start (arg=0x10b7a9d0) at thread/qthread_unix.cpp:338
#10 0x00007f26d80c1f6e in start_thread (arg=0x7f266953c700) at pthread_create.c:311
#11 0x00007f26de1249cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f26e0bae800 (LWP 3561)):
[KCrash Handler]
#6  KCalCore::Incidence::hasRecurrenceId (this=0x0) at ../../kcalcore/incidence.cpp:1035
#7  0x00007f26508aa4c2 in EventViews::AgendaView::displayIncidence (this=this@entry=0x7ae1a50, aitem=..., createSelected=createSelected@entry=true) at ../../calendarviews/agenda/agendaview.cpp:1664
#8  0x00007f26508b0316 in EventViews::AgendaView::fillAgenda (this=this@entry=0x7ae1a50) at ../../calendarviews/agenda/agendaview.cpp:1636
#9  0x00007f26508b099a in EventViews::AgendaView::showDates (this=this@entry=0x7ae1a50, start=..., end=..., preferredMonth=...) at ../../calendarviews/agenda/agendaview.cpp:1533
#10 0x00007f265087f218 in EventViews::EventView::setDateRange (this=0x7ae1a50, start=..., end=..., preferredMonth=...) at ../../calendarviews/eventview.cpp:294
#11 0x00007f2650c49301 in KOAgendaView::setDateRange (this=<optimized out>, start=..., end=...) at ../../korganizer/views/agendaview/koagendaview.cpp:331
#12 0x00007f2650c0b5c7 in KOViewManager::updateView (this=0x6b670c0, start=..., end=..., preferredMonth=...) at ../../korganizer/koviewmanager.cpp:277
#13 0x00007f2650bcf6bb in CalendarView::updateView (this=0x7a7f6b0, start=..., end=..., preferredMonth=..., updateTodos=<optimized out>) at ../../korganizer/calendarview.cpp:778
#14 0x00007f2650be4213 in CalendarView::qt_static_metacall (_o=0x7a7f6b0, _c=QMetaObject::ReadProperty, _id=-566315112, _a=0x7f26de3eb748 <main_arena+8>) at ./calendarview.moc:572
#15 0x00007f26de884a58 in QMetaObject::activate (sender=sender@entry=0x3a39eb0, m=m@entry=0x7f2650ea2ec0 <DateNavigator::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff444b8390) at kernel/qobject.cpp:3539
#16 0x00007f2650be8a67 in DateNavigator::datesSelected (this=this@entry=0x3a39eb0, _t1=..., _t2=...) at ./datenavigator.moc:185
#17 0x00007f2650be8bee in emitSelected (preferredMonth=..., this=0x3a39eb0) at ../../korganizer/datenavigator.cpp:312
#18 DateNavigator::selectDates (this=this@entry=0x3a39eb0, d=..., count=count@entry=7, preferredMonth=...) at ../../korganizer/datenavigator.cpp:94
#19 0x00007f2650be8fcf in DateNavigator::selectPrevious (this=0x3a39eb0) at ../../korganizer/datenavigator.cpp:265
#20 0x00007f2650bcf534 in CalendarView::goPrevious (this=0x7a7f6b0) at ../../korganizer/calendarview.cpp:566
#21 0x00007f2650be430e in CalendarView::qt_static_metacall (_o=0x7a7f6b0, _c=QMetaObject::ReadProperty, _id=-566315112, _a=0x7f26de3eb748 <main_arena+8>) at ./calendarview.moc:555
#22 0x00007f26de884a58 in QMetaObject::activate (sender=sender@entry=0x78c67e0, m=m@entry=0x7f26dfd0ade0 <QAction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff444b8640) at kernel/qobject.cpp:3539
#23 0x00007f26df25ba32 in QAction::triggered (this=this@entry=0x78c67e0, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#24 0x00007f26df25d403 in QAction::activate (this=0x78c67e0, event=<optimized out>) at kernel/qaction.cpp:1257
#25 0x00007f26df6140a2 in QAbstractButtonPrivate::click (this=this@entry=0x12e25970) at widgets/qabstractbutton.cpp:530
#26 0x00007f26df6141cc in QAbstractButton::mouseReleaseEvent (this=0x118428c0, e=0x7fff444b8b40) at widgets/qabstractbutton.cpp:1123
#27 0x00007f26df6cad9a in QToolButton::mouseReleaseEvent (this=<optimized out>, e=<optimized out>) at widgets/qtoolbutton.cpp:718
#28 0x00007f26df2b131e in QWidget::event (this=0x118428c0, event=0x7fff444b8b40) at kernel/qwidget.cpp:8375
#29 0x00007f26df261dfc in QApplicationPrivate::notify_helper (this=this@entry=0x25c7440, receiver=receiver@entry=0x118428c0, e=e@entry=0x7fff444b8b40) at kernel/qapplication.cpp:4567
#30 0x00007f26df2685ad in QApplication::notify (this=this@entry=0x7fff444b93a0, receiver=receiver@entry=0x118428c0, e=e@entry=0x7fff444b8b40) at kernel/qapplication.cpp:4110
#31 0x00007f26dff6ba6a in KApplication::notify (this=0x7fff444b93a0, receiver=0x118428c0, event=0x7fff444b8b40) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007f26de8708bd in QCoreApplication::notifyInternal (this=0x7fff444b93a0, receiver=receiver@entry=0x118428c0, event=event@entry=0x7fff444b8b40) at kernel/qcoreapplication.cpp:946
#33 0x00007f26df267d63 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x118428c0, event=event@entry=0x7fff444b8b40, alienWidget=alienWidget@entry=0x118428c0, nativeWidget=nativeWidget@entry=0x27d5a50, buttonDown=buttonDown@entry=0x7f26dfd462f8 <qt_button_down>, lastMouseReceiver=..., spontaneous=spontaneous@entry=true) at kernel/qapplication.cpp:3178
#35 0x00007f26df2dc7db in QETWidget::translateMouseEvent (this=this@entry=0x27d5a50, event=event@entry=0x7fff444b8ec0) at kernel/qapplication_x11.cpp:4631
#36 0x00007f26df2dc079 in QApplication::x11ProcessEvent (this=0x7fff444b93a0, event=event@entry=0x7fff444b8ec0) at kernel/qapplication_x11.cpp:3624
#37 0x00007f26df303922 in x11EventSourceDispatch (s=0x25c7b60, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#38 0x00007f26d7be93b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f26d7be9708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f26d7be97ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f26de89da76 in QEventDispatcherGlib::processEvents (this=0x2586690, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#42 0x00007f26df3039d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f26de86f5ef in QEventLoop::processEvents (this=this@entry=0x7fff444b92a0, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f26de86f8e5 in QEventLoop::exec (this=this@entry=0x7fff444b92a0, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f26de874e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#46 0x00007f26df26034c in QApplication::exec () at kernel/qapplication.cpp:3828
#47 0x0000000000403660 in main (argc=1, argv=0x7fff444b94e8) at ../../../kontact/src/main.cpp:219

The reporter indicates this bug may be a duplicate of or related to bug 327878.

Possible duplicates by query: bug 327878, bug 327796, bug 323433.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-12-06 01:44:58 UTC

*** This bug has been marked as a duplicate of bug 327878 ***