Bug 328931 - Muon updater crashes after changing advanced settings, then reloading software lists
Summary: Muon updater crashes after changing advanced settings, then reloading softwar...
Status: RESOLVED DUPLICATE of bug 327544
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-17 22:23 UTC by Jesse Burt
Modified: 2016-03-02 13:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Burt 2013-12-17 22:23:31 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-14-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:
Opened Muon updater, clicked 'More' button > Advanced > Configure Software sources. Entered password. Checked 'Source Code' box on Kubuntu Software tab. Checked 'Pre-released updates' box on Updates tab. Clicked Close button. Muon went to reload repository information and crashed (didn't happen to notice if it was right away or a few seconds after starting to refresh the software lists).

- Custom settings of the application:

Software sources > Kubuntu Software > Source Code box checked
Software sources > Updates > Pre-released updates box checked

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb7c9fc17c0 (LWP 2044))]

Thread 3 (Thread 0x7fb7b711c700 (LWP 2045)):
#0  0x00007fb7c4e7b055 in __GI___pthread_mutex_lock (mutex=0x7fb7b0000a60) at pthread_mutex_lock.c:95
#1  0x00007fb7c49e03a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb7c49a0286 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb7c49a0708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb7c49a07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fb7c7d99a76 in QEventDispatcherGlib::processEvents (this=0x7fb7b00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fb7c7d6b5ef in QEventLoop::processEvents (this=this@entry=0x7fb7b711bd70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fb7c7d6b8e5 in QEventLoop::exec (this=this@entry=0x7fb7b711bd70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fb7c7c6a88f in QThread::exec (this=this@entry=0x1210bc0) at thread/qthread.cpp:542
#9  0x00007fb7c7d4cd13 in QInotifyFileSystemWatcherEngine::run (this=0x1210bc0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007fb7c7c6cf2f in QThreadPrivate::start (arg=0x1210bc0) at thread/qthread_unix.cpp:338
#11 0x00007fb7c4e78f6e in start_thread (arg=0x7fb7b711c700) at pthread_create.c:311
#12 0x00007fb7c76209cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fb7a708d700 (LWP 2098)):
#0  0x00007fb7c7613f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb7c49a06a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb7c49a07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb7c7d99a76 in QEventDispatcherGlib::processEvents (this=0x7fb7980008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fb7c7d6b5ef in QEventLoop::processEvents (this=this@entry=0x7fb7a708cd70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb7c7d6b8e5 in QEventLoop::exec (this=this@entry=0x7fb7a708cd70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb7c7c6a88f in QThread::exec (this=this@entry=0x158b980) at thread/qthread.cpp:542
#7  0x00007fb7c7d4cd13 in QInotifyFileSystemWatcherEngine::run (this=0x158b980) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007fb7c7c6cf2f in QThreadPrivate::start (arg=0x158b980) at thread/qthread_unix.cpp:338
#9  0x00007fb7c4e78f6e in start_thread (arg=0x7fb7a708d700) at pthread_create.c:311
#10 0x00007fb7c76209cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fb7c9fc17c0 (LWP 2044)):
[KCrash Handler]
#6  UpdateModel::setResources (this=0x1438600, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x13b8980) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0x13b8980) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#10 0x00007fb7c7d80a58 in QMetaObject::activate (sender=0x11b98e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007fb7c7d80a58 in QMetaObject::activate (sender=sender@entry=0x1602f70, m=m@entry=0x7fb7c9dd0380 <AbstractBackendUpdater::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff7c573600) at kernel/qobject.cpp:3539
#12 0x00007fb7c9ba9a72 in AbstractBackendUpdater::progressingChanged (this=this@entry=0x1602f70, _t1=false) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractBackendUpdater.cpp:190
#13 0x00007fb7b547709c in ApplicationUpdates::setProgressing (this=0x1602f70, progressing=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:371
#14 0x00007fb7c7d80a58 in QMetaObject::activate (sender=sender@entry=0x16016a0, m=m@entry=0x7fb7c9dd03c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#15 0x00007fb7c9ba9940 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x16016a0) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#16 0x00007fb7b5469e93 in ApplicationBackend::setFetching (this=0x16016a0, f=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:643
#17 0x00007fb7b546c4c3 in ApplicationBackend::reload (this=0x16016a0) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#18 0x00007fb7b5477154 in ApplicationUpdates::transactionFinished (this=0x1602f70) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#19 0x00007fb7c7d80a58 in QMetaObject::activate (sender=0x17557c0, m=m@entry=0x7fb7b4e039c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff7c5738c0) at kernel/qobject.cpp:3539
#20 0x00007fb7b4bee441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#21 0x00007fb7b4be11af in QApt::Transaction::updateProperty (this=0x17557c0, type=0, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#22 0x00007fb7b4bee974 in QApt::Transaction::qt_static_metacall (_o=0x17557c0, _c=<optimized out>, _id=<optimized out>, _a=0x7fff7c573ae0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#23 0x00007fb7c7d80a58 in QMetaObject::activate (sender=sender@entry=0x1bc2240, m=m@entry=0x7fb7b4e03aa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff7c573ae0) at kernel/qobject.cpp:3539
#24 0x00007fb7b4bef3d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x1bc2240, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#25 0x00007fb7b4bef77c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x1bc2240, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff7c573da0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#26 0x00007fb7b4bf00f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x1bc2240, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff7c573da0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#27 0x00007fb7c6e1de36 in QDBusConnectionPrivate::deliverCall (this=0x120fc80, object=0x1bc2240, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#28 0x00007fb7c7d84dce in QObject::event (this=0x1bc2240, e=<optimized out>) at kernel/qobject.cpp:1194
#29 0x00007fb7c875ddfc in QApplicationPrivate::notify_helper (this=this@entry=0x108d960, receiver=receiver@entry=0x1bc2240, e=e@entry=0x112f350) at kernel/qapplication.cpp:4567
#30 0x00007fb7c8764470 in QApplication::notify (this=this@entry=0x7fff7c574550, receiver=receiver@entry=0x1bc2240, e=e@entry=0x112f350) at kernel/qapplication.cpp:4353
#31 0x00007fb7c9467a6a in KApplication::notify (this=0x7fff7c574550, receiver=0x1bc2240, event=0x112f350) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007fb7c7d6c8bd in QCoreApplication::notifyInternal (this=0x7fff7c574550, receiver=receiver@entry=0x1bc2240, event=event@entry=0x112f350) at kernel/qcoreapplication.cpp:946
#33 0x00007fb7c7d6fe1f in sendEvent (event=0x112f350, receiver=0x1bc2240) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1057500) at kernel/qcoreapplication.cpp:1570
#35 0x00007fb7c7d702c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#36 0x00007fb7c7d9a073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#37 postEventSourceDispatch (s=0x1087340) at kernel/qeventdispatcher_glib.cpp:279
#38 0x00007fb7c49a03b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007fb7c49a0708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007fb7c49a07ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007fb7c7d99a55 in QEventDispatcherGlib::processEvents (this=0x1058de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#42 0x00007fb7c87ff9d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007fb7c7d6b5ef in QEventLoop::processEvents (this=this@entry=0x7fff7c574450, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007fb7c7d6b8e5 in QEventLoop::exec (this=this@entry=0x7fff7c574450, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007fb7c7d70e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#46 0x00007fb7c875c34c in QApplication::exec () at kernel/qapplication.cpp:3828
#47 0x000000000040ce11 in main (argc=5, argv=0x7fff7c574688) at /build/buildd/muon-2.1.1/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 327544.

Possible duplicates by query: bug 328875, bug 328633, bug 328536, bug 328475, bug 328269.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-12-18 01:40:46 UTC

*** This bug has been marked as a duplicate of bug 327544 ***