Bug 328633 - Muon Updater crashed
Summary: Muon Updater crashed
Status: RESOLVED DUPLICATE of bug 327544
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-10 18:00 UTC by ATILIUS
Modified: 2016-03-02 13:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ATILIUS 2013-12-10 18:00:56 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

Nothing special, just started Muan Updater and run search for updates.

-- Backtrace:
Application: Muon-Aktualisierungsverwaltung (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1ec3a2d7c0 (LWP 14629))]

Thread 3 (Thread 0x7f1eb0c21700 (LWP 14630)):
#0  0x00007f1ebe41eb3c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1ebe420ceb in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1ebe4215c3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1ebe4217ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1ec181aa76 in QEventDispatcherGlib::processEvents (this=0x7f1eac0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f1ec17ec5ef in QEventLoop::processEvents (this=this@entry=0x7f1eb0c20d70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f1ec17ec8e5 in QEventLoop::exec (this=this@entry=0x7f1eb0c20d70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f1ec16eb88f in QThread::exec (this=this@entry=0xa022d0) at thread/qthread.cpp:542
#8  0x00007f1ec17cdd13 in QInotifyFileSystemWatcherEngine::run (this=0xa022d0) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f1ec16edf2f in QThreadPrivate::start (arg=0xa022d0) at thread/qthread_unix.cpp:338
#10 0x00007f1ebe8f9f6e in start_thread (arg=0x7f1eb0c21700) at pthread_create.c:311
#11 0x00007f1ec10a19cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f1ea083b700 (LWP 14690)):
#0  0x00007f1ec1094f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1ebe4216a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1ebe4217ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1ec181aa76 in QEventDispatcherGlib::processEvents (this=0x7f1e9c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f1ec17ec5ef in QEventLoop::processEvents (this=this@entry=0x7f1ea083ad70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1ec17ec8e5 in QEventLoop::exec (this=this@entry=0x7f1ea083ad70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f1ec16eb88f in QThread::exec (this=this@entry=0x11bf790) at thread/qthread.cpp:542
#7  0x00007f1ec17cdd13 in QInotifyFileSystemWatcherEngine::run (this=0x11bf790) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f1ec16edf2f in QThreadPrivate::start (arg=0x11bf790) at thread/qthread_unix.cpp:338
#9  0x00007f1ebe8f9f6e in start_thread (arg=0x7f1ea083b700) at pthread_create.c:311
#10 0x00007f1ec10a19cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f1ec3a2d7c0 (LWP 14629)):
[KCrash Handler]
#6  UpdateModel::setResources (this=0xb2e2f0, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0xb2d140) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0xb2d140) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#10 0x00007f1ec1801a58 in QMetaObject::activate (sender=0x800140, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007f1ec1801a58 in QMetaObject::activate (sender=sender@entry=0xd18680, m=m@entry=0x7f1ec3851380 <AbstractBackendUpdater::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff2ba30710) at kernel/qobject.cpp:3539
#12 0x00007f1ec362aa72 in AbstractBackendUpdater::progressingChanged (this=this@entry=0xd18680, _t1=false) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractBackendUpdater.cpp:190
#13 0x00007f1eaad1d09c in ApplicationUpdates::setProgressing (this=0xd18680, progressing=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:371
#14 0x00007f1ec1801a58 in QMetaObject::activate (sender=sender@entry=0xd14f30, m=m@entry=0x7f1ec38513c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#15 0x00007f1ec362a940 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0xd14f30) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#16 0x00007f1eaad0fe93 in ApplicationBackend::setFetching (this=0xd14f30, f=<optimized out>) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:643
#17 0x00007f1eaad124c3 in ApplicationBackend::reload (this=0xd14f30) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#18 0x00007f1eaad1d154 in ApplicationUpdates::transactionFinished (this=0xd18680) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#19 0x00007f1ec1801a58 in QMetaObject::activate (sender=0xc399e0, m=m@entry=0x7f1eaa6a99c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fff2ba309d0) at kernel/qobject.cpp:3539
#20 0x00007f1eaa494441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#21 0x00007f1eaa4871af in QApt::Transaction::updateProperty (this=0xc399e0, type=0, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#22 0x00007f1eaa494974 in QApt::Transaction::qt_static_metacall (_o=0xc399e0, _c=<optimized out>, _id=<optimized out>, _a=0x7fff2ba30bf0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#23 0x00007f1ec1801a58 in QMetaObject::activate (sender=sender@entry=0x219e680, m=m@entry=0x7f1eaa6a9aa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff2ba30bf0) at kernel/qobject.cpp:3539
#24 0x00007f1eaa4953d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x219e680, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#25 0x00007f1eaa49577c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x219e680, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7fff2ba30eb0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#26 0x00007f1eaa4960f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x219e680, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff2ba30eb0) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#27 0x00007f1ec089ee36 in QDBusConnectionPrivate::deliverCall (this=0x9cbff0, object=0x219e680, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#28 0x00007f1ec1805dce in QObject::event (this=0x219e680, e=<optimized out>) at kernel/qobject.cpp:1194
#29 0x00007f1ec21dedfc in QApplicationPrivate::notify_helper (this=this@entry=0x7fb5d0, receiver=receiver@entry=0x219e680, e=e@entry=0x248f370) at kernel/qapplication.cpp:4567
#30 0x00007f1ec21e5470 in QApplication::notify (this=this@entry=0x7fff2ba31660, receiver=receiver@entry=0x219e680, e=e@entry=0x248f370) at kernel/qapplication.cpp:4353
#31 0x00007f1ec2ee8a6a in KApplication::notify (this=0x7fff2ba31660, receiver=0x219e680, event=0x248f370) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007f1ec17ed8bd in QCoreApplication::notifyInternal (this=0x7fff2ba31660, receiver=receiver@entry=0x219e680, event=event@entry=0x248f370) at kernel/qcoreapplication.cpp:946
#33 0x00007f1ec17f0e1f in sendEvent (event=0x248f370, receiver=0x219e680) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x7c3500) at kernel/qcoreapplication.cpp:1570
#35 0x00007f1ec17f12c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#36 0x00007f1ec181b073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#37 postEventSourceDispatch (s=0x7f2ac0) at kernel/qeventdispatcher_glib.cpp:279
#38 0x00007f1ebe4213b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f1ebe421708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f1ebe4217ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f1ec181aa55 in QEventDispatcherGlib::processEvents (this=0x7c4de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#42 0x00007f1ec22809d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f1ec17ec5ef in QEventLoop::processEvents (this=this@entry=0x7fff2ba31560, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f1ec17ec8e5 in QEventLoop::exec (this=this@entry=0x7fff2ba31560, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f1ec17f1e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#46 0x00007f1ec21dd34c in QApplication::exec () at kernel/qapplication.cpp:3828
#47 0x000000000040ce11 in main (argc=5, argv=0x7fff2ba31798) at /build/buildd/muon-2.1.1/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 327544.

Possible duplicates by query: bug 328536, bug 328475, bug 328269, bug 328088, bug 327761.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-12-11 13:55:17 UTC

*** This bug has been marked as a duplicate of bug 327544 ***