Bug 328269 - Muon Software Updater crashes after being launched from tray notification
Summary: Muon Software Updater crashes after being launched from tray notification
Status: RESOLVED DUPLICATE of bug 327544
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-01 05:50 UTC by automaticjack
Modified: 2016-03-02 13:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.16 KB, text/plain)
2013-12-01 05:52 UTC, automaticjack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description automaticjack 2013-12-01 05:50:19 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

I was doing some 3D Printing work.
Then I noticed the update notification in the system tray.
Then i clicked on the update notification in the system tray.
Then the Muon Software Updater popped up.
Then (give or take 10s) it crashed.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff431ff87c0 (LWP 7774))]

Thread 3 (Thread 0x7ff41f160700 (LWP 7776)):
#0  0x00007ff42c9e478e in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff42fddda76 in QEventDispatcherGlib::processEvents (this=0x7ff4180008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#2  0x00007ff42fdaf5ef in QEventLoop::processEvents (this=this@entry=0x7ff41f15fd70, flags=...) at kernel/qeventloop.cpp:149
#3  0x00007ff42fdaf8e5 in QEventLoop::exec (this=this@entry=0x7ff41f15fd70, flags=...) at kernel/qeventloop.cpp:204
#4  0x00007ff42fcae88f in QThread::exec (this=this@entry=0x20bb450) at thread/qthread.cpp:542
#5  0x00007ff42fd90d13 in QInotifyFileSystemWatcherEngine::run (this=0x20bb450) at io/qfilesystemwatcher_inotify.cpp:265
#6  0x00007ff42fcb0f2f in QThreadPrivate::start (arg=0x20bb450) at thread/qthread_unix.cpp:338
#7  0x00007ff42cebcf6e in start_thread (arg=0x7ff41f160700) at pthread_create.c:311
#8  0x00007ff42f6649cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7ff416583700 (LWP 7985)):
#0  0x00007ff42f657f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ff42c9e46a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff42c9e47ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff42fddda76 in QEventDispatcherGlib::processEvents (this=0x7ff4080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff42fdaf5ef in QEventLoop::processEvents (this=this@entry=0x7ff416582d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff42fdaf8e5 in QEventLoop::exec (this=this@entry=0x7ff416582d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff42fcae88f in QThread::exec (this=this@entry=0x27e5b90) at thread/qthread.cpp:542
#7  0x00007ff42fd90d13 in QInotifyFileSystemWatcherEngine::run (this=0x27e5b90) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007ff42fcb0f2f in QThreadPrivate::start (arg=0x27e5b90) at thread/qthread_unix.cpp:338
#9  0x00007ff42cebcf6e in start_thread (arg=0x7ff416583700) at pthread_create.c:311
#10 0x00007ff42f6649cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7ff431ff87c0 (LWP 7774)):
[KCrash Handler]
#6  UpdateModel::setResources (this=0x2217000, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x20d6c60) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0x20d6c60) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#10 0x00007ff42fdc4a58 in QMetaObject::activate (sender=0x2025330, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007ff431bee485 in ResourcesModel::qt_static_metacall (_o=0x2025330, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90
#12 0x00007ff42fdc4a58 in QMetaObject::activate (sender=sender@entry=0x2025330, m=m@entry=0x7ff431e14180 <ResourcesModel::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#13 0x00007ff431bee1f3 in ResourcesModel::allInitialized (this=this@entry=0x2025330) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:184
#14 0x00007ff431bfb907 in ResourcesModel::resetBackend (this=0x2025330, backend=0x23b9ce0) at /build/buildd/muon-2.1.1/libmuon/resources/ResourcesModel.cpp:269
#15 0x00007ff431bee595 in ResourcesModel::qt_static_metacall (_o=0x2025330, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:101
#16 0x00007ff42fdc4a58 in QMetaObject::activate (sender=0x23b9ce0, m=m@entry=0x7ff431e143c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007ff431bed940 in AbstractResourcesBackend::fetchingChanged (this=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007ff41e58890f in KNSBackend::setFetching (this=<optimized out>, f=f@entry=false) at /build/buildd/muon-2.1.1/libmuon/backends/KNSBackend/KNSBackend.cpp:112
#19 0x00007ff41e588c97 in KNSBackend::receivedEntries (this=0x23b9ce0, entries=...) at /build/buildd/muon-2.1.1/libmuon/backends/KNSBackend/KNSBackend.cpp:186
#20 0x00007ff42fdc4a58 in QMetaObject::activate (sender=0x23a6f00, m=m@entry=0x7ff41e57c2c0 <KNS3::DownloadManager::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffe55b08f0) at kernel/qobject.cpp:3539
#21 0x00007ff41e32ffd2 in KNS3::DownloadManager::searchResult (this=<optimized out>, _t1=...) at ./downloadmanager.moc:113
#22 0x00007ff41e33014a in KNS3::DownloadManager::Private::_k_slotEntriesLoaded (this=0x23b0370, entries=...) at ../../../knewstuff/knewstuff3/downloadmanager.cpp:117
#23 0x00007ff42fdc4a58 in QMetaObject::activate (sender=sender@entry=0x1ee7d50, m=m@entry=0x7ff41e57c740 <KNS3::Engine::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7fffe55b0a90) at kernel/qobject.cpp:3539
#24 0x00007ff41e33770b in signalEntriesLoaded (_t1=..., this=0x1ee7d50) at ./engine.moc:199
#25 KNS3::Engine::slotEntriesLoaded (this=0x1ee7d50, request=..., entries=...) at ../../../knewstuff/knewstuff3/core/engine.cpp:280
#26 0x00007ff41e339f36 in KNS3::Engine::qt_static_metacall (_o=0x1ee7d50, _id=0, _a=0x0, _c=<optimized out>) at ./engine.moc:129
#27 0x00007ff42fdc4a58 in QMetaObject::activate (sender=sender@entry=0x25ac200, m=m@entry=0x7ff41e57c960 <KNS3::Provider::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fffe55b0c30) at kernel/qobject.cpp:3539
#28 0x00007ff41e3456ba in KNS3::Provider::loadingFinished (this=this@entry=0x25ac200, _t1=..., _t2=...) at ./provider.moc:125
#29 0x00007ff41e35a4bb in KNS3::AtticaProvider::categoryContentsLoaded (this=0x25ac200, job=<optimized out>) at ../../../knewstuff/knewstuff3/attica/atticaprovider.cpp:230
#30 0x00007ff42fdc4a58 in QMetaObject::activate (sender=0x37e8db0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe55b0e40) at kernel/qobject.cpp:3539
#31 0x00007ff42df2730f in Attica::BaseJob::finished(Attica::BaseJob*) () from /usr/lib/x86_64-linux-gnu/libattica.so.0.4
#32 0x00007ff42df274e9 in Attica::BaseJob::dataFinished() () from /usr/lib/x86_64-linux-gnu/libattica.so.0.4
#33 0x00007ff42fdc4a58 in QMetaObject::activate (sender=0x37ec730, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#34 0x00007ff42fdb8bf8 in QMetaMethod::invoke (this=this@entry=0x7fffe55b1350, object=object@entry=0x37ec730, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#35 0x00007ff42fdbb0b8 in QMetaObject::invokeMethod (obj=obj@entry=0x37ec730, member=member@entry=0x7ff4253e3645 "finished", type=type@entry=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#36 0x00007ff42527bbbc in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., type=Qt::AutoConnection, member=0x7ff4253e3645 "finished", obj=0x37ec730) at /usr/include/qt4/QtCore/qobjectdefs.h:418
#37 KDEPrivate::AccessManagerReply::emitFinished (this=this@entry=0x37ec730, state=state@entry=true, type=type@entry=Qt::AutoConnection) at ../../kio/kio/accessmanagerreply_p.cpp:484
#38 0x00007ff42527d840 in KDEPrivate::AccessManagerReply::slotResult (this=0x37ec730, kJob=0x3aa08a0) at ../../kio/kio/accessmanagerreply_p.cpp:427
#39 0x00007ff42fdc4a58 in QMetaObject::activate (sender=sender@entry=0x3aa08a0, m=m@entry=0x7ff4305c9600 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fffe55b1840) at kernel/qobject.cpp:3539
#40 0x00007ff4302390c2 in KJob::result (this=this@entry=0x3aa08a0, _t1=_t1@entry=0x3aa08a0) at ./kjob.moc:208
#41 0x00007ff430239100 in KJob::emitResult (this=this@entry=0x3aa08a0) at ../../kdecore/jobs/kjob.cpp:318
#42 0x00007ff4252b7e3a in KIO::SimpleJob::slotFinished (this=this@entry=0x3aa08a0) at ../../kio/kio/job.cpp:496
#43 0x00007ff4252b8f8e in KIO::TransferJob::slotFinished (this=0x3aa08a0) at ../../kio/kio/job.cpp:1099
#44 0x00007ff42fdc4a58 in QMetaObject::activate (sender=0x2565d10, m=m@entry=0x7ff425661580 <KIO::SlaveInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#45 0x00007ff425355d33 in KIO::SlaveInterface::finished (this=<optimized out>) at ./slaveinterface.moc:185
#46 0x00007ff425357276 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:176
#47 0x00007ff425354d6e in KIO::SlaveInterface::dispatch (this=0x2565d10) at ../../kio/kio/slaveinterface.cpp:92
#48 0x00007ff4253499d6 in KIO::Slave::gotInput (this=0x2565d10) at ../../kio/kio/slave.cpp:344
#49 0x00007ff42fdc4a58 in QMetaObject::activate (sender=0x2615aa0, m=m@entry=0x7ff42565aaa0 <KIO::Connection::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#50 0x00007ff4252851e0 in KIO::Connection::readyRead (this=<optimized out>) at ./connection.moc:106
#51 0x00007ff4252858d1 in KIO::ConnectionPrivate::dequeue (this=0x2632a00) at ../../kio/kio/connection.cpp:82
#52 0x00007ff42fdc8dce in QObject::event (this=0x2615aa0, e=<optimized out>) at kernel/qobject.cpp:1194
#53 0x00007ff4307a1dfc in QApplicationPrivate::notify_helper (this=this@entry=0x1eee310, receiver=receiver@entry=0x2615aa0, e=e@entry=0x37ee610) at kernel/qapplication.cpp:4567
#54 0x00007ff4307a8470 in QApplication::notify (this=this@entry=0x7fffe55b2590, receiver=receiver@entry=0x2615aa0, e=e@entry=0x37ee610) at kernel/qapplication.cpp:4353
#55 0x00007ff4314aba6a in KApplication::notify (this=0x7fffe55b2590, receiver=0x2615aa0, event=0x37ee610) at ../../kdeui/kernel/kapplication.cpp:311
#56 0x00007ff42fdb08bd in QCoreApplication::notifyInternal (this=0x7fffe55b2590, receiver=receiver@entry=0x2615aa0, event=event@entry=0x37ee610) at kernel/qcoreapplication.cpp:946
#57 0x00007ff42fdb3e1f in sendEvent (event=0x37ee610, receiver=0x2615aa0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1ebb500) at kernel/qcoreapplication.cpp:1570
#59 0x00007ff42fdb42c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#60 0x00007ff42fdde073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#61 postEventSourceDispatch (s=0x1eec8c0) at kernel/qeventdispatcher_glib.cpp:279
#62 0x00007ff42c9e43b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#63 0x00007ff42c9e4708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#64 0x00007ff42c9e47ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#65 0x00007ff42fddda55 in QEventDispatcherGlib::processEvents (this=0x1ebcde0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#66 0x00007ff4308439d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#67 0x00007ff42fdaf5ef in QEventLoop::processEvents (this=this@entry=0x7fffe55b2490, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007ff42fdaf8e5 in QEventLoop::exec (this=this@entry=0x7fffe55b2490, flags=...) at kernel/qeventloop.cpp:204
#69 0x00007ff42fdb4e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#70 0x00007ff4307a034c in QApplication::exec () at kernel/qapplication.cpp:3828
#71 0x000000000040ce11 in main (argc=1, argv=0x7fffe55b26c8) at /build/buildd/muon-2.1.1/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 327544.

Possible duplicates by query: bug 328088, bug 327761, bug 327544.

Reported using DrKonqi
Comment 1 automaticjack 2013-12-01 05:52:53 UTC
Created attachment 83845 [details]
New crash information added by DrKonqi

muon-updater (2.1.1) on KDE Platform 4.11.2 using Qt 4.8.4

- What I was doing when the application crashed:

I was doing some 3D Printing work.
Then I noticed the update notification in the system tray.
Then i clicked on the update notification in the system tray.
Then the Muon Software Updater popped up.
Then (give or take 10s) it crashed.  
Then i repeated this whole cycle again.
Then i tried " sudo update-apt-xapian-index -f " as suguested in another bug.
Then I tried it again and it failed again.

-- Backtrace (Reduced):
#6  UpdateModel::setResources (this=0x250a0c0, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x2509b90) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0x2509b90) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
[...]
#11 0x00007f4889401485 in ResourcesModel::qt_static_metacall (_o=0x230efb0, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90
Comment 2 Jekyll Wu 2013-12-03 01:00:08 UTC

*** This bug has been marked as a duplicate of bug 327544 ***