Bug 328875 - Checking for Updates resulted in crash
Summary: Checking for Updates resulted in crash
Status: RESOLVED DUPLICATE of bug 327544
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-12-16 19:03 UTC by Haneman
Modified: 2016-03-02 13:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Haneman 2013-12-16 19:03:33 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
Ctrl+R update process started normally then around 30% the program crashed. Continues to do this when updates are searched for.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Update Manager (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb51b0740 (LWP 2488))]

Thread 3 (Thread 0xb2540b40 (LWP 2489)):
#0  0xb7773424 in __kernel_vsyscall ()
#1  0xb6013a0b in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb585fa4b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb5850b68 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5850ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63748df in QEventDispatcherGlib::processEvents (this=0xb1c00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63439f3 in QEventLoop::processEvents (this=this@entry=0xb2540228, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6343d19 in QEventLoop::exec (this=this@entry=0xb2540228, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6232e3d in QThread::exec (this=this@entry=0xa121140) at thread/qthread.cpp:542
#9  0xb6323e14 in QInotifyFileSystemWatcherEngine::run (this=0xa121140) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb623572f in QThreadPrivate::start (arg=0xa121140) at thread/qthread_unix.cpp:338
#11 0xb592ed78 in start_thread (arg=0xb2540b40) at pthread_create.c:311
#12 0xb602301e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 2 (Thread 0xae199b40 (LWP 2552)):
#0  0xb7773424 in __kernel_vsyscall ()
#1  0xb6013a0b in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb585fa4b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb5850b68 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5850ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63748df in QEventDispatcherGlib::processEvents (this=0xad800468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63439f3 in QEventLoop::processEvents (this=this@entry=0xae199228, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6343d19 in QEventLoop::exec (this=this@entry=0xae199228, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6232e3d in QThread::exec (this=this@entry=0xa8a24a8) at thread/qthread.cpp:542
#9  0xb6323e14 in QInotifyFileSystemWatcherEngine::run (this=0xa8a24a8) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb623572f in QThreadPrivate::start (arg=0xa8a24a8) at thread/qthread_unix.cpp:338
#11 0xb592ed78 in start_thread (arg=0xae199b40) at pthread_create.c:311
#12 0xb602301e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:131

Thread 1 (Thread 0xb51b0740 (LWP 2488)):
[KCrash Handler]
#7  UpdateModel::setResources (this=0xa114858, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#8  0x08056e6d in UpdaterWidget::populateUpdateModel (this=this@entry=0xa110598) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#9  0x08056f61 in UpdaterWidget::activityChanged (this=0xa110598) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#10 0x08052658 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-i686-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#11 0xb6359fc7 in QMetaObject::activate (sender=sender@entry=0xa0a57a0, m=m@entry=0xb7753a90 <ResourcesUpdatesModel::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#12 0xb7729875 in ResourcesUpdatesModel::progressingChanged (this=0xa0a57a0) at /build/buildd/muon-2.1.1/obj-i686-linux-gnu/libmuon/moc_ResourcesUpdatesModel.cpp:198
#13 0xb77299a8 in ResourcesUpdatesModel::qt_static_metacall (_o=0x0, _id=1, _a=0xbf825488, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-i686-linux-gnu/libmuon/moc_ResourcesUpdatesModel.cpp:92
#14 0xb6359fc7 in QMetaObject::activate (sender=sender@entry=0xa1a7d70, m=m@entry=0xb77539e8 <AbstractBackendUpdater::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0xbf825488) at kernel/qobject.cpp:3539
#15 0xb772a42d in AbstractBackendUpdater::progressingChanged (this=this@entry=0xa1a7d70, _t1=false) at /build/buildd/muon-2.1.1/obj-i686-linux-gnu/libmuon/moc_AbstractBackendUpdater.cpp:190
#16 0xb0fe93a1 in ApplicationUpdates::setProgressing (this=0xa1a7d70, progressing=false) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:371
#17 0xb0feaaa8 in ApplicationUpdates::fetchingChanged (this=0xa1a7d70) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:442
#18 0xb0fd9eb8 in ApplicationUpdates::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbf825588, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-i686-linux-gnu/libmuon/backends/ApplicationBackend/moc_ApplicationUpdates.cpp:83
#19 0xb6359fc7 in QMetaObject::activate (sender=sender@entry=0xa1e6cc8, m=m@entry=0xb7753a00 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#20 0xb772a215 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0xa1e6cc8) at /build/buildd/muon-2.1.1/obj-i686-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#21 0xb0fdb5d8 in ApplicationBackend::setFetching (this=0xa1e6cc8, f=false) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:643
#22 0xb0fddd0b in ApplicationBackend::reload (this=0xa1e6cc8) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#23 0xb0fe9486 in ApplicationUpdates::transactionFinished (this=0xa1a7d70) at /build/buildd/muon-2.1.1/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#24 0xb0fd9d89 in ApplicationUpdates::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbf825738, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-i686-linux-gnu/libmuon/backends/ApplicationBackend/moc_ApplicationUpdates.cpp:85
#25 0xb6359fc7 in QMetaObject::activate (sender=sender@entry=0xae333c8, m=m@entry=0xb0f8bd18 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0xbf825738) at kernel/qobject.cpp:3539
#26 0xb0f76235 in QApt::Transaction::finished (this=this@entry=0xae333c8, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transaction.cxx:338
#27 0xb0f68317 in QApt::Transaction::updateProperty (this=this@entry=0xae333c8, type=11, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#28 0xb0f768d4 in QApt::Transaction::qt_static_metacall (_o=_o@entry=0xae333c8, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=24, _a=0xbf8258b4) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transaction.cxx:164
#29 0xb6359fc7 in QMetaObject::activate (sender=sender@entry=0xa4a9e68, m=m@entry=0xb0f8bd78 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0xbf8258b4) at kernel/qobject.cpp:3539
#30 0xb0f775bd in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0xa4a9e68, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:246
#31 0xb0f779e9 in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0xa4a9e68, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0xbf825a5c) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:111
#32 0xb0f78456 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0xa4a9e68, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf825a5c) at /build/buildd/qapt-2.0.65/obj-i686-linux-gnu/src/moc_transactiondbus.cxx:164
#33 0xb5e24ebe in QDBusConnectionPrivate::deliverCall (this=0xa115c60, object=object@entry=0xa4a9e68, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#34 0xb5e2df3d in QDBusCallDeliveryEvent::placeMetaCall (this=0xa1ac140, object=0xa4a9e68) at qdbusintegrator_p.h:103
#35 0xb635e58b in QObject::event (this=0xa4a9e68, e=0xa1ac140) at kernel/qobject.cpp:1194
#36 0xb68a0744 in QApplicationPrivate::notify_helper (this=0x9fa06f8, receiver=0xa4a9e68, e=0xa1ac140) at kernel/qapplication.cpp:4567
#37 0xb68a7223 in QApplication::notify (this=0xbf8260e0, receiver=receiver@entry=0xa4a9e68, e=e@entry=0xa1ac140) at kernel/qapplication.cpp:4353
#38 0xb73edff4 in KApplication::notify (this=0xbf8260e0, receiver=0xa4a9e68, event=0xa1ac140) at ../../kdeui/kernel/kapplication.cpp:311
#39 0xb6344eda in QCoreApplication::notifyInternal (this=0xbf8260e0, receiver=receiver@entry=0xa4a9e68, event=event@entry=0xa1ac140) at kernel/qcoreapplication.cpp:946
#40 0xb63486ad in sendEvent (event=0xa1ac140, receiver=0xa4a9e68) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x9f7a1d8) at kernel/qcoreapplication.cpp:1570
#42 0xb6348bbc in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#43 0xb6374f6e in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#44 postEventSourceDispatch (s=0x9fa83b8) at kernel/qeventdispatcher_glib.cpp:279
#45 0xb585083e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0xb5850be8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0xb5850ca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0xb63748bf in QEventDispatcherGlib::processEvents (this=this@entry=0x9f7af50, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#49 0xb695532e in QGuiEventDispatcherGlib::processEvents (this=0x9f7af50, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#50 0xb63439f3 in QEventLoop::processEvents (this=this@entry=0xbf826028, flags=...) at kernel/qeventloop.cpp:149
#51 0xb6343d19 in QEventLoop::exec (this=this@entry=0xbf826028, flags=...) at kernel/qeventloop.cpp:204
#52 0xb634989e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#53 0xb689e974 in QApplication::exec () at kernel/qapplication.cpp:3828
#54 0x080520f4 in main (argc=5, argv=0xbf8261b4) at /build/buildd/muon-2.1.1/updater/main.cpp:59

Possible duplicates by query: bug 328633, bug 328536, bug 328475, bug 328269, bug 328088.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-12-17 06:29:54 UTC

*** This bug has been marked as a duplicate of bug 327544 ***