Bug 326996 - Gwenview trava ao fechar
Summary: Gwenview trava ao fechar
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.10.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-11-01 13:09 UTC by Roberta Schmitz
Modified: 2013-11-07 02:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberta Schmitz 2013-11-01 13:09:01 UTC
Application: gwenview (4.10.4)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.9.10-100.fc17.i686.PAE i686
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
Sempre que eu abro uma imagem com o Gwenview, ao fechar o programa trava.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb76a2a00 (LWP 3047))]

Thread 2 (Thread 0xb5047b40 (LWP 3049)):
#0  0x42b53dad in __GI_clock_gettime (clock_id=1, tp=0xb5046f08) at ../sysdeps/unix/clock_gettime.c:116
#1  0x438c4ce6 in do_gettime (frac=0xb5046f00, sec=0xb5046ef8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x439ae56f in QTimerInfoList::updateCurrentTime (this=0xb5046f88) at kernel/qeventdispatcher_unix.cpp:354
#4  0xb47004e0 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb76a2a00 (LWP 3047)):
[KCrash Handler]
#7  0x443a327c in QRasterWindowSurface::~QRasterWindowSurface (this=0x84f0928, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#8  0x443a3313 in QRasterWindowSurface::~QRasterWindowSurface (this=0x84f0928, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#9  0x443be43c in QWidgetBackingStore::~QWidgetBackingStore (this=0x84f06d0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#10 0x441c75cd in QWidgetBackingStoreTracker::destroy (this=0x84f0d08) at kernel/qwidget.cpp:221
#11 0x441c7722 in QWidgetPrivate::deleteExtra (this=this@entry=0x8649200) at kernel/qwidget.cpp:1835
#12 0x441c792e in QWidgetPrivate::~QWidgetPrivate (this=0x8649200, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#13 0x441c7bd3 in QWidgetPrivate::~QWidgetPrivate (this=0x8649200, __in_chrg=<optimized out>) at kernel/qwidget.cpp:366
#14 0x439932ca in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x86491ec, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x86491e8, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#17 0x441c9c21 in QWidget::~QWidget (this=0x86491e8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1556
#18 0x441c9ee3 in QWidget::~QWidget (this=0x86491e8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
#19 0x447d3fd9 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x44b12648, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1948
#20 0x4297dcd1 in __run_exit_handlers (status=status@entry=0, listp=0x42afa3c4, run_list_atexit=run_list_atexit@entry=true) at exit.c:78
#21 0x4297dd5d in __GI_exit (status=0) at exit.c:100
#22 0x4296563d in __libc_start_main (main=0x8066920 <main(int, char**)>, argc=6, ubp_av=0xbf959f64, init=0x80ab5a0 <__libc_csu_init>, fini=0x80ab610 <__libc_csu_fini>, rtld_fini=0x42934a90 <_dl_fini>, stack_end=0xbf959f5c) at libc-start.c:258
#23 0x0806712d in _start ()

Possible duplicates by query: bug 326407, bug 326249, bug 320766.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-11-07 02:52:10 UTC
See https://bugs.kde.org/show_bug.cgi?id=261539#c30

*** This bug has been marked as a duplicate of bug 261539 ***