Bug 326249 - Gwenview crashes on close in fresh install of Kubuntu 13.10
Summary: Gwenview crashes on close in fresh install of Kubuntu 13.10
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.11.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
: 326407 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-19 06:41 UTC by John Smith
Modified: 2014-03-01 13:12 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.11 KB, text/plain)
2014-01-16 12:34 UTC, Sadako Sasaki
Details
New crash information added by DrKonqi (5.25 KB, text/plain)
2014-03-01 13:12 UTC, nomad2018
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2013-10-19 06:41:12 UTC
Application: gwenview (4.11.2)
KDE Platform Version: 4.11.2 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.11.0-12-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed: Closing Gwenview causes it to crash every time.
in fresh install of Kubuntu 13.10 (after oxygen-transparent has been installed)

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f14785557c0 (LWP 2184))]

Thread 3 (Thread 0x7f1461529700 (LWP 2190)):
#0  0x00007f1474d14f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1470f50694 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1470f5079c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1477394a76 in QEventDispatcherGlib::processEvents (this=0x7f14540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f14773665ef in QEventLoop::processEvents (this=this@entry=0x7f1461528d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f14773668e5 in QEventLoop::exec (this=this@entry=0x7f1461528d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f147726588f in QThread::exec (this=this@entry=0x1c94a70) at thread/qthread.cpp:542
#7  0x00007f1477347d13 in QInotifyFileSystemWatcherEngine::run (this=0x1c94a70) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f1477267f2f in QThreadPrivate::start (arg=0x1c94a70) at thread/qthread_unix.cpp:338
#9  0x00007f1471414f6e in start_thread (arg=0x7f1461529700) at pthread_create.c:311
#10 0x00007f1474d219cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f145bfff700 (LWP 2192)):
#0  0x00007f1470f900dd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1470f90389 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1470f5067a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1470f5079c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1477394a76 in QEventDispatcherGlib::processEvents (this=0x7f14500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f14773665ef in QEventLoop::processEvents (this=this@entry=0x7f145bffed70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f14773668e5 in QEventLoop::exec (this=this@entry=0x7f145bffed70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f147726588f in QThread::exec (this=this@entry=0x1fa70e0) at thread/qthread.cpp:542
#8  0x00007f1477347d13 in QInotifyFileSystemWatcherEngine::run (this=0x1fa70e0) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f1477267f2f in QThreadPrivate::start (arg=0x1fa70e0) at thread/qthread_unix.cpp:338
#10 0x00007f1471414f6e in start_thread (arg=0x7f145bfff700) at pthread_create.c:311
#11 0x00007f1474d219cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f14785557c0 (LWP 2184)):
[KCrash Handler]
#6  0x00007f1475b6ff79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1fc3f20, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f1475b6fff9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1fc3f20, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f1475b8834c in QWidgetBackingStore::~QWidgetBackingStore (this=0x1fc3320, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f14759c0e09 in QWidgetBackingStoreTracker::destroy (this=0x228e9d0) at kernel/qwidget.cpp:221
#10 0x00007f14759c0fa9 in QWidgetPrivate::deleteExtra (this=this@entry=0x21aaa10) at kernel/qwidget.cpp:1835
#11 0x00007f14759c11bd in QWidgetPrivate::~QWidgetPrivate (this=0x21aaa10, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#12 0x00007f14759c1449 in QWidgetPrivate::~QWidgetPrivate (this=0x21aaa10, __in_chrg=<optimized out>) at kernel/qwidget.cpp:366
#13 0x00007f14773808e5 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x21aa8a8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x21aa8a0, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007f14759c9bcc in QWidget::~QWidget (this=0x21aa8a0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1556
#17 0x00007f14759c9e49 in QWidget::~QWidget (this=0x21aa8a0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1705
#18 0x00007f1475f18f75 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f1476465180 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1950
#19 0x00007f1474c63071 in __run_exit_handlers (status=0, listp=0x7f1474fe86a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#20 0x00007f1474c630f5 in __GI_exit (status=<optimized out>) at exit.c:99
#21 0x00007f1474c48dec in __libc_start_main (main=0x4279c0 <main(int, char**)>, argc=6, ubp_av=0x7fff7d18b048, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7d18b038) at libc-start.c:294
#22 0x0000000000427f42 in _start ()

Possible duplicates by query: bug 320766.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-10-21 20:38:47 UTC
*** Bug 326407 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2013-10-21 21:12:06 UTC

*** This bug has been marked as a duplicate of bug 261539 ***
Comment 3 Sadako Sasaki 2014-01-16 12:34:47 UTC
Created attachment 84662 [details]
New crash information added by DrKonqi

gwenview (4.12.0) on KDE Platform 4.12.0 using Qt 4.8.4

With a fresh installation and oxygen transparent every time i close gwenview teh prgamm is crashing

-- Backtrace (Reduced):
#7  0xb6379282 in QRasterWindowSurface::~QRasterWindowSurface (this=0x8a2f298, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#8  0xb637930c in QRasterWindowSurface::~QRasterWindowSurface (this=0x8a2f298, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#9  0xb6394154 in QWidgetBackingStore::~QWidgetBackingStore (this=<optimized out>, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#10 0xb61a2683 in QWidgetBackingStoreTracker::destroy (this=0x84ccec8) at kernel/qwidget.cpp:221
#11 0xb61a2838 in QWidgetPrivate::deleteExtra (this=this@entry=0x8a06bd8) at kernel/qwidget.cpp:1835
Comment 4 nomad2018 2014-03-01 13:12:29 UTC
Created attachment 85370 [details]
New crash information added by DrKonqi

gwenview (4.11.4) on KDE Platform 4.11.5 using Qt 4.8.4

- What I was doing when the application crashed:
I open the image in "gwenview". The bug arises when I close a window.

-- Backtrace (Reduced):
#6  0x00007f1f6b20bf79 in QRasterWindowSurface::~QRasterWindowSurface (this=0x13895e0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f1f6b20bff9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x13895e0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f1f6b22434c in QWidgetBackingStore::~QWidgetBackingStore (this=0x1389aa0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f1f6b05ce09 in QWidgetBackingStoreTracker::destroy (this=0x174a700) at kernel/qwidget.cpp:221
#10 0x00007f1f6b05cfa9 in QWidgetPrivate::deleteExtra (this=this@entry=0x15ea360) at kernel/qwidget.cpp:1835