Bug 320357 - Crash de Digikam
Summary: Crash de Digikam
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Backend (show other bugs)
Version: 3.3.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-27 18:05 UTC by Christophe Gallaire
Modified: 2022-02-01 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Gallaire 2013-05-27 18:05:49 UTC
Application: digikam (3.3.0-beta1)
KDE Platform Version: 4.10.2 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.4-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
Crash de Digikam au démarrage. Lancement impossible. Plantage systématique.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff29fbd2800 (LWP 2515))]

Thread 3 (Thread 0x7ff27a28b700 (LWP 2518)):
#0  0x00007ff2974d3964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff29afed62b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000005d8978 in Digikam::ScanController::run (this=0x12fe0f0) at /usr/src/debug/digikam-software-compilation/core/digikam/database/scancontroller.cpp:713
#3  0x00007ff29afed0cc in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007ff2974cfe0f in start_thread () from /lib64/libpthread.so.0
#5  0x00007ff2995577dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ff279a8a700 (LWP 2519)):
#0  0x00007ff29954e87d in poll () from /lib64/libc.so.6
#1  0x00007ff29198daa4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff29198dbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff29b1171f6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007ff29b0e79ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007ff29b0e7c78 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007ff29afea0f0 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007ff29b0c81af in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007ff29afed0cc in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007ff2974cfe0f in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff2995577dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ff29fbd2800 (LWP 2515)):
[KCrash Handler]
#5  0x00007ff2994fcf6a in strchrnul () from /lib64/libc.so.6
#6  0x00007ff2994b5c6d in vfprintf () from /lib64/libc.so.6
#7  0x00007ff29956a9f0 in __vsnprintf_chk () from /lib64/libc.so.6
#8  0x00007ff295b38a58 in vsnprintf (__ap=0x7fff43f2f3d8, __fmt=0x7ff294752cb0 "Tag '%lx' not found", __n=1023, __s=0x7fff43f2f3f0 "") at /usr/include/bits/stdio2.h:77
#9  cmsSignalError (ContextID=ContextID@entry=0x3000, ErrorCode=ErrorCode@entry=2490707120, ErrorText=ErrorText@entry=0x64657363 <Address 0x64657363 out of bounds>) at cmserr.c:409
#10 0x00007ff2947357ad in _cmsSearchTag (sig=icSigProfileDescriptionTag, Profile=<optimized out>, lSignalError=<optimized out>) at cmsio0.c:292
#11 _cmsSearchTag (Profile=Profile@entry=0x15af540, sig=sig@entry=icSigProfileDescriptionTag, lSignalError=lSignalError@entry=1) at cmsio0.c:279
#12 0x00007ff29473b0d0 in cmsReadICCTextEx (hProfile=hProfile@entry=0x15af540, sig=sig@entry=icSigProfileDescriptionTag, Name=Name@entry=0x7ff29495e320 <Name.7711> "", size_max=size_max@entry=512) at cmsio1.c:1675
#13 0x00007ff29473b16a in cmsReadICCText (hProfile=hProfile@entry=0x15af540, sig=sig@entry=icSigProfileDescriptionTag, Text=Text@entry=0x7ff29495e320 <Name.7711> "") at cmsio1.c:1706
#14 0x00007ff29473bf36 in cmsTakeProductDesc (hProfile=0x15af540) at cmsio1.c:2218
#15 0x00007ff29d2ad0b5 in Digikam::IccProfile::description (this=0x1431950) at /usr/src/debug/digikam-software-compilation/core/libs/dimg/filters/icc/iccprofile.cpp:389
#16 0x00007ff29d2b9ab3 in Digikam::IccSettings::loadAllProfilesProperties (this=0x148f990) at /usr/src/debug/digikam-software-compilation/core/libs/dimg/filters/icc/iccsettings.cpp:583
#17 0x000000000059d092 in Digikam::DigikamApp::DigikamApp (this=0x1320fa0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/digikam-software-compilation/core/digikam/main/digikamapp.cpp:226
#18 0x000000000049a631 in main (argc=5, argv=0x7fff43f30428) at /usr/src/debug/digikam-software-compilation/core/digikam/main/main.cpp:189

Possible duplicates by query: bug 319690, bug 319166, bug 319144, bug 319070, bug 318991.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-05-27 18:16:59 UTC
It crash in LCMS library...
Comment 2 caulier.gilles 2013-05-27 18:19:31 UTC
It's exactly the same problem than bug #318721

Giles Caulier

*** This bug has been marked as a duplicate of bug 318721 ***
Comment 3 caulier.gilles 2017-07-23 12:54:01 UTC
Since digiKam 5.0.0, we use drop lcms version 1.x in favor of lcms version 2.x. This problem will not reproducible.