Bug 317552 - Automatic Indexing (renaming) of Snapshot causes Error
Summary: Automatic Indexing (renaming) of Snapshot causes Error
Status: RESOLVED DUPLICATE of bug 258431
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: 0.8.2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks: extramile
  Show dependency treegraph
 
Reported: 2013-03-29 16:51 UTC by Richard Llom
Modified: 2013-05-07 17:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Llom 2013-03-29 16:51:14 UTC
The automatic indexing (renaming) of snapshots causes errors (see below).

To avoid such error I would suggest the indexing, should only happen *after* a *new* screenshot was taken.

Reproducible: Always

Steps to Reproduce:
1. Open KSnapshot.
2. "Save as ..." snapshot as "test.png".
3. Notice the title of ksnapshot says "test1.png" (which is wrong).
4. Choose "Send to ..." -> Gwenview
Actual Results:  
Error in Gwenview, as it trys to load "test1.png" instead of "test.png"
("Loading ‘test1.png’ failed
Could not open file /home/richard/test1.png")

Expected Results:  
Title must not display wrong file name.
Wrong file name must not be send to other applications.
Comment 1 Richard Llom 2013-03-29 16:53:08 UTC
Maybe this classifys as extramile bug?
Comment 3 Richard Llom 2013-03-30 13:10:58 UTC
(In reply to comment #2)
> There seem to be a lot of similar/duplicate reports about this issue:
> ...
Oh my, what a mess and I didn't see any of them? =:-0
In bug 237353 comment #12 there is even already a patch proposed.

I will post to the ML and see if there is an *active* dev.
Comment 4 Maarten De Meyer 2013-05-07 17:49:18 UTC

*** This bug has been marked as a duplicate of bug 258431 ***