Bug 315831 - Crash after changing desktop theme to Oxygen
Summary: Crash after changing desktop theme to Oxygen
Status: RESOLVED DUPLICATE of bug 299077
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-folderview (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Ignat Semenov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-27 01:32 UTC by deanguan
Modified: 2013-02-27 02:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description deanguan 2013-02-27 01:32:58 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic x86_64
Distribution: Linux Mint 14 Nadia

-- Information about the crash:
- What I was doing when the application crashed:
i m changeing my desktop theme to Oxygen

- Unusual behavior I noticed:
it crashed and showed debug information

- Custom settings of the application:
no

i just installed this os in this early morning before i sleep

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma 桌面 shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f71f9440780 (LWP 2063))]

Thread 4 (Thread 0x7f71d4a91700 (LWP 2065)):
#0  0x00007f71ec9efba0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f71ec9efe19 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f71ec9b2623 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f71ec9b2cab in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f71ec9b2ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f71f59c1c16 in QEventDispatcherGlib::processEvents (this=0x7f71d00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f71f59922bf in QEventLoop::processEvents (this=this@entry=0x7f71d4a90dd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f71f5992548 in QEventLoop::exec (this=0x7f71d4a90dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f71f5893b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f71f59729af in QInotifyFileSystemWatcherEngine::run (this=0x2349b20) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f71f5896aec in QThreadPrivate::start (arg=0x2349b20) at thread/qthread_unix.cpp:338
#11 0x00007f71ed0b1e9a in start_thread (arg=0x7f71d4a91700) at pthread_create.c:308
#12 0x00007f71f8d1ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f71cf7cf700 (LWP 2066)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f71f2a18cd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f71f2a18d09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f71ed0b1e9a in start_thread (arg=0x7f71cf7cf700) at pthread_create.c:308
#4  0x00007f71f8d1ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f71cce14700 (LWP 2068)):
#0  0x00007f71f8d13303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f71ec9b2d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f71ec9b31e2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f71cd9014a6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f71ec9d6645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f71ed0b1e9a in start_thread (arg=0x7f71cce14700) at pthread_create.c:308
#6  0x00007f71f8d1ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f71f9440780 (LWP 2063)):
[KCrash Handler]
#6  0x00007f71db87d0b4 in ListView::updateSizeHint (this=0x2ee8d90) at ../../../../plasma/applets/folderview/listview.cpp:209
#7  0x00007f71f59a8f5f in QMetaObject::activate (sender=0x2add3f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#8  0x00007f71f88d4c3f in themeChanged (this=0x2ee6430) at ../../plasma/svg.cpp:618
#9  Plasma::SvgPrivate::themeChanged (this=0x2ee6430) at ../../plasma/svg.cpp:601
#10 0x00007f71f88d4e99 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./svg.moc:114
#11 Plasma::Svg::qt_static_metacall (_o=0x0, _c=3472472016, _id=-158160, _a=0x7fffcef9b960) at ./svg.moc:106
#12 0x00007f71f59a8f5f in QMetaObject::activate (sender=0x2340480, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#13 0x00007f71f88dd7ab in Plasma::ThemePrivate::notifyOfChanged (this=0x23f56f0) at ../../plasma/theme.cpp:366
#14 0x00007f71f88dd989 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./theme.moc:102
#15 Plasma::Theme::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./theme.moc:88
#16 0x00007f71f59a8f5f in QMetaObject::activate (sender=0x24104f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#17 0x00007f71f59a826c in QObject::event (this=0x24104f0, e=<optimized out>) at kernel/qobject.cpp:1157
#18 0x00007f71f4d3ae9c in QApplicationPrivate::notify_helper (this=this@entry=0x22bc700, receiver=receiver@entry=0x24104f0, e=e@entry=0x7fffcef9c410) at kernel/qapplication.cpp:4562
#19 0x00007f71f4d3f30a in QApplication::notify (this=0x229a680, receiver=0x24104f0, e=0x7fffcef9c410) at kernel/qapplication.cpp:4423
#20 0x00007f71f664c1d6 in KApplication::notify (this=0x229a680, receiver=0x24104f0, event=0x7fffcef9c410) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007f71f599356e in QCoreApplication::notifyInternal (this=0x229a680, receiver=0x24104f0, event=0x7fffcef9c410) at kernel/qcoreapplication.cpp:915
#22 0x00007f71f59c4462 in sendEvent (event=0x7fffcef9c410, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 QTimerInfoList::activateTimers (this=0x22c0860) at kernel/qeventdispatcher_unix.cpp:611
#24 0x00007f71f59c1584 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#25 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#26 0x00007f71f59c15a1 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#27 0x00007f71ec9b2ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f71ec9b2de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f71ec9b2ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f71f59c1bf6 in QEventDispatcherGlib::processEvents (this=0x223aae0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0x00007f71f4ddfc1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f71f59922bf in QEventLoop::processEvents (this=this@entry=0x7fffcef9c690, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f71f5992548 in QEventLoop::exec (this=0x7fffcef9c690, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007f71f5997708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#35 0x00007f71f9025035 in kdemain (argc=1, argv=0x7fffcef9c988) at ../../../../plasma/desktop/shell/main.cpp:120
#36 0x00007f71f8c4c76d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7fffcef9c988, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffcef9c978) at libc-start.c:226
#37 0x00000000004006d1 in _start ()

This bug may be a duplicate of or related to bug 299077.

Possible duplicates by query: bug 311661, bug 303770, bug 303681, bug 303123, bug 302011.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-02-27 02:07:08 UTC
Should be fixed in 4.9.5

*** This bug has been marked as a duplicate of bug 299077 ***