Bug 302011 - KDE Crash
Summary: KDE Crash
Status: RESOLVED DUPLICATE of bug 299077
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-16 12:57 UTC by Steve Atty
Modified: 2012-06-16 13:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Atty 2012-06-16 12:57:55 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
I was changing the desktop theme and settings, using the regular options on the System settings menu

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1a48740 (LWP 1990))]

Thread 5 (Thread 0xa9931b40 (LWP 2018)):
#0  0xb2c52dc8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb75cf5f4 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b7f3d0 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b3fc5e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b40125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2b40201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb63e58e7 in QEventDispatcherGlib::processEvents (this=0xa9000468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb63b150d in QEventLoop::processEvents (this=0xa9931240, flags=...) at kernel/qeventloop.cpp:149
#8  0xb63b17a9 in QEventLoop::exec (this=0xa9931240, flags=...) at kernel/qeventloop.cpp:204
#9  0xb629a94c in QThread::exec (this=0x90c4a10) at thread/qthread.cpp:501
#10 0xb638eb5d in QInotifyFileSystemWatcherEngine::run (this=0x90c4a10) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb629dde0 in QThreadPrivate::start (arg=0x90c4a10) at thread/qthread_unix.cpp:298
#12 0xb2c50d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb75c1ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xa8e37b40 (LWP 2019)):
#0  0xb75cf608 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0xb2b7f410 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2b3f865 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b3ffaf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b40201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63e58e7 in QEventDispatcherGlib::processEvents (this=0xa8500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63b150d in QEventLoop::processEvents (this=0xa8e37240, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63b17a9 in QEventLoop::exec (this=0xa8e37240, flags=...) at kernel/qeventloop.cpp:204
#8  0xb629a94c in QThread::exec (this=0x90b1728) at thread/qthread.cpp:501
#9  0xb638eb5d in QInotifyFileSystemWatcherEngine::run (this=0x90b1728) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb629dde0 in QThreadPrivate::start (arg=0x90b1728) at thread/qthread_unix.cpp:298
#11 0xb2c50d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb75c1ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa73bfb40 (LWP 2022)):
#0  0xb7710424 in __kernel_vsyscall ()
#1  0xb2c5496b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75cf3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb3c13029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3c1306f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2c50d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb75c1ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa5e56b40 (LWP 2024)):
#0  0xb75b117f in read () from /lib/i386-linux-gnu/libc.so.6
#1  0xb2b7e6ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2b3fbd2 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b40042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b4056b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xa67271ba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb2b636b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb2c50d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb75c1ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb1a48740 (LWP 1990)):
[KCrash Handler]
#7  0x9ea513d2 in ListView::updateSizeHint (this=0xb13d018) at ../../../../plasma/applets/folderview/listview.cpp:209
#8  0x9ea4d7fb in qt_static_metacall (_a=0xbfb4a150, _id=12, _o=0xb13d018, _c=<optimized out>) at ./abstractitemview.moc:96
#9  AbstractItemView::qt_static_metacall (_o=0xb13d018, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfb4a150) at ./abstractitemview.moc:78
#10 0xb63c96b1 in QMetaObject::activate (sender=0xb13cf20, m=0xb74ce5f8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#11 0xb736a5a5 in Plasma::Svg::repaintNeeded (this=0xb13cf20) at ./svg.moc:221
#12 0xb736de55 in themeChanged (this=0x9e067b8) at ../../plasma/svg.cpp:618
#13 Plasma::SvgPrivate::themeChanged (this=0x9e067b8) at ../../plasma/svg.cpp:601
#14 0xb736f90b in qt_static_metacall (_a=0xbfb4a2e0, _id=2, _o=0xb13cf20, _c=<optimized out>) at ./svg.moc:114
#15 Plasma::Svg::qt_static_metacall (_o=0xb13cf20, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfb4a2e0) at ./svg.moc:106
#16 0xb63c96b1 in QMetaObject::activate (sender=0x8a096b0, m=0xb74ce6d8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#17 0xb7371c55 in Plasma::Theme::themeChanged (this=0x8a096b0) at ./theme.moc:199
#18 0xb7379eb2 in Plasma::ThemePrivate::notifyOfChanged (this=0x8a8a398) at ../../plasma/theme.cpp:366
#19 0xb737a063 in qt_static_metacall (_a=0xbfb4a430, _id=8, _o=0x8a096b0, _c=<optimized out>) at ./theme.moc:102
#20 Plasma::Theme::qt_static_metacall (_o=0x8a096b0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfb4a430) at ./theme.moc:88
#21 0xb63c96b1 in QMetaObject::activate (sender=0x8a8d978, m=0xb65104d8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#22 0xb641c625 in QTimer::timeout (this=0x8a8d978) at .moc/release-shared/moc_qtimer.cpp:148
#23 0xb63d2566 in QTimer::timerEvent (this=0x8a8d978, e=0xbfb4a93c) at kernel/qtimer.cpp:280
#24 0xb63cdac4 in QObject::event (this=0x8a8d978, e=0xbfb4a93c) at kernel/qobject.cpp:1157
#25 0xb589ded4 in notify_helper (e=0xbfb4a93c, receiver=0x8a8d978, this=0x899e488) at kernel/qapplication.cpp:4559
#26 QApplicationPrivate::notify_helper (this=0x899e488, receiver=0x8a8d978, e=0xbfb4a93c) at kernel/qapplication.cpp:4531
#27 0xb58a330d in QApplication::notify (this=0xbfb4a93c, receiver=0x8a8d978, e=0xbfb4a93c) at kernel/qapplication.cpp:4288
#28 0xb6a4cb61 in KApplication::notify (this=0x898e420, receiver=0x8a8d978, event=0xbfb4a93c) at ../../kdeui/kernel/kapplication.cpp:311
#29 0xb63b297e in QCoreApplication::notifyInternal (this=0x898e420, receiver=0x8a8d978, event=0xbfb4a93c) at kernel/qcoreapplication.cpp:876
#30 0xb63e7990 in sendEvent (event=0xbfb4a93c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QTimerInfoList::activateTimers (this=0x89a2234) at kernel/qeventdispatcher_unix.cpp:611
#32 0xb63e50f8 in timerSourceDispatch (source=0x89a2200) at kernel/qeventdispatcher_glib.cpp:186
#33 timerSourceDispatch (source=0x89a2200) at kernel/qeventdispatcher_glib.cpp:180
#34 0xb63e5132 in idleTimerSourceDispatch (source=0x89a2268) at kernel/qeventdispatcher_glib.cpp:233
#35 0xb2b3fd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb2b40125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0xb2b40201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb63e5887 in QEventDispatcherGlib::processEvents (this=0x894deb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#39 0xb5956aaa in QGuiEventDispatcherGlib::processEvents (this=0x894deb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0xb63b150d in QEventLoop::processEvents (this=0xbfb4abc4, flags=...) at kernel/qeventloop.cpp:149
#41 0xb63b17a9 in QEventLoop::exec (this=0xbfb4abc4, flags=...) at kernel/qeventloop.cpp:204
#42 0xb63b6eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#43 0xb589ba74 in QApplication::exec () at kernel/qapplication.cpp:3820
#44 0xb76c4a7b in kdemain (argc=1, argv=0xbfb4adc4) at ../../../../plasma/desktop/shell/main.cpp:120
#45 0x0804850b in main (argc=1, argv=0xbfb4adc4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 299077.

Possible duplicates by query: bug 299077.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-16 13:20:28 UTC

*** This bug has been marked as a duplicate of bug 299077 ***