Bug 303770 - Compiz
Summary: Compiz
Status: RESOLVED DUPLICATE of bug 299077
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-18 23:31 UTC by ivypes
Modified: 2012-07-18 23:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ivypes 2012-07-18 23:31:48 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
No me permite abrir el gestor compiz

The crash can be reproduced every time.

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff148546780 (LWP 1961))]

Thread 9 (Thread 0x7ff12572f700 (LWP 1964)):
#0  0x00007ff147e18b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff13bfc7036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff13bfc7164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff144fea426 in QEventDispatcherGlib::processEvents (this=0x7ff1200008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff144fb9c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff144fb9ed7 in QEventLoop::exec (this=0x7ff12572edd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff144eb8fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007ff144f999ff in QInotifyFileSystemWatcherEngine::run (this=0x12d2980) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff144ebbfcb in QThreadPrivate::start (arg=0x12d2980) at thread/qthread_unix.cpp:298
#9  0x00007ff13c8cbe9a in start_thread (arg=0x7ff12572f700) at pthread_create.c:308
#10 0x00007ff147e244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7ff11e431700 (LWP 1993)):
#0  0x00007ff147e18b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff13bfc7036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff13bfc7164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff144fea426 in QEventDispatcherGlib::processEvents (this=0x7ff1180008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff144fb9c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff144fb9ed7 in QEventLoop::exec (this=0x7ff11e430dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff144eb8fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007ff144f999ff in QInotifyFileSystemWatcherEngine::run (this=0x125ea50) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff144ebbfcb in QThreadPrivate::start (arg=0x125ea50) at thread/qthread_unix.cpp:298
#9  0x00007ff13c8cbe9a in start_thread (arg=0x7ff11e431700) at pthread_create.c:308
#10 0x00007ff147e244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7ff1170fb700 (LWP 1996)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff141d9e222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007ff141d9e259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007ff13c8cbe9a in start_thread (arg=0x7ff1170fb700) at pthread_create.c:308
#4  0x00007ff147e244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7ff10f7fe700 (LWP 2001)):
#0  0x00007ff147e18b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff13bfc7036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff13bfc749a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff114944406 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007ff13bfe89e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ff13c8cbe9a in start_thread (arg=0x7ff10f7fe700) at pthread_create.c:308
#6  0x00007ff147e244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7ff10dc2c700 (LWP 3199)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff144ebc4db in wait (time=18446744073709551615, this=0x1c94c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1bb5900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff140a670eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1c7fd20, th=0x3c04680) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff140a699db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1c1f960, th=0x3c04680) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff140a6884f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff10dc2be20, parent=0x1c7fd20, th=0x3c04680) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ff140a688db in ThreadWeaver::Thread::run (this=0x3c04680) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff144ebbfcb in QThreadPrivate::start (arg=0x3c04680) at thread/qthread_unix.cpp:298
#8  0x00007ff13c8cbe9a in start_thread (arg=0x7ff10dc2c700) at pthread_create.c:308
#9  0x00007ff147e244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ff10ec2f700 (LWP 3200)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff144ebc4db in wait (time=18446744073709551615, this=0x1c94c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1bb5900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff140a670eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1c7fd20, th=0x5327ad0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff140a699db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1c1f960, th=0x5327ad0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff140a6884f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff10ec2ee20, parent=0x1c7fd20, th=0x5327ad0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ff140a688db in ThreadWeaver::Thread::run (this=0x5327ad0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff144ebbfcb in QThreadPrivate::start (arg=0x5327ad0) at thread/qthread_unix.cpp:298
#8  0x00007ff13c8cbe9a in start_thread (arg=0x7ff10ec2f700) at pthread_create.c:308
#9  0x00007ff147e244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ff10ffff700 (LWP 3201)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff144ebc4db in wait (time=18446744073709551615, this=0x1c94c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1bb5900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff140a670eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1c7fd20, th=0x5045130) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff140a699db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1c1f960, th=0x5045130) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff140a6884f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff10fffee20, parent=0x1c7fd20, th=0x5045130) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ff140a688db in ThreadWeaver::Thread::run (this=0x5045130) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff144ebbfcb in QThreadPrivate::start (arg=0x5045130) at thread/qthread_unix.cpp:298
#8  0x00007ff13c8cbe9a in start_thread (arg=0x7ff10ffff700) at pthread_create.c:308
#9  0x00007ff147e244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff0f15ea700 (LWP 3202)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff144ebc4db in wait (time=18446744073709551615, this=0x1c94c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1bb5900, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff140a670eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1c7fd20, th=0x3c048e0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff140a699db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1c1f960, th=0x3c048e0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007ff140a6884f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff0f15e9e20, parent=0x1c7fd20, th=0x3c048e0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007ff140a688db in ThreadWeaver::Thread::run (this=0x3c048e0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007ff144ebbfcb in QThreadPrivate::start (arg=0x3c048e0) at thread/qthread_unix.cpp:298
#8  0x00007ff13c8cbe9a in start_thread (arg=0x7ff0f15ea700) at pthread_create.c:308
#9  0x00007ff147e244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff148546780 (LWP 1961)):
[KCrash Handler]
#6  0x00007ff0e991b44c in ListView::updateSizeHint (this=0x31ab4a0) at ../../../../plasma/applets/folderview/listview.cpp:209
#7  0x00007ff144fcf281 in QMetaObject::activate (sender=0x3175e10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#8  0x00007ff1479d303e in themeChanged (this=0x31c7a40) at ../../plasma/svg.cpp:618
#9  Plasma::SvgPrivate::themeChanged (this=0x31c7a40) at ../../plasma/svg.cpp:601
#10 0x00007ff1479d47f1 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./svg.moc:114
#11 Plasma::Svg::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./svg.moc:106
#12 0x00007ff144fcf281 in QMetaObject::activate (sender=0x12aef70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#13 0x00007ff1479de10b in Plasma::ThemePrivate::notifyOfChanged (this=<optimized out>) at ../../plasma/theme.cpp:366
#14 0x00007ff1479de2c9 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./theme.moc:102
#15 Plasma::Theme::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./theme.moc:88
#16 0x00007ff144fcf281 in QMetaObject::activate (sender=0x1352d70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#17 0x00007ff144fd4179 in QObject::event (this=0x1352d70, e=<optimized out>) at kernel/qobject.cpp:1157
#18 0x00007ff14433d894 in notify_helper (e=0x7fff4b08da70, receiver=0x1352d70, this=0x121bdf0) at kernel/qapplication.cpp:4559
#19 QApplicationPrivate::notify_helper (this=0x121bdf0, receiver=0x1352d70, e=0x7fff4b08da70) at kernel/qapplication.cpp:4531
#20 0x00007ff144342713 in QApplication::notify (this=0x120b710, receiver=0x1352d70, e=0x7fff4b08da70) at kernel/qapplication.cpp:4420
#21 0x00007ff145c9e9e6 in KApplication::notify (this=0x120b710, receiver=0x1352d70, event=0x7fff4b08da70) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007ff144fbae9c in QCoreApplication::notifyInternal (this=0x120b710, receiver=0x1352d70, event=0x7fff4b08da70) at kernel/qcoreapplication.cpp:876
#23 0x00007ff144fec1f2 in sendEvent (event=0x7fff4b08da70, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QTimerInfoList::activateTimers (this=0x121e460) at kernel/qeventdispatcher_unix.cpp:611
#25 0x00007ff144fe9c0d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#26 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#27 0x00007ff13bfc6d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007ff13bfc70a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ff13bfc7164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ff144fea3bf in QEventDispatcherGlib::processEvents (this=0x119bad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0x00007ff1443e5d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007ff144fb9c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007ff144fb9ed7 in QEventLoop::exec (this=0x7fff4b08dcd0, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007ff144fbef67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#35 0x00007ff148130a13 in kdemain (argc=1, argv=0x7fff4b08e0b8) at ../../../../plasma/desktop/shell/main.cpp:120
#36 0x00007ff147d5376d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff4b08e0b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff4b08e0a8) at libc-start.c:226
#37 0x0000000000400671 in _start ()

Possible duplicates by query: bug 303681, bug 303123, bug 302011, bug 299531, bug 299077.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-07-18 23:50:24 UTC

*** This bug has been marked as a duplicate of bug 299077 ***