Bug 303681 - crash after changing desktop theme
Summary: crash after changing desktop theme
Status: RESOLVED DUPLICATE of bug 299077
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-17 13:35 UTC by nakki
Modified: 2012-07-17 14:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nakki 2012-07-17 13:35:37 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I changed desktop theme then a crash occurred, and the tray became too large, occupying almost half panel.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7feca08917c0 (LWP 22378))]

Thread 9 (Thread 0x7fec8373b700 (LWP 22379)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fec9a0e0222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fec9a0e0259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fec91602b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007fec94c0de9a in start_thread (arg=0x7fec8373b700) at pthread_create.c:308
#5  0x00007feca01664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fec80e4a700 (LWP 22380)):
#0  __libc_disable_asynccancel () at ../nptl/sysdeps/unix/sysv/linux/x86_64/cancellation.S:99
#1  0x00007feca01590c9 in read () at ../sysdeps/unix/syscall-template.S:82
#2  0x00007fec916010bc in ?? () from /usr/lib/nvidia-current/libGL.so.1
#3  0x00007fec8ee7fb27 in ?? () from /usr/lib/nvidia-current/tls/libnvidia-tls.so.295.40
#4  0x00007fec943438cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fec94308ba4 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fec94308fd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fec94309164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fec9d32c426 in QEventDispatcherGlib::processEvents (this=0x7fec7c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#9  0x00007fec9d2fbc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#10 0x00007fec9d2fbed7 in QEventLoop::exec (this=0x7fec80e49cd0, flags=...) at kernel/qeventloop.cpp:204
#11 0x00007fec9d1fafa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#12 0x00007fec9d2db9ff in QInotifyFileSystemWatcherEngine::run (this=0xe17130) at io/qfilesystemwatcher_inotify.cpp:248
#13 0x00007fec9d1fdfcb in QThreadPrivate::start (arg=0xe17130) at thread/qthread_unix.cpp:298
#14 0x00007fec91602b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#15 0x00007fec94c0de9a in start_thread (arg=0x7fec80e4a700) at pthread_create.c:308
#16 0x00007feca01664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fec76964700 (LWP 22381)):
#0  0x00007feca01740f0 in pthread_mutex_unlock (mutex=0x7fec70000a80) at forward.c:184
#1  0x00007fec943445d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fec9430883b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fec94308f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fec94309164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fec9d32c426 in QEventDispatcherGlib::processEvents (this=0x7fec700008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fec9d2fbc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fec9d2fbed7 in QEventLoop::exec (this=0x7fec76963cd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fec9d1fafa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fec9d2db9ff in QInotifyFileSystemWatcherEngine::run (this=0xf1d500) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fec9d1fdfcb in QThreadPrivate::start (arg=0xf1d500) at thread/qthread_unix.cpp:298
#11 0x00007fec91602b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x00007fec94c0de9a in start_thread (arg=0x7fec76964700) at pthread_create.c:308
#13 0x00007feca01664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fec65ff8700 (LWP 22385)):
#0  0x00007feca015ab17 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:89
#1  0x00007fec94309036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fec9430949a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fec66ae2406 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fec9432a9e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fec91602b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#6  0x00007fec94c0de9a in start_thread (arg=0x7fec65ff8700) at pthread_create.c:308
#7  0x00007feca01664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fec64f92700 (LWP 22614)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fec9d1fe4db in wait (time=18446744073709551615, this=0xf9f720) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xf6a5b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fec98da90eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10595d0, th=0x24253f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fec98dab9db in ThreadWeaver::WorkingHardState::applyForWork (this=0xf5f1b0, th=0x24253f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fec98daa84f in ThreadWeaver::ThreadRunHelper::run (this=0x7fec64f91d20, parent=0x10595d0, th=0x24253f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fec98daa8db in ThreadWeaver::Thread::run (this=0x24253f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fec9d1fdfcb in QThreadPrivate::start (arg=0x24253f0) at thread/qthread_unix.cpp:298
#8  0x00007fec91602b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007fec94c0de9a in start_thread (arg=0x7fec64f92700) at pthread_create.c:308
#10 0x00007feca01664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fec667f9700 (LWP 22615)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fec9d1fe4db in wait (time=18446744073709551615, this=0xf9f720) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xf6a5b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fec98da90eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10595d0, th=0x243a170) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fec98dab9db in ThreadWeaver::WorkingHardState::applyForWork (this=0xf5f1b0, th=0x243a170) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fec98daa84f in ThreadWeaver::ThreadRunHelper::run (this=0x7fec667f8d20, parent=0x10595d0, th=0x243a170) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fec98daa8db in ThreadWeaver::Thread::run (this=0x243a170) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fec9d1fdfcb in QThreadPrivate::start (arg=0x243a170) at thread/qthread_unix.cpp:298
#8  0x00007fec91602b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007fec94c0de9a in start_thread (arg=0x7fec667f9700) at pthread_create.c:308
#10 0x00007feca01664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fec566dd700 (LWP 22616)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fec9d1fe4db in wait (time=18446744073709551615, this=0xf9f720) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xf6a5b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fec98da90eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10595d0, th=0x31999e0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fec98dab9db in ThreadWeaver::WorkingHardState::applyForWork (this=0xf5f1b0, th=0x31999e0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fec98dab9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf5f1b0, th=0x31999e0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fec98daa84f in ThreadWeaver::ThreadRunHelper::run (this=0x7fec566dcd20, parent=0x10595d0, th=0x31999e0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007fec98daa8db in ThreadWeaver::Thread::run (this=0x31999e0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007fec9d1fdfcb in QThreadPrivate::start (arg=0x31999e0) at thread/qthread_unix.cpp:298
#9  0x00007fec91602b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007fec94c0de9a in start_thread (arg=0x7fec566dd700) at pthread_create.c:308
#11 0x00007feca01664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fec55edc700 (LWP 22617)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fec9d1fe4db in wait (time=18446744073709551615, this=0xf9f720) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xf6a5b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fec98da90eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10595d0, th=0x98bd80) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fec98dab9db in ThreadWeaver::WorkingHardState::applyForWork (this=0xf5f1b0, th=0x98bd80) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fec98dab9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf5f1b0, th=0x98bd80) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fec98daa84f in ThreadWeaver::ThreadRunHelper::run (this=0x7fec55edbd20, parent=0x10595d0, th=0x98bd80) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007fec98daa8db in ThreadWeaver::Thread::run (this=0x98bd80) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007fec9d1fdfcb in QThreadPrivate::start (arg=0x98bd80) at thread/qthread_unix.cpp:298
#9  0x00007fec91602b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007fec94c0de9a in start_thread (arg=0x7fec55edc700) at pthread_create.c:308
#11 0x00007feca01664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7feca08917c0 (LWP 22378)):
[KCrash Handler]
#6  0x00007fec81b8844c in ListView::updateSizeHint (this=0x3cee730) at ../../../../plasma/applets/folderview/listview.cpp:209
#7  0x00007fec9d311281 in QMetaObject::activate (sender=0x4287160, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#8  0x00007fec9fd1503e in themeChanged (this=0x3d1c820) at ../../plasma/svg.cpp:618
#9  Plasma::SvgPrivate::themeChanged (this=0x3d1c820) at ../../plasma/svg.cpp:601
#10 0x00007fec9fd167f1 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./svg.moc:114
#11 Plasma::Svg::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./svg.moc:106
#12 0x00007fec9d311281 in QMetaObject::activate (sender=0xa73e60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#13 0x00007fec9fd2010b in Plasma::ThemePrivate::notifyOfChanged (this=<optimized out>) at ../../plasma/theme.cpp:366
#14 0x00007fec9fd202c9 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./theme.moc:102
#15 Plasma::Theme::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./theme.moc:88
#16 0x00007fec9d311281 in QMetaObject::activate (sender=0xb2a230, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#17 0x00007fec9d316179 in QObject::event (this=0xb2a230, e=<optimized out>) at kernel/qobject.cpp:1157
#18 0x00007fec9c67f894 in notify_helper (e=0x7ffffed4e4b0, receiver=0xb2a230, this=0xa0c110) at kernel/qapplication.cpp:4559
#19 QApplicationPrivate::notify_helper (this=0xa0c110, receiver=0xb2a230, e=0x7ffffed4e4b0) at kernel/qapplication.cpp:4531
#20 0x00007fec9c684713 in QApplication::notify (this=0x9c47e0, receiver=0xb2a230, e=0x7ffffed4e4b0) at kernel/qapplication.cpp:4420
#21 0x00007fec9dfe09e6 in KApplication::notify (this=0x9c47e0, receiver=0xb2a230, event=0x7ffffed4e4b0) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007fec9d2fce9c in QCoreApplication::notifyInternal (this=0x9c47e0, receiver=0xb2a230, event=0x7ffffed4e4b0) at kernel/qcoreapplication.cpp:876
#23 0x00007fec9d32e1f2 in sendEvent (event=0x7ffffed4e4b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QTimerInfoList::activateTimers (this=0xa0d960) at kernel/qeventdispatcher_unix.cpp:611
#25 0x00007fec9d32bc0d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#26 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#27 0x00007fec9d32bc31 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#28 0x00007fec94308d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fec943090a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fec94309164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fec9d32c3bf in QEventDispatcherGlib::processEvents (this=0x918ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#32 0x00007fec9c727d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fec9d2fbc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fec9d2fbed7 in QEventLoop::exec (this=0x7ffffed4e720, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007fec9d300f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#36 0x00007feca0472a13 in kdemain (argc=1, argv=0x7ffffed4eb08) at ../../../../plasma/desktop/shell/main.cpp:120
#37 0x00007feca009576d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7ffffed4eb08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffffed4eaf8) at libc-start.c:226
#38 0x0000000000400671 in _start ()

This bug may be a duplicate of or related to bug 299077.

Possible duplicates by query: bug 303123, bug 302011, bug 299531, bug 299077.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-17 14:03:43 UTC

*** This bug has been marked as a duplicate of bug 299077 ***