Bug 312422 - Crash by starting
Summary: Crash by starting
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Database-Scan (show other bugs)
Version: 2.9.0
Platform: Microsoft Windows Microsoft Windows
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-31 08:49 UTC by Laurent Soron
Modified: 2018-08-11 09:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Soron 2012-12-31 08:49:18 UTC
Application: digikam (2.9.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.2
Operating System: WindowsNT Windows 7 i686

-- Information about the crash:
- What I was doing when the application crashed: starting the application
Application was reinstalled (and SQLlite database removed). Note that I did not see by reinstalling the first configuration steps (e.g. "where should be located the digikam settings ?"), App asked where the collections were located

- Unusual behavior I noticed: During the installation, the process Catalyst Control Centre crashed.
 Catalyst Control Centre may be related to AMD ATI Radeon HD 5650 embedded in my Laptop (Toshiba Satellite L655-1EX, german)

- Custom settings of the application:
Data stored in D:\Photos, Database located
Digikam settings stored in C:\users\user
OS: Windows 7 64 bits English, current set of hotfixes installed
German keyboard
User language: english, local administrator

Application installed from Installation Package as recommended by Digikam.org

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam.exe), signal: EXCEPTION_ACCESS_VIOLATION


ntdll.dll!ZwWaitForMultipleObjects() [[unknown] @ -1] at 0x77c3013d
kernel32.dll!WaitForMultipleObjectsEx() [[unknown] @ -1] at 0x76f81a2c
kernel32.dll!WaitForMultipleObjects() [[unknown] @ -1] at 0x76f84220
QtCore4.dll!QString::contains() [[unknown] @ -1] at 0x72a728a3
QtCore4.dll!QThread::setTerminationEnabled() [[unknown] @ -1] at 0x729a7b8d
QtCore4.dll!QEventDispatcherWin32::`default constructor closure'() [[unknown] @ -1] at 0x729a74ad


ntdll.dll!ZwWaitForMultipleObjects() [[unknown] @ -1] at 0x77c3013d
kernel32.dll!WaitForMultipleObjectsEx() [[unknown] @ -1] at 0x76f81a2c
kernel32.dll!WaitForMultipleObjects() [[unknown] @ -1] at 0x76f84220
QtCore4.dll!QString::contains() [[unknown] @ -1] at 0x72a728a3
QtCore4.dll!QThread::setTerminationEnabled() [[unknown] @ -1] at 0x729a7b8d
QtCore4.dll!QEventDispatcherWin32::`default constructor closure'() [[unknown] @ -1] at 0x729a74ad


ntdll.dll!ZwWaitForMultipleObjects() [[unknown] @ -1] at 0x77c3013d
kernel32.dll!WaitForMultipleObjectsEx() [[unknown] @ -1] at 0x76f81a2c
libvlccore.dll!vlc_timer_create() [[unknown] @ -1] at 0x6b2e82ae
KERNELBASE.dll!ResetEvent() [[unknown] @ -1] at 0x77310dfc
libvlccore.dll!vlc_cond_wait() [[unknown] @ -1] at 0x6b2e8fd4
libvlccore.dll!intf_Create() [[unknown] @ -1] at 0x6b265e7e
ntdll.dll!RtlImageNtHeader() [[unknown] @ -1] at 0x77c4389a
ntdll.dll!RtlImageNtHeader() [[unknown] @ -1] at 0x77c43492
libvlccore.dll!vlc_threadvar_set() [[unknown] @ -1] at 0x6b2e87c9
msvcrt.dll!endthreadex() [[unknown] @ -1] at 0x75561328
kernel32.dll!BaseThreadInitThunk() [[unknown] @ -1] at 0x76f833aa
ntdll.dll!RtlInitializeExceptionChain() [[unknown] @ -1] at 0x77c49ef2
ntdll.dll!RtlInitializeExceptionChain() [[unknown] @ -1] at 0x77c49ec5


ntdll.dll!ZwWaitForMultipleObjects() [[unknown] @ -1] at 0x77c3013d
kernel32.dll!WaitForMultipleObjectsEx() [[unknown] @ -1] at 0x76f81a2c
kernel32.dll!WaitForMultipleObjects() [[unknown] @ -1] at 0x76f84220
QtCore4.dll!QString::contains() [[unknown] @ -1] at 0x72a728a3
QtCore4.dll!QThread::setTerminationEnabled() [[unknown] @ -1] at 0x729a7b8d
QtCore4.dll!QEventDispatcherWin32::`default constructor closure'() [[unknown] @ -1] at 0x729a74ad


ntdll.dll!ZwWaitForMultipleObjects() [[unknown] @ -1] at 0x77c3013d
kernel32.dll!WaitForMultipleObjectsEx() [[unknown] @ -1] at 0x76f81a2c
kernel32.dll!WaitForMultipleObjects() [[unknown] @ -1] at 0x76f84220
QtCore4.dll!QString::contains() [[unknown] @ -1] at 0x72a728a3
QtCore4.dll!QThread::setTerminationEnabled() [[unknown] @ -1] at 0x729a7b8d
QtCore4.dll!QEventDispatcherWin32::`default constructor closure'() [[unknown] @ -1] at 0x729a74ad


ntdll.dll!ZwWaitForMultipleObjects() [[unknown] @ -1] at 0x77c3013d
kernel32.dll!WaitForMultipleObjectsEx() [[unknown] @ -1] at 0x76f81a2c
kernel32.dll!WaitForMultipleObjects() [[unknown] @ -1] at 0x76f84220
QtCore4.dll!QString::contains() [[unknown] @ -1] at 0x72a728a3
QtCore4.dll!QThread::setTerminationEnabled() [[unknown] @ -1] at 0x729a7b8d
QtCore4.dll!QEventDispatcherWin32::`default constructor closure'() [[unknown] @ -1] at 0x729a74ad


ntdll.dll!ZwWaitForMultipleObjects() [[unknown] @ -1] at 0x77c3013d
kernel32.dll!WaitForMultipleObjectsEx() [[unknown] @ -1] at 0x76f81a2c
kernel32.dll!WaitForMultipleObjects() [[unknown] @ -1] at 0x76f84220
QtCore4.dll!QString::contains() [[unknown] @ -1] at 0x72a728a3
QtCore4.dll!QThread::setTerminationEnabled() [[unknown] @ -1] at 0x729a7b8d
QtCore4.dll!QEventDispatcherWin32::`default constructor closure'() [[unknown] @ -1] at 0x729a74ad


ntdll.dll!ZwWaitForMultipleObjects() [[unknown] @ -1] at 0x77c3013d
kernel32.dll!WaitForMultipleObjectsEx() [[unknown] @ -1] at 0x76f81a2c
kernel32.dll!WaitForMultipleObjects() [[unknown] @ -1] at 0x76f84220
QtCore4.dll!QString::contains() [[unknown] @ -1] at 0x72a728a3
QtCore4.dll!QThread::setTerminationEnabled() [[unknown] @ -1] at 0x729a7b8d
QtCore4.dll!QEventDispatcherWin32::`default constructor closure'() [[unknown] @ -1] at 0x729a74ad


[unknown]![unknown]() [[unknown] @ -1] at 0x77c3013d

This bug may be a duplicate of or related to bug 308393.

Possible duplicates by query: bug 308393.

Reported using DrKonqi
Comment 1 caulier.gilles 2012-12-31 10:40:01 UTC

*** This bug has been marked as a duplicate of bug 308393 ***
Comment 2 Ananta Palani 2013-02-03 22:05:01 UTC
Git commit 57b269e2d6dfd8f0c11d482ec12d3e9c126c1cd1 by Ananta Palani.
Committed on 03/02/2013 at 23:04.
Pushed by palani into branch 'master'.

Fix thumbnails not shown in Windows and excessive use of virtual memory / handles which may cause crashes and other unexpected behavior by removing file monitoring and only monitoring directories for changes. These problems might still occur with very large numbers of folders but could not be confirmed. However, medium to large collections should no longer cause a problem.
Related: bug 290962, bug 297793, bug 308310, bug 310252, bug 310865, bug 312999, bug 291917, bug 295445, bug 297686
FIXED-IN: 3.0.0

M  +9    -2    digikam/album/albumwatch.cpp

http://commits.kde.org/digikam/57b269e2d6dfd8f0c11d482ec12d3e9c126c1cd1
Comment 3 Ananta Palani 2013-02-03 22:17:07 UTC
I have made a beta compilation of digiKam 3.0.0 for you to test whether the commit I just made fixes your problem:

   https://docs.google.com/file/d/0B4Esh3gAgC9QcW5nS04zQWVsNGs/edit?usp=sharing

Can you give it a try and let me know how it works for you?
Comment 4 Laurent Soron 2013-02-06 19:54:38 UTC
I confirm that the bug is fixed with the beta version provided in the previous comment. Digikam is starting, asking for the location of the collections, crawling all the files (23.500 files of many pictures and some videos, 40Gb) without any complaint.
Thumbnails and folder are visible. Sometimes, thumbnails are not 'calculated', but the menu item "Rebuild Thumbnails..." does the Job.

The process Catalyst Control Centre still crash as soon as the digikam setup starts.

Thanks to the Digikam Team!
Comment 5 Ananta Palani 2013-02-06 21:46:17 UTC
(In reply to comment #4)
> I confirm that the bug is fixed with the beta version provided in the
> previous comment.

Great, thank you for the confirmation!

> The process Catalyst Control Centre still crash as soon as the digikam setup
> starts.

Certain versions (all versions? I kid :) of the Catalyst Control Centre are notoriously buggy, but I'm not sure why an installer would cause it to crash. Does it always crash at the same point in the installer? If so it might be something I could work on. Could you file a new bug report describing where in the installer the crash occurs?