Bug 310252 - digiKam crashes with medium to large sized collections under Microsoft Windows
Summary: digiKam crashes with medium to large sized collections under Microsoft Windows
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Database-Scan (show other bugs)
Version: 2.9.0
Platform: Microsoft Windows Microsoft Windows
: NOR critical (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-17 16:36 UTC by Laurent Espitallier
Modified: 2017-07-26 07:09 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Espitallier 2012-11-17 16:36:52 UTC
Hi,

with digikam 2.9.0 on Microsoft Windows 7 Pro 64 bits and XP 32 bits I have big problems with a medium sized pictures collection (about 22000 pictures, 700 albums, with CR2 and JPG files). When I first start digiKam, I give it the root of the collection, it then scans the content for the first time and fills the database (SQLite). But once started, digiKam displays nothing, whatever the album I select (yet everything is OK in the database : the photos have a status of 1, the albums are there, the pictures are well related to an album, etc.). If I try to leave digiKam, I see that it stays in memory (probably a crash because the process dont seem to do anything). If I kill all processes (digiKam and KDE) and then restart digiKam, at worst digiKam crashes at best it shows nothing like the first time. If I close again all processes and that I move admit half the collection apart from the collection path and I start digiKam again, it displays all the images well and naturally creates the thumbnails in the second file database ... (except for the files I moved outside the root of the collection of course). I also tried with another collection of pictures and had the same results...

If it is a bug, it is really a critical one to me as digiKam becomes unusable.

Laurent.
Comment 1 Laurent Espitallier 2012-11-22 12:14:20 UTC
Just tried with digiKam 2.3 for Win32 and it seems to work. All other versions beginning with 2.5 don't seem to work properly...
Comment 2 caulier.gilles 2012-11-22 12:46:16 UTC
It's probably due to kdelibs and co. I CC Ananta for info (the package windows stuff)

Gilles Caulier
Comment 3 caulier.gilles 2012-11-22 12:47:21 UTC
Another test will be to try 3.0.0 beta version also. Ananta has also done an installer.

Take a care, it's beta. Don't mix with stable.

Gilles Caulier
Comment 4 Dennis Grunert 2012-12-13 20:07:28 UTC
I can confirm this bug with Windows 7 64Bit, Digikam 2.9.
Comment 5 Ananta Palani 2013-02-03 22:04:55 UTC
Git commit 57b269e2d6dfd8f0c11d482ec12d3e9c126c1cd1 by Ananta Palani.
Committed on 03/02/2013 at 23:04.
Pushed by palani into branch 'master'.

Fix thumbnails not shown in Windows and excessive use of virtual memory / handles which may cause crashes and other unexpected behavior by removing file monitoring and only monitoring directories for changes. These problems might still occur with very large numbers of folders but could not be confirmed. However, medium to large collections should no longer cause a problem.
Related: bug 290962, bug 297793, bug 308310, bug 310865, bug 312422, bug 312999, bug 291917, bug 295445, bug 297686
FIXED-IN: 3.0.0

M  +9    -2    digikam/album/albumwatch.cpp

http://commits.kde.org/digikam/57b269e2d6dfd8f0c11d482ec12d3e9c126c1cd1
Comment 6 Ananta Palani 2013-02-03 22:17:41 UTC
I have made a beta compilation of digiKam 3.0.0 for you to test whether the commit I just made fixes your problem:

   https://docs.google.com/file/d/0B4Esh3gAgC9QcW5nS04zQWVsNGs/edit?usp=sharing

Can you give it a try and let me know how it works for you?