Bug 290962 - Thumbnails are never visible
Summary: Thumbnails are never visible
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Thumbs-Image (show other bugs)
Version: 2.5.0
Platform: Microsoft Windows Microsoft Windows
: NOR major (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-08 12:09 UTC by Deep-Sea
Modified: 2017-07-24 09:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Deep-Sea 2012-01-08 12:09:02 UTC
Version:           2.5.0 (using KDE 4.7.4) 
OS:                MS Windows

After the update from digiKam 2.3.0 to 2.5.0, no thumbnails are visible. All albums are shown correctly. The image count displayed after each album name is correct (same as in 2.3.0).
I think it's no duplicate of Bug 224038, because the thumbnails will not appear after pressing F5 and waiting.

Reproducible: Always

Steps to Reproduce:
Start digiKam.


Expected Results:  
Visible thumbnails.
Comment 1 Martin Klapetek 2012-01-08 12:10:57 UTC

*** This bug has been marked as a duplicate of bug 290421 ***
Comment 2 Ananta Palani 2013-02-03 21:00:11 UTC
Reopened because bug does not have the same cause as bug 290421.
Comment 3 Ananta Palani 2013-02-03 22:04:55 UTC
Git commit 57b269e2d6dfd8f0c11d482ec12d3e9c126c1cd1 by Ananta Palani.
Committed on 03/02/2013 at 23:04.
Pushed by palani into branch 'master'.

Fix thumbnails not shown in Windows and excessive use of virtual memory / handles which may cause crashes and other unexpected behavior by removing file monitoring and only monitoring directories for changes. These problems might still occur with very large numbers of folders but could not be confirmed. However, medium to large collections should no longer cause a problem.
Related: bug 297793, bug 308310, bug 310252, bug 310865, bug 312422, bug 312999, bug 291917, bug 295445, bug 297686
FIXED-IN: 3.0.0

M  +9    -2    digikam/album/albumwatch.cpp

http://commits.kde.org/digikam/57b269e2d6dfd8f0c11d482ec12d3e9c126c1cd1
Comment 4 Ananta Palani 2013-02-03 22:12:42 UTC
I have made a beta compilation of digiKam 3.0.0 for you to test whether the commit I just made fixes your problem:

   https://docs.google.com/file/d/0B4Esh3gAgC9QcW5nS04zQWVsNGs/edit?usp=sharing

Can you give it a try and let me know how it works for you?
Comment 5 Deep-Sea 2013-02-04 22:34:54 UTC
Yes, it works :-)
Comment 6 Ananta Palani 2013-02-04 22:40:06 UTC
(In reply to comment #5)
> Yes, it works :-)

Great! Glad to hear it. Thanks for your patience, and for testing.