Bug 310865 - No images displayed in the album
Summary: No images displayed in the album
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Albums-MainView (show other bugs)
Version: 2.6.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-29 11:00 UTC by Michal Thoma
Modified: 2013-02-04 14:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Thoma 2012-11-29 11:00:55 UTC
I imported first album to the freshly installed 2.9 running on Windows XP. The album was huge, so imported quite long time. Though after all importing, I can see no images, like the all album is empty.

Can be related - when I try to add new album, the digikam will not allow me to browse other directrories then it's one installation tree.

Maybe the reason also is, that album is located on the separate drive (D:/)

Reproducible: Always
Comment 1 Ananta Palani 2013-02-03 22:04:56 UTC
Git commit 57b269e2d6dfd8f0c11d482ec12d3e9c126c1cd1 by Ananta Palani.
Committed on 03/02/2013 at 23:04.
Pushed by palani into branch 'master'.

Fix thumbnails not shown in Windows and excessive use of virtual memory / handles which may cause crashes and other unexpected behavior by removing file monitoring and only monitoring directories for changes. These problems might still occur with very large numbers of folders but could not be confirmed. However, medium to large collections should no longer cause a problem.
Related: bug 290962, bug 297793, bug 308310, bug 310252, bug 312422, bug 312999, bug 291917, bug 295445, bug 297686
FIXED-IN: 3.0.0

M  +9    -2    digikam/album/albumwatch.cpp

http://commits.kde.org/digikam/57b269e2d6dfd8f0c11d482ec12d3e9c126c1cd1
Comment 2 Ananta Palani 2013-02-03 22:17:28 UTC
I have made a beta compilation of digiKam 3.0.0 for you to test whether the commit I just made fixes your problem:

   https://docs.google.com/file/d/0B4Esh3gAgC9QcW5nS04zQWVsNGs/edit?usp=sharing

Can you give it a try and let me know how it works for you?
Comment 3 Michal Thoma 2013-02-04 14:06:47 UTC
Tested on Windows 7 and works fine for me this time. Kudos to you!