Bug 312312 - Program: amarok PID: 6509 Signal: Segmentation fault (11)
Summary: Program: amarok PID: 6509 Signal: Segmentation fault (11)
Status: RESOLVED DUPLICATE of bug 302607
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-28 18:01 UTC by sAso
Modified: 2012-12-28 20:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sAso 2012-12-28 18:01:35 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.5 (4.8.5) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-35-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
it crashes imediately, was updating database, album covers

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbad66587c0 (LWP 6360))]

Thread 2 (Thread 0x7fbab29c9700 (LWP 6364)):
#0  0x00007fbad2f53303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbacdb4f036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbacdb4f164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbad38ea3bf in QEventDispatcherGlib::processEvents (this=0x7fbaac002660, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fbad38b9c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbad38b9ed7 in QEventLoop::exec (this=0x7fbab29c8cd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fbad37b8fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fbad38999ff in QInotifyFileSystemWatcherEngine::run (this=0x1c6fa60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fbad37bbfcb in QThreadPrivate::start (arg=0x1c6fa60) at thread/qthread_unix.cpp:298
#9  0x00007fbac4c6a734 in ?? () from /usr/lib/nvidia-current-updates/libGL.so.1
#10 0x00007fbacf66ce9a in start_thread (arg=0x7fbab29c9700) at pthread_create.c:308
#11 0x00007fbad2f5ecbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbad66587c0 (LWP 6360)):
[KCrash Handler]
#6  Playlist::TrackNavigator::queueIds (this=0x1e86cc0, ids=...) at ../../src/playlist/navigators/TrackNavigator.cpp:61
#7  0x00007fbad5375ddf in Playlist::TrackNavigator::queueId (this=0x1e86cc0, id=0) at ../../src/playlist/navigators/TrackNavigator.cpp:51
#8  0x00007fbad52f1b4a in Playlist::Actions::queue (this=0x1d131a0, rows=...) at ../../src/playlist/PlaylistActions.cpp:400
#9  0x00007fbad52f7129 in Playlist::Actions::restoreDefaultPlaylist (this=0x1d131a0) at ../../src/playlist/PlaylistActions.cpp:514
#10 0x00007fbad52f7670 in Playlist::Actions::instance () at ../../src/playlist/PlaylistActions.cpp:59
#11 0x00007fbad5657e89 in MainWindow::createActions (this=0x18b4510) at ../../src/MainWindow.cpp:697
#12 0x00007fbad5662c53 in MainWindow::MainWindow (this=0x18b4510) at ../../src/MainWindow.cpp:145
#13 0x00007fbad563ae6f in App::continueInit (this=0x7fff8437d180) at ../../src/App.cpp:545
#14 0x00007fbad563c55c in App::App (this=0x7fff8437d180) at ../../src/App.cpp:185
#15 0x0000000000408e45 in main (argc=1, argv=0x7fff8437f608) at ../../src/main.cpp:301

This bug may be a duplicate of or related to bug 302607.

Possible duplicates by query: bug 310171, bug 303966, bug 302650, bug 302607.

Reported using DrKonqi
Comment 1 sAso 2012-12-28 18:05:33 UTC
GREPME MySQLe query failed! (1017) Can't find file: 'albums' (errno: 2) on DELETE FROM albums WHERE id NOT IN ( SELECT album FROM tracks WHERE album IS NOT NULL )
GREPME MySQLe query failed! (1017) Can't find file: 'artists' (errno: 2) on DELETE FROM artists WHERE id NOT IN ( SELECT artist FROM tracks WHERE artist IS NOT NULL ) AND id NOT IN ( SELECT artist FROM albums WHERE artist IS NOT NULL )
GREPME MySQLe query failed! (1017) Can't find file: 'genres' (errno: 2) on DELETE FROM genres WHERE id NOT IN ( SELECT genre FROM tracks WHERE genre IS NOT NULL )
GREPME MySQLe query failed! (1017) Can't find file: 'composers' (errno: 2) on DELETE FROM composers WHERE id NOT IN ( SELECT composer FROM tracks WHERE composer IS NOT NULL )
GREPME MySQLe query failed! (1017) Can't find file: 'urls' (errno: 2) on DELETE FROM urls WHERE id NOT IN ( SELECT url FROM tracks WHERE url IS NOT NULL )
GREPME MySQLe query failed! (1017) Can't find file: 'tracks' (errno: 2) on DELETE FROM years WHERE id NOT IN ( SELECT year FROM tracks WHERE year IS NOT NULL )
Comment 2 Myriam Schweingruber 2012-12-28 20:12:18 UTC
Please upgrade to Amarok 2.6, this is already solved since quite some time. See also http://kubuntu.org/news/amarok-26

*** This bug has been marked as a duplicate of bug 302607 ***