Bug 302650 - Amarok se cierra al abrir
Summary: Amarok se cierra al abrir
Status: RESOLVED DUPLICATE of bug 302607
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-27 16:08 UTC by Gerardo Dávila
Modified: 2012-12-18 20:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerardo Dávila 2012-06-27 16:08:44 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.3 (4.8.3) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

No puedo abrir Amarok porque se Reinicia, y tira errores, help

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb5dd0740 (LWP 2666))]

Thread 7 (Thread 0xafb32b40 (LWP 2669)):
#0  0x00ed6416 in __kernel_vsyscall ()
#1  0x004a4380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x08af74c6 in ?? () from /usr/lib/i386-linux-gnu/libpulse.so.0
#3  0x08ae575a in pa_mainloop_poll () from /usr/lib/i386-linux-gnu/libpulse.so.0
#4  0x08ae5fb7 in pa_mainloop_iterate () from /usr/lib/i386-linux-gnu/libpulse.so.0
#5  0x08ae6094 in pa_mainloop_run () from /usr/lib/i386-linux-gnu/libpulse.so.0
#6  0x08af744e in ?? () from /usr/lib/i386-linux-gnu/libpulse.so.0
#7  0x04584246 in ?? () from /usr/lib/i386-linux-gnu/libpulsecommon-1.1.so
#8  0x087d7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0x004b2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 6 (Thread 0xaa667b40 (LWP 2671)):
#0  0x004a217b in read () from /lib/i386-linux-gnu/libc.so.6
#1  0x06cac6ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x06c6dbd2 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x06c6e042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x06c6e201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0498a8e7 in QEventDispatcherGlib::processEvents (this=0xa9d00488, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x0495650d in QEventLoop::processEvents (this=0xaa667240, flags=...) at kernel/qeventloop.cpp:149
#7  0x049567a9 in QEventLoop::exec (this=0xaa667240, flags=...) at kernel/qeventloop.cpp:204
#8  0x0483f94c in QThread::exec (this=0x99ee518) at thread/qthread.cpp:501
#9  0x04933b5d in QInotifyFileSystemWatcherEngine::run (this=0x99ee518) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x04842de0 in QThreadPrivate::start (arg=0x99ee518) at thread/qthread_unix.cpp:298
#11 0x087d7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x004b2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xa8ba5b40 (LWP 2672)):
#0  0x00ed6416 in __kernel_vsyscall ()
#1  0x087db96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x004c03dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x04843350 in wait (time=4294967295, this=0x9bfb650) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9bfb5a0, mutex=0x9bf5ad0, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x00ebcacc in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9bfb588, th=0x9bfb990) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x00ebf95b in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9bfb7d0, th=0x9bfb990) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x00ebc63a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9bfb588, th=0x9bfb990) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x00ebfa5c in ThreadWeaver::WorkingHardState::applyForWork (this=0x9bfb7d0, th=0x9bfb990) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00ebc533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9bfb588, th=0x9bfb990, previous=0x9d0ba08) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x00ebe4e4 in ThreadWeaver::ThreadRunHelper::run (this=0xa8ba52a4, parent=0x9bfb588, th=0x9bfb990) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x00ebe59a in ThreadWeaver::Thread::run (this=0x9bfb990) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x04842de0 in QThreadPrivate::start (arg=0x9bfb990) at thread/qthread_unix.cpp:298
#13 0x087d7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x004b2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xa83a4b40 (LWP 2673)):
#0  0x087dc873 in pthread_getspecific () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x06cad952 in g_private_get () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x06c91c84 in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x06c6e1ef in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0498a8e7 in QEventDispatcherGlib::processEvents (this=0xa9d02130, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0495650d in QEventLoop::processEvents (this=0xa83a4270, flags=...) at kernel/qeventloop.cpp:149
#6  0x049567a9 in QEventLoop::exec (this=0xa83a4270, flags=...) at kernel/qeventloop.cpp:204
#7  0x0483f94c in QThread::exec (this=0x9cbf378) at thread/qthread.cpp:501
#8  0x0483fa3b in QThread::run (this=0x9cbf378) at thread/qthread.cpp:568
#9  0x04842de0 in QThreadPrivate::start (arg=0x9cbf378) at thread/qthread_unix.cpp:298
#10 0x087d7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x004b2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa7ba3b40 (LWP 2674)):
#0  0x06cad0f2 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x06cad3c8 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x06c6d362 in g_main_context_release () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x06c6e058 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x06c6e201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0498a8e7 in QEventDispatcherGlib::processEvents (this=0xab201510, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x0495650d in QEventLoop::processEvents (this=0xa7ba3270, flags=...) at kernel/qeventloop.cpp:149
#7  0x049567a9 in QEventLoop::exec (this=0xa7ba3270, flags=...) at kernel/qeventloop.cpp:204
#8  0x0483f94c in QThread::exec (this=0x9ce1008) at thread/qthread.cpp:501
#9  0x0483fa3b in QThread::run (this=0x9ce1008) at thread/qthread.cpp:568
#10 0x04842de0 in QThreadPrivate::start (arg=0x9ce1008) at thread/qthread_unix.cpp:298
#11 0x087d7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x004b2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa6ba1b40 (LWP 2676)):
#0  0x00ed6416 in __kernel_vsyscall ()
#1  0x087db96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x004c03dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x04843350 in wait (time=4294967295, this=0x9bfb650) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9bfb5a0, mutex=0x9bf5ad0, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x00ebcacc in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9bfb588, th=0x9d0c4f8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x00ebf95b in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9bfb7d0, th=0x9d0c4f8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x00ebc63a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9bfb588, th=0x9d0c4f8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x00ebfa5c in ThreadWeaver::WorkingHardState::applyForWork (this=0x9bfb7d0, th=0x9d0c4f8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00ebc533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9bfb588, th=0x9d0c4f8, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x00ebe4e4 in ThreadWeaver::ThreadRunHelper::run (this=0xa6ba12a4, parent=0x9bfb588, th=0x9d0c4f8) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x00ebe59a in ThreadWeaver::Thread::run (this=0x9d0c4f8) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x04842de0 in QThreadPrivate::start (arg=0x9d0c4f8) at thread/qthread_unix.cpp:298
#13 0x087d7d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x004b2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb5dd0740 (LWP 2666)):
[KCrash Handler]
#7  Playlist::TrackNavigator::queueIds (this=0x9d1add8, ids=...) at ../../src/playlist/navigators/TrackNavigator.cpp:61
#8  0x010f72ce in Playlist::TrackNavigator::queueId (this=0x9d1add8, id=0) at ../../src/playlist/navigators/TrackNavigator.cpp:51
#9  0x01066dbe in Playlist::Actions::queue (this=0x9d2a5a8, rows=...) at ../../src/playlist/PlaylistActions.cpp:400
#10 0x0106c89f in Playlist::Actions::restoreDefaultPlaylist (this=0x0) at ../../src/playlist/PlaylistActions.cpp:514
#11 0x0106cd7a in Playlist::Actions::init (this=0x9d2a5a8) at ../../src/playlist/PlaylistActions.cpp:94
#12 0x0106cde8 in Playlist::Actions::instance () at ../../src/playlist/PlaylistActions.cpp:59
#13 0x0106ce24 in The::playlistActions () at ../../src/playlist/PlaylistActions.cpp:534
#14 0x01411647 in MainWindow::createActions (this=0x9954510) at ../../src/MainWindow.cpp:697
#15 0x0141c92b in MainWindow::MainWindow (this=0x9954510) at ../../src/MainWindow.cpp:145
#16 0x013f26f6 in App::continueInit (this=0xbfea3664) at ../../src/App.cpp:545
#17 0x013f3f18 in App::App (this=0xbfea3664) at ../../src/App.cpp:185
#18 0x0804fc20 in main (argc=<error reading variable: Cannot access memory at address 0x1df7dbeb>, argv=<error reading variable: Cannot access memory at address 0x1df7dbef>) at ../../src/main.cpp:301

Possible duplicates by query: bug 302607, bug 280769.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-06-28 17:42:14 UTC
English, please! Please erase this file:
$HOME/.kde/share/apps/amarok/current.xspf, your playlist queue is probably corrupt.

*** This bug has been marked as a duplicate of bug 302607 ***
Comment 2 Craig Magina 2012-12-18 20:33:50 UTC
Most recent reproduction:

Application: amarok (2.6.0)
KDE Platform Version: 4.9.90
Qt Version: 4.8.3
Operating System: Linux 3.7.0-7-generic x86_64
Distribution: Ubuntu Raring Ringtail (development branch)

The crash can be reproduced some of the time.

-- Backtrace:
A useful backtrace could not be generated

Report to https://bugs.kde.org/

Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8745a757c0 (LWP 4666))]

Thread 11 (Thread 0x7f87241a6700 (LWP 4669)):
#0  0x00007f87423cd44d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f873a6dcb6f in poll_func (ufds=0x7f8718002610, nfds=2, timeout=-1, userdata=0x14c8f10) at pulse/thread-mainloop.c:69
#2  0x00007f873a6ce0b5 in pa_mainloop_poll (m=m@entry=0x1488a40) at pulse/mainloop.c:873
#3  0x00007f873a6ce719 in pa_mainloop_iterate (m=m@entry=0x1488a40, block=block@entry=1, retval=retval@entry=0x0) at pulse/mainloop.c:955
#4  0x00007f873a6ce7d0 in pa_mainloop_run (m=0x1488a40, retval=retval@entry=0x0) at pulse/mainloop.c:973
#5  0x00007f873a6dcb1f in thread (userdata=0x14a9300) at pulse/thread-mainloop.c:88
#6  0x00007f8735da5543 in internal_thread_func (userdata=0xe1e290) at pulsecore/thread-posix.c:83
#7  0x00007f873e961f9f in start_thread (arg=0x7f87241a6700) at pthread_create.c:311
#8  0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 10 (Thread 0x7f871e8cb700 (LWP 4671)):
#0  0x00007f87423cd44d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f873ce70d64 in g_main_context_poll (n_fds=1, fds=0x7f870c001c30, timeout=-1, context=0x7f870c0009e0, priority=<optimized out>) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3584
#2  g_main_context_iterate (context=context@entry=0x7f870c0009e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3285
#3  0x00007f873ce70e84 in g_main_context_iteration (context=0x7f870c0009e0, may_block=1) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3351
#4  0x00007f8742d63c16 in QEventDispatcherGlib::processEvents (this=0x7f870c000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f8742d342bf in QEventLoop::processEvents (this=this@entry=0x7f871e8cad90, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f8742d34548 in QEventLoop::exec (this=0x7f871e8cad90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f8742c35b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f8742d149af in QInotifyFileSystemWatcherEngine::run (this=0x15b97f0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f8742c38aec in QThreadPrivate::start (arg=0x15b97f0) at thread/qthread_unix.cpp:338
#10 0x00007f873e961f9f in start_thread (arg=0x7f871e8cb700) at pthread_create.c:311
#11 0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 9 (Thread 0x7f8713885700 (LWP 4673)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:168
#1  0x00007f8742c3904b in wait (time=18446744073709551615, this=0x1bf8de0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x19d3c80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f873fedb101 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1bf9ec0, th=0x1a039b0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f873fedd94b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1bf9de0, th=0x1a039b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f873fedc7bf in ThreadWeaver::ThreadRunHelper::run (this=this@entry=0x7f8713884dc0, parent=0x1bf9ec0, th=th@entry=0x1a039b0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f873fedc84b in ThreadWeaver::Thread::run (this=0x1a039b0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f8742c38aec in QThreadPrivate::start (arg=0x1a039b0) at thread/qthread_unix.cpp:338
#8  0x00007f873e961f9f in start_thread (arg=0x7f8713885700) at pthread_create.c:311
#9  0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 8 (Thread 0x7f8713084700 (LWP 4674)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:168
#1  0x00007f8742c3904b in wait (time=18446744073709551615, this=0x1bf8de0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x19d3c80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f873fedb101 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1bf9ec0, th=0x1baf6a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f873fedd94b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1bf9de0, th=0x1baf6a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f873fedc7bf in ThreadWeaver::ThreadRunHelper::run (this=this@entry=0x7f8713083dc0, parent=0x1bf9ec0, th=th@entry=0x1baf6a0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f873fedc84b in ThreadWeaver::Thread::run (this=0x1baf6a0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f8742c38aec in QThreadPrivate::start (arg=0x1baf6a0) at thread/qthread_unix.cpp:338
#8  0x00007f873e961f9f in start_thread (arg=0x7f8713084700) at pthread_create.c:311
#9  0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 7 (Thread 0x7f8712883700 (LWP 4675)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:168
#1  0x00007f8742c3904b in wait (time=18446744073709551615, this=0x1bf8de0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x19d3c80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f873fedb101 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1bf9ec0, th=0x1bbd0c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f873fedd94b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1bf9de0, th=0x1bbd0c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f873fedc7bf in ThreadWeaver::ThreadRunHelper::run (this=this@entry=0x7f8712882dc0, parent=0x1bf9ec0, th=th@entry=0x1bbd0c0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f873fedc84b in ThreadWeaver::Thread::run (this=0x1bbd0c0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f8742c38aec in QThreadPrivate::start (arg=0x1bbd0c0) at thread/qthread_unix.cpp:338
#8  0x00007f873e961f9f in start_thread (arg=0x7f8712883700) at pthread_create.c:311
#9  0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 6 (Thread 0x7f8712082700 (LWP 4676)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:168
#1  0x00007f8742c3904b in wait (time=18446744073709551615, this=0x1bf8de0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x19d3c80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f873fedb101 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1bf9ec0, th=0x1bbadc0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f873fedd94b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1bf9de0, th=0x1bbadc0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f873fedc7bf in ThreadWeaver::ThreadRunHelper::run (this=this@entry=0x7f8712081dc0, parent=0x1bf9ec0, th=th@entry=0x1bbadc0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f873fedc84b in ThreadWeaver::Thread::run (this=0x1bbadc0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f8742c38aec in QThreadPrivate::start (arg=0x1bbadc0) at thread/qthread_unix.cpp:338
#8  0x00007f873e961f9f in start_thread (arg=0x7f8712082700) at pthread_create.c:311
#9  0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 5 (Thread 0x7f87113f3700 (LWP 4677)):
#0  g_mutex_get_impl (mutex=0x7f86f80009a0) at /build/buildd/glib2.0-2.34.3/./glib/gthread-posix.c:132
#1  0x00007f873ceaddf9 in g_mutex_lock (mutex=mutex@entry=0x7f86f80009a0) at /build/buildd/glib2.0-2.34.3/./glib/gthread-posix.c:210
#2  0x00007f873ce704b3 in g_main_context_prepare (context=context@entry=0x7f86f80009a0, priority=priority@entry=0x7f87113f2c38) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:2929
#3  0x00007f873ce70c8b in g_main_context_iterate (context=context@entry=0x7f86f80009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3270
#4  0x00007f873ce70e84 in g_main_context_iteration (context=0x7f86f80009a0, may_block=1) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3351
#5  0x00007f8742d63c16 in QEventDispatcherGlib::processEvents (this=0x7f86f80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f8742d342bf in QEventLoop::processEvents (this=this@entry=0x7f87113f2d90, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f8742d34548 in QEventLoop::exec (this=0x7f87113f2d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f8742c35b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f8742d149af in QInotifyFileSystemWatcherEngine::run (this=0x1a935c0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f8742c38aec in QThreadPrivate::start (arg=0x1a935c0) at thread/qthread_unix.cpp:338
#11 0x00007f873e961f9f in start_thread (arg=0x7f87113f3700) at pthread_create.c:311
#12 0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 4 (Thread 0x7f8703fff700 (LWP 4678)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:168
#1  0x00007f8739ac2b2d in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f873a483280 <WTF::pageheap_memory>) at wtf/FastMalloc.cpp:2499
#2  0x00007f8739ac2c39 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1622
#3  0x00007f873e961f9f in start_thread (arg=0x7f8703fff700) at pthread_create.c:311
#4  0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 3 (Thread 0x7f87037fe700 (LWP 4679)):
#0  0x00007fff7b3ff60a in ?? ()
#1  0x00007fff7b3ff8ac in clock_gettime ()
#2  0x00007f873b8a532d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#3  0x00007f8742c8e9c4 in do_gettime (frac=0x7f87037fdb18, sec=0x7f87037fdb10) at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f8742d6441d in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f86ec001f50) at kernel/qeventdispatcher_unix.cpp:343
#6  0x00007f8742d64763 in QTimerInfoList::timerWait (this=0x7f86ec001f50, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#7  0x00007f8742d632cc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f87037fdc04) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f8742d63375 in timerSourcePrepare (source=<optimized out>, timeout=timeout@entry=0x7f87037fdc04) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f873ce705f8 in g_main_context_prepare (context=context@entry=0x7f86ec0009a0, priority=priority@entry=0x7f87037fdc68) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:2986
#10 0x00007f873ce70c8b in g_main_context_iterate (context=context@entry=0x7f86ec0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3270
#11 0x00007f873ce70e84 in g_main_context_iteration (context=0x7f86ec0009a0, may_block=1) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3351
#12 0x00007f8742d63c16 in QEventDispatcherGlib::processEvents (this=0x7f86ec0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#13 0x00007f8742d342bf in QEventLoop::processEvents (this=this@entry=0x7f87037fddc0, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f8742d34548 in QEventLoop::exec (this=0x7f87037fddc0, flags=...) at kernel/qeventloop.cpp:204
#15 0x00007f8742c35b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#16 0x00007f8742c38aec in QThreadPrivate::start (arg=0x1de6e20) at thread/qthread_unix.cpp:338
#17 0x00007f873e961f9f in start_thread (arg=0x7f87037fe700) at pthread_create.c:311
#18 0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 2 (Thread 0x7f8701b3a700 (LWP 4682)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:168
#1  0x00007f873ef3acd7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f873f248660 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f873ef3ad09 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f873e961f9f in start_thread (arg=0x7f8701b3a700) at pthread_create.c:311
#4  0x00007f87423d90cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 1 (Thread 0x7f8745a757c0 (LWP 4666)):
[KCrash Handler]
#6  0x00007f86458ca030 in ?? ()
#7  0x00007f86a3cc2da0 in ?? ()
#8  0x7fffffff00000032 in ?? ()
#9  0x00007f8700646240 in ?? ()
#10 0x00007f8700000010 in ?? ()
#11 0x0000000000000003 in ?? ()
#12 0x00007f86e9b8bcb8 in ?? ()
#13 0x00007f8710012240 in ?? ()
#14 0x00007f8710007738 in ?? ()
#15 0x00007f86e9bee960 in ?? ()
#16 0x00007f871001b480 in ?? ()
#17 0x00007f86a3cbc000 in ?? ()
#18 0x00007f8710007750 in ?? ()
#19 0x00007f8700f3a060 in ?? ()
#20 0x00007f871000da88 in ?? ()
#21 0x00007f873f233d98 in QTJSC::ExecutableAllocator::pageSize () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#22 0x00007f871000c800 in ?? ()
#23 0x00007f8700f3a000 in ?? ()
#24 0x00007f871001daf0 in ?? ()
#25 0x00007f873f233d98 in QTJSC::ExecutableAllocator::pageSize () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#26 0x0000000001fdcc18 in ?? ()
#27 0x00007f8700f3a060 in ?? ()
#28 0x00007f8710007738 in ?? ()
#29 0x00007f873ee488d9 in execute (exception=0x7f871000da88, globalData=0x7f871000c800, callFrame=0x200, registerFile=0x7fff7b3bc128, this=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITCode.h:79
#30 QTJSC::Interpreter::execute (this=0x7fff7b3bc110, functionExecutable=0xffff000000000002, callFrame=0x7f8700f3a0e0, function=0x7f8700ec3a80, thisObj=<optimized out>, args=..., scopeChain=0x7f8710012240, exception=0x7f871000da88) at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:716
#31 0x00007f873eed9817 in QTJSC::JSFunction::call (this=0x7f8700ec3a80, exec=0x1fdcc18, thisValue=..., args=...) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSFunction.cpp:122
#32 0x00007f873eead1ff in QTJSC::call (exec=<optimized out>, functionObject=..., callType=<optimized out>, callData=..., thisValue=..., args=...) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:62
#33 0x00007f873efabf36 in QScript::QObjectConnectionManager::execute (this=this@entry=0x2638db0, slotIndex=<optimized out>, argv=argv@entry=0x7fff7b3bc490) at bridge/qscriptqobject.cpp:2163
#34 0x00007f873efac331 in QScript::QObjectConnectionManager::qt_metacall (this=0x2638db0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7b3bc490) at bridge/qscriptqobject.cpp:2066
#35 0x00007f8742d4b123 in QMetaObject::activate (sender=0x23b9ba0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff7b3bc490) at kernel/qobject.cpp:3566
#36 0x00007f8744a13f98 in ScriptableServiceScript::populate (this=this@entry=0x23b9ba0, _t1=_t1@entry=1, _t2=..., _t3=...) at ./AmarokScriptableServiceScript.moc:252
#37 0x00007f8744a14023 in ScriptableServiceScript::slotPopulate (this=0x23b9ba0, name=..., level=1, parent_id=-1, callbackData=..., filter=...) at ../../src/scriptengine/AmarokScriptableServiceScript.cpp:222
#38 0x00007f8744ac3637 in ScriptManager::ServiceScriptPopulate (this=0x20f4280, name=..., level=1, parent_id=-1, path=..., filter=...) at ../../src/ScriptManager.cpp:343
#39 0x00007f87446dc43a in Collections::ScriptableServiceQueryMaker::fetchAlbums (this=0x29d6610) at ../../src/services/scriptable/ScriptableServiceQueryMaker.cpp:302
#40 0x00007f8742d4a43e in QObject::event (this=0x29d6610, e=<optimized out>) at kernel/qobject.cpp:1195
#41 0x00007f8743717e9c in QApplicationPrivate::notify_helper (this=this@entry=0xe1c160, receiver=receiver@entry=0x29d6610, e=e@entry=0x2a62650) at kernel/qapplication.cpp:4562
#42 0x00007f874371c30a in QApplication::notify (this=0x7fff7b3bf2a0, receiver=0x29d6610, e=0x2a62650) at kernel/qapplication.cpp:4423
#43 0x00007f87454865b6 in KApplication::notify (this=0x7fff7b3bf2a0, receiver=0x29d6610, event=0x2a62650) at ../../kdeui/kernel/kapplication.cpp:311
#44 0x00007f8742d3556e in QCoreApplication::notifyInternal (this=0x7fff7b3bf2a0, receiver=receiver@entry=0x29d6610, event=event@entry=0x2a62650) at kernel/qcoreapplication.cpp:915
#45 0x00007f8742d393f1 in sendEvent (event=0x2a62650, receiver=0x29d6610) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#46 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xca41f0) at kernel/qcoreapplication.cpp:1539
#47 0x00007f8742d63a63 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#48 postEventSourceDispatch (s=s@entry=0xe17120) at kernel/qeventdispatcher_glib.cpp:279
#49 0x00007f873ce70a95 in g_main_dispatch (context=0xe18520) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:2715
#50 g_main_context_dispatch (context=context@entry=0xe18520) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3219
#51 0x00007f873ce70dc8 in g_main_context_iterate (context=context@entry=0xe18520, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3290
#52 0x00007f873ce70e84 in g_main_context_iteration (context=0xe18520, may_block=1) at /build/buildd/glib2.0-2.34.3/./glib/gmain.c:3351
#53 0x00007f8742d63bf6 in QEventDispatcherGlib::processEvents (this=0xca5ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#54 0x00007f87437bcc1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#55 0x00007f8742d342bf in QEventLoop::processEvents (this=this@entry=0x7fff7b3bcf60, flags=...) at kernel/qeventloop.cpp:149
#56 0x00007f8742d34548 in QEventLoop::exec (this=0x7fff7b3bcf60, flags=...) at kernel/qeventloop.cpp:204
#57 0x00007f8742d39708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#58 0x0000000000408e1a in main (argc=1, argv=0x7fff7b3bf408) at ../../src/main.cpp:306
Comment 3 Craig Magina 2012-12-18 20:36:17 UTC
(In reply to comment #2)
Sorry, meant to post this to bug 310228 (the auto-move to next bug after making a change to a bug bit me again).