Bug 303966 - amarok crashes on starting
Summary: amarok crashes on starting
Status: RESOLVED DUPLICATE of bug 302607
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-23 16:10 UTC by chinmayanand
Modified: 2012-07-25 03:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chinmayanand 2012-07-23 16:10:37 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic x86_64
Distribution: Linux Mint 13 Maya

-- Information about the crash:
It started after i installed updates. after installing updates on next boot i started it but it crashed. tried purging & reinstalling but not worked.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5be572c7c0 (LWP 4767))]

Thread 6 (Thread 0x7f5bc1aed700 (LWP 4782)):
#0  0x00007f5be2018b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5bda47535f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007f5bda46676c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f5bda466dd9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f5bda466e90 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f5bda47530f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f5bd58bad18 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
#7  0x00007f5bde735e9a in start_thread (arg=0x7f5bc1aed700) at pthread_create.c:308
#8  0x00007f5be20244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f5bb5874700 (LWP 4784)):
#0  0x00007f5be2018b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5bdcc18036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5bdcc18164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5be29af426 in QEventDispatcherGlib::processEvents (this=0x7f5ba4000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f5be297ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5be297eed7 in QEventLoop::exec (this=0x7f5bb5873d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f5be287dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f5be295e9ff in QInotifyFileSystemWatcherEngine::run (this=0x1268280) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f5be2880fcb in QThreadPrivate::start (arg=0x1268280) at thread/qthread_unix.cpp:298
#9  0x00007f5bde735e9a in start_thread (arg=0x7f5bb5874700) at pthread_create.c:308
#10 0x00007f5be20244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f5bab4b3700 (LWP 4785)):
#0  0x00007f5be2018b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5bdcc18036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5bdcc18164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5be29af426 in QEventDispatcherGlib::processEvents (this=0x7f5b9c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f5be297ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5be297eed7 in QEventLoop::exec (this=0x7f5bab4b2dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f5be287dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f5be2880fcb in QThreadPrivate::start (arg=0x13620a0) at thread/qthread_unix.cpp:298
#8  0x00007f5bde735e9a in start_thread (arg=0x7f5bab4b3700) at pthread_create.c:308
#9  0x00007f5be20244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5baa013700 (LWP 4786)):
#0  0x00007f5bde73905d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f5ba0000a60) at pthread_mutex_unlock.c:290
#2  0x00007f5bdcc535d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5bdcc1783b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5bdcc17f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5bdcc18164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f5be29af426 in QEventDispatcherGlib::processEvents (this=0x7f5ba00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007f5be297ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f5be297eed7 in QEventLoop::exec (this=0x7f5baa012dc0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f5be287dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#10 0x00007f5be2880fcb in QThreadPrivate::start (arg=0x13be580) at thread/qthread_unix.cpp:298
#11 0x00007f5bde735e9a in start_thread (arg=0x7f5baa013700) at pthread_create.c:308
#12 0x00007f5be20244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5ba8c06700 (LWP 4788)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:160
#1  0x00007f5be28814db in wait (time=18446744073709551615, this=0x14176c0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1417840, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f5bdfcca0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1417570, th=0x1418fa0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f5bdfccc9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1417910, th=0x1418fa0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f5bdfccb84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5ba8c05de0, parent=0x1417570, th=0x1418fa0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f5bdfccb8db in ThreadWeaver::Thread::run (this=0x1418fa0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f5be2880fcb in QThreadPrivate::start (arg=0x1418fa0) at thread/qthread_unix.cpp:298
#8  0x00007f5bde735e9a in start_thread (arg=0x7f5ba8c06700) at pthread_create.c:308
#9  0x00007f5be20244bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5be572c7c0 (LWP 4767)):
[KCrash Handler]
#6  Playlist::TrackNavigator::queueIds (this=0x1435a70, ids=...) at ../../src/playlist/navigators/TrackNavigator.cpp:61
#7  0x00007f5be443bddf in Playlist::TrackNavigator::queueId (this=0x1435a70, id=0) at ../../src/playlist/navigators/TrackNavigator.cpp:51
#8  0x00007f5be43b7b4a in Playlist::Actions::queue (this=0x1430150, rows=...) at ../../src/playlist/PlaylistActions.cpp:400
#9  0x00007f5be43bd129 in Playlist::Actions::restoreDefaultPlaylist (this=0x1430150) at ../../src/playlist/PlaylistActions.cpp:514
#10 0x00007f5be43bd670 in Playlist::Actions::instance () at ../../src/playlist/PlaylistActions.cpp:59
#11 0x00007f5be471de89 in MainWindow::createActions (this=0x11a19b0) at ../../src/MainWindow.cpp:697
#12 0x00007f5be4728c53 in MainWindow::MainWindow (this=0x11a19b0) at ../../src/MainWindow.cpp:145
#13 0x00007f5be4700e6f in App::continueInit (this=0x7fff73f09d50) at ../../src/App.cpp:545
#14 0x00007f5be470255c in App::App (this=0x7fff73f09d50) at ../../src/App.cpp:185
#15 0x0000000000408e45 in main (argc=2, argv=0x7fff73f0c1d8) at ../../src/main.cpp:301

This bug may be a duplicate of or related to bug 302607.

Possible duplicates by query: bug 302650, bug 302607, bug 280769.

Reported using DrKonqi
Comment 1 Dario Cambié 2012-07-23 21:01:09 UTC
Definitely a duplicate of bug 302607.
Comment 2 Myriam Schweingruber 2012-07-25 03:22:59 UTC

*** This bug has been marked as a duplicate of bug 302607 ***