Bug 310171 - crash
Summary: crash
Status: RESOLVED DUPLICATE of bug 302607
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-15 20:14 UTC by antonio
Modified: 2012-11-15 23:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description antonio 2012-11-15 20:14:39 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-33-generic-pae i686
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed: i have installed ubuntu actualizations. The aplication doesnt start again

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1121740 (LWP 5004))]

Thread 8 (Thread 0xae967b40 (LWP 5005)):
#0  0xb7710424 in __kernel_vsyscall ()
#1  0xb562b5f0 in __GI___poll (fds=0xae000c78, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb4375a7b in g_poll (fds=0xae000c78, nfds=1, timeout=-1) at /build/buildd/glib2.0-2.32.3/./glib/gpoll.c:132
#3  0xb43680ae in g_main_context_poll (n_fds=1, fds=0xae000c78, timeout=<optimized out>, context=0x8a6e800, priority=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3440
#4  g_main_context_iterate (dispatch=1, block=-1271440816, context=0x8a6e800, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3141
#5  g_main_context_iterate (context=0x8a6e800, block=-1271440816, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#6  0xb436856b in g_main_loop_run (loop=0xae000c68) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3340
#7  0xae9c5134 in ?? () from /usr/lib/i386-linux-gnu/gio/modules/libdconfsettings.so
#8  0xb438b6b3 in g_thread_proxy (data=0x8a6afb0) at /build/buildd/glib2.0-2.32.3/./glib/gthread.c:801
#9  0xb4677d4c in start_thread (arg=0xae967b40) at pthread_create.c:308
#10 0xb5639d3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 7 (Thread 0xadfffb40 (LWP 5006)):
#0  0xb7710424 in __kernel_vsyscall ()
#1  0xb562b5f0 in __GI___poll (fds=0xad602298, nfds=3, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb4375a7b in g_poll (fds=0xad602298, nfds=3, timeout=-1) at /build/buildd/glib2.0-2.32.3/./glib/gpoll.c:132
#3  0xb43680ae in g_main_context_poll (n_fds=3, fds=0xad602298, timeout=<optimized out>, context=0xae00ada8, priority=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3440
#4  g_main_context_iterate (dispatch=1, block=-1271440816, context=0xae00ada8, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3141
#5  g_main_context_iterate (context=0xae00ada8, block=-1271440816, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#6  0xb436856b in g_main_loop_run (loop=0xae00ad80) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3340
#7  0xaf6d31ba in gdbus_shared_thread_func (user_data=0xae00ad90) at /build/buildd/glib2.0-2.32.3/./gio/gdbusprivate.c:277
#8  0xb438b6b3 in g_thread_proxy (data=0xae005490) at /build/buildd/glib2.0-2.32.3/./glib/gthread.c:801
#9  0xb4677d4c in start_thread (arg=0xadfffb40) at pthread_create.c:308
#10 0xb5639d3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 6 (Thread 0xa7adeb40 (LWP 5010)):
#0  0xb7710424 in __kernel_vsyscall ()
#1  0xb562b5f0 in __GI___poll (fds=0xa3100b60, nfds=2, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb3fa2e76 in ?? () from /usr/lib/i386-linux-gnu/libpulse.so.0
#3  0xb3f9110a in pa_mainloop_poll () from /usr/lib/i386-linux-gnu/libpulse.so.0
#4  0xb3f91967 in pa_mainloop_iterate () from /usr/lib/i386-linux-gnu/libpulse.so.0
#5  0xb3f91a44 in pa_mainloop_run () from /usr/lib/i386-linux-gnu/libpulse.so.0
#6  0xb3fa2dfe in ?? () from /usr/lib/i386-linux-gnu/libpulse.so.0
#7  0xb1c7d916 in ?? () from /usr/lib/i386-linux-gnu/pulseaudio/libpulsecommon-2.0.so
#8  0xb4677d4c in start_thread (arg=0xa7adeb40) at pthread_create.c:308
#9  0xb5639d3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 5 (Thread 0xa657db40 (LWP 5012)):
#0  0xb7710424 in __kernel_vsyscall ()
#1  0xb562b5f0 in __GI___poll (fds=0xa5c02098, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb4375a7b in g_poll (fds=0xa5c02098, nfds=1, timeout=-1) at /build/buildd/glib2.0-2.32.3/./glib/gpoll.c:132
#3  0xb43680ae in g_main_context_poll (n_fds=1, fds=0xa5c02098, timeout=<optimized out>, context=0xa5c00500, priority=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3440
#4  g_main_context_iterate (dispatch=1, block=-1271440816, context=0xa5c00500, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3141
#5  g_main_context_iterate (context=0xa5c00500, block=-1271440816, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#6  0xb4368201 in g_main_context_iteration (context=0xa5c00500, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#7  0xb59a88e7 in QEventDispatcherGlib::processEvents (this=0xa5c00488, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#8  0xb597450d in QEventLoop::processEvents (this=0xa657d240, flags=...) at kernel/qeventloop.cpp:149
#9  0xb59747a9 in QEventLoop::exec (this=0xa657d240, flags=...) at kernel/qeventloop.cpp:204
#10 0xb585d94c in QThread::exec (this=0x8facfa8) at thread/qthread.cpp:501
#11 0xb5951b5d in QInotifyFileSystemWatcherEngine::run (this=0x8facfa8) at io/qfilesystemwatcher_inotify.cpp:248
#12 0xb5860de0 in QThreadPrivate::start (arg=0x8facfa8) at thread/qthread_unix.cpp:298
#13 0xb4677d4c in start_thread (arg=0xa657db40) at pthread_create.c:308
#14 0xb5639d3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 4 (Thread 0xa4adeb40 (LWP 5013)):
#0  0xb4191dcd in __GI_clock_gettime (clock_id=1, tp=0xa4addfe8) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb58bf315 in do_gettime (frac=0xa4addfe0, sec=0xa4addfd8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb59a9226 in QTimerInfoList::updateCurrentTime (this=0xa4101c74) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb59a957a in QTimerInfoList::timerWait (this=0xa4101c74, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb59a7e23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa4ade0ec) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb59a7ebd in timerSourcePrepare (source=0xa4101c40, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb4367872 in g_main_context_prepare (context=0xa41004e0, priority=0xa4ade148) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:2836
#8  0xb4367faf in g_main_context_iterate (dispatch=1, block=1, context=0xa41004e0, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3126
#9  g_main_context_iterate (context=0xa41004e0, block=1, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#10 0xb4368201 in g_main_context_iteration (context=0xa41004e0, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#11 0xb59a88e7 in QEventDispatcherGlib::processEvents (this=0xa4100468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0xb597450d in QEventLoop::processEvents (this=0xa4ade270, flags=...) at kernel/qeventloop.cpp:149
#13 0xb59747a9 in QEventLoop::exec (this=0xa4ade270, flags=...) at kernel/qeventloop.cpp:204
#14 0xb585d94c in QThread::exec (this=0x916d330) at thread/qthread.cpp:501
#15 0xb585da3b in QThread::run (this=0x916d330) at thread/qthread.cpp:568
#16 0xb5860de0 in QThreadPrivate::start (arg=0x916d330) at thread/qthread_unix.cpp:298
#17 0xb4677d4c in start_thread (arg=0xa4adeb40) at pthread_create.c:308
#18 0xb5639d3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xa3efeb40 (LWP 5014)):
#0  0xb4191dcd in __GI_clock_gettime (clock_id=1, tp=0xa3efe048) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb58bf315 in do_gettime (frac=0xa3efe040, sec=0xa3efe038) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb59a9226 in QTimerInfoList::updateCurrentTime (this=0xa3501574) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb59a8e16 in timerSourceCheckHelper (src=0xa3501540) at kernel/qeventdispatcher_glib.cpp:150
#5  timerSourceCheckHelper (src=0xa3501540) at kernel/qeventdispatcher_glib.cpp:144
#6  0xb4367b7b in g_main_context_check (context=0xa35004e0, max_priority=2147483647, fds=0xa350ed90, n_fds=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3023
#7  0xb4368042 in g_main_context_iterate (dispatch=1, block=-1271440816, context=0xa35004e0, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3143
#8  g_main_context_iterate (context=0xa35004e0, block=-1271440816, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#9  0xb4368201 in g_main_context_iteration (context=0xa35004e0, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#10 0xb59a88e7 in QEventDispatcherGlib::processEvents (this=0xa3500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb597450d in QEventLoop::processEvents (this=0xa3efe270, flags=...) at kernel/qeventloop.cpp:149
#12 0xb59747a9 in QEventLoop::exec (this=0xa3efe270, flags=...) at kernel/qeventloop.cpp:204
#13 0xb585d94c in QThread::exec (this=0x918d7b8) at thread/qthread.cpp:501
#14 0xb585da3b in QThread::run (this=0x918d7b8) at thread/qthread.cpp:568
#15 0xb5860de0 in QThreadPrivate::start (arg=0x918d7b8) at thread/qthread_unix.cpp:298
#16 0xb4677d4c in start_thread (arg=0xa3efeb40) at pthread_create.c:308
#17 0xb5639d3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0x9e8fdb40 (LWP 5016)):
#0  0xb7710424 in __kernel_vsyscall ()
#1  0xb467b96b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0xb564764c in __pthread_cond_wait (cond=0x91aabd8, mutex=0x91aabc0) at forward.c:139
#3  0xb5861350 in wait (time=4294967295, this=0x91aabc0) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x91aab10, mutex=0x91aace0, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb4dd0acc in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x91aaaf8, th=0x91aaf40) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb4dd395b in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x91aad80, th=0x91aaf40) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb4dd063a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x91aaaf8, th=0x91aaf40) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb4dd3a5c in ThreadWeaver::WorkingHardState::applyForWork (this=0x91aad80, th=0x91aaf40) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb4dd0533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x91aaaf8, th=0x91aaf40, previous=0x91a9f60) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb4dd24e4 in ThreadWeaver::ThreadRunHelper::run (this=0x9e8fd2a4, parent=0x91aaaf8, th=0x91aaf40) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb4dd259a in ThreadWeaver::Thread::run (this=0x91aaf40) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb5860de0 in QThreadPrivate::start (arg=0x91aaf40) at thread/qthread_unix.cpp:298
#13 0xb4677d4c in start_thread (arg=0x9e8fdb40) at pthread_create.c:308
#14 0xb5639d3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb1121740 (LWP 5004)):
[KCrash Handler]
#7  Playlist::TrackNavigator::queueIds (this=0x91d1f78, ids=...) at ../../src/playlist/navigators/TrackNavigator.cpp:61
#8  0xb6bce2ce in Playlist::TrackNavigator::queueId (this=0x91d1f78, id=0) at ../../src/playlist/navigators/TrackNavigator.cpp:51
#9  0xb6b3ddbe in Playlist::Actions::queue (this=0x91d2650, rows=...) at ../../src/playlist/PlaylistActions.cpp:400
#10 0xb6b4389f in Playlist::Actions::restoreDefaultPlaylist (this=0x0) at ../../src/playlist/PlaylistActions.cpp:514
#11 0xb6b43d7a in Playlist::Actions::init (this=0x91d2650) at ../../src/playlist/PlaylistActions.cpp:94
#12 0xb6b43de8 in Playlist::Actions::instance () at ../../src/playlist/PlaylistActions.cpp:59
#13 0xb6b43e24 in The::playlistActions () at ../../src/playlist/PlaylistActions.cpp:534
#14 0xb6ee8647 in MainWindow::createActions (this=0x8b26ce0) at ../../src/MainWindow.cpp:697
#15 0xb6ef392b in MainWindow::MainWindow (this=0x8b26ce0) at ../../src/MainWindow.cpp:145
#16 0xb6ec96f6 in App::continueInit (this=0xbfb9f064) at ../../src/App.cpp:545
#17 0xb6ecaf18 in App::App (this=0xbfb9f064) at ../../src/App.cpp:185
#18 0x0804fc20 in main (argc=153822888, argv=0xffffffff) at ../../src/main.cpp:301

Possible duplicates by query: bug 303966, bug 302650, bug 302607.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-11-15 23:18:33 UTC
Please upgrade to Amarok 2.6, this is solved since quite some time now.

*** This bug has been marked as a duplicate of bug 302607 ***