Bug 308420 - kmail4 crashed opening encrypted email
Summary: kmail4 crashed opening encrypted email
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.9.2
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-15 01:33 UTC by Steve
Modified: 2012-10-15 05:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2012-10-15 01:33:35 UTC
Application: kontact (4.9.2)
KDE Platform Version: 4.9.2
Qt Version: 4.8.2
Operating System: Linux 3.6.1-1.fc17.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
Opening email. First attempt I forgot to enter my password. It failed and asked If I want to try again. I did and typed the password and it crashed. immediately.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f8f56fed880 (LWP 2209))]

Thread 3 (Thread 0x7f8f44b71700 (LWP 2210)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007f8f6db8877d in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f8f6e572980) at wtf/FastMalloc.cpp:2495
#2  0x00007f8f6db88889 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f8f68972d14 in start_thread (arg=0x7f8f44b71700) at pthread_create.c:309
#4  0x00007f8f67c1767d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f8f44370700 (LWP 2211)):
#0  0x00007f8f657409b1 in g_mutex_unlock (mutex=mutex@entry=0x7f8f3c0009a0) at gthread-posix.c:227
#1  0x00007f8f65704a0e in g_main_context_iterate (context=context@entry=0x7f8f3c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3124
#2  0x00007f8f65704c14 in g_main_context_iteration (context=0x7f8f3c0009a0, may_block=1) at gmain.c:3207
#3  0x00007f8f68d2b4e6 in QEventDispatcherGlib::processEvents (this=0x7f8f3c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f8f68cfc10f in QEventLoop::processEvents (this=this@entry=0x7f8f4436fd20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8f68cfc398 in QEventLoop::exec (this=0x7f8f4436fd20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f8f68bff650 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f8f68c025eb in QThreadPrivate::start (arg=0x14d7e10) at thread/qthread_unix.cpp:307
#8  0x00007f8f68972d14 in start_thread (arg=0x7f8f44370700) at pthread_create.c:309
#9  0x00007f8f67c1767d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f8f56fed880 (LWP 2209)):
[KCrash Handler]
#6  0x00007f8f62d9de84 in KMime::Content::parent (this=0x53b0aa0) at /usr/src/debug/kdepimlibs-4.9.2/kmime/kmime_content.cpp:949
#7  0x00007f8eead42336 in MessageCore::NodeHelper::nextSibling (node=0x53b0aa0) at /usr/src/debug/kdepim-4.9.2/messagecore/nodehelper.cpp:32
#8  0x00007f8ee8d54b64 in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0x7fffaef8e870, node=0x53b0aa0) at /usr/src/debug/kdepim-4.9.2/messageviewer/objecttreeparser.cpp:296
#9  0x00007f8ee8d8a3d0 in MessageViewer::ViewerPrivate::parseContent (this=this@entry=0x1cbbe90, content=0x53b0aa0) at /usr/src/debug/kdepim-4.9.2/messageviewer/viewer_p.cpp:1022
#10 0x00007f8ee8d8bc9c in MessageViewer::ViewerPrivate::displayMessage (this=this@entry=0x1cbbe90) at /usr/src/debug/kdepim-4.9.2/messageviewer/viewer_p.cpp:894
#11 0x00007f8ee8d8c1b6 in MessageViewer::ViewerPrivate::updateReaderWin (this=0x1cbbe90) at /usr/src/debug/kdepim-4.9.2/messageviewer/viewer_p.cpp:2251
#12 0x00007f8ee8d8eefa in MessageViewer::ViewerPrivate::qt_static_metacall (_o=0x1cbbe90, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdepim-4.9.2/x86_64-redhat-linux-gnu/messageviewer/viewer_p.moc:229
#13 0x00007f8f68d13b6f in QMetaObject::activate (sender=0x1cbbf20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#14 0x00007f8f68d11aec in QObject::event (this=0x1cbbf20, e=<optimized out>) at kernel/qobject.cpp:1157
#15 0x00007f8f6994437c in QApplicationPrivate::notify_helper (this=this@entry=0x14c9aa0, receiver=receiver@entry=0x1cbbf20, e=e@entry=0x7fffaef8f2a0) at kernel/qapplication.cpp:4551
#16 0x00007f8f699487fa in QApplication::notify (this=0x7fffaef8f6a0, receiver=0x1cbbf20, e=0x7fffaef8f2a0) at kernel/qapplication.cpp:4412
#17 0x00007f8f6a6618a6 in KApplication::notify (this=0x7fffaef8f6a0, receiver=0x1cbbf20, event=0x7fffaef8f2a0) at /usr/src/debug/kdelibs-4.9.2/kdeui/kernel/kapplication.cpp:311
#18 0x00007f8f68cfd3be in QCoreApplication::notifyInternal (this=0x7fffaef8f6a0, receiver=0x1cbbf20, event=0x7fffaef8f2a0) at kernel/qcoreapplication.cpp:915
#19 0x00007f8f68d2dd32 in sendEvent (event=0x7fffaef8f2a0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#20 QTimerInfoList::activateTimers (this=0x14d20d0) at kernel/qeventdispatcher_unix.cpp:611
#21 0x00007f8f68d2ae54 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#22 timerSourceDispatch (source=source@entry=0x14d2070) at kernel/qeventdispatcher_glib.cpp:180
#23 0x00007f8f65704825 in g_main_dispatch (context=0x14d0f00) at gmain.c:2539
#24 g_main_context_dispatch (context=context@entry=0x14d0f00) at gmain.c:3075
#25 0x00007f8f65704b58 in g_main_context_iterate (context=context@entry=0x14d0f00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#26 0x00007f8f65704c14 in g_main_context_iteration (context=0x14d0f00, may_block=1) at gmain.c:3207
#27 0x00007f8f68d2b4c6 in QEventDispatcherGlib::processEvents (this=0x1496ee0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007f8f699e41ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#29 0x00007f8f68cfc10f in QEventLoop::processEvents (this=this@entry=0x7fffaef8f510, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f8f68cfc398 in QEventLoop::exec (this=0x7fffaef8f510, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007f8f68d01188 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#32 0x00000000004033f9 in main (argc=1, argv=0x7fffaef8f7e8) at /usr/src/debug/kdepim-4.9.2/kontact/src/main.cpp:219

Possible duplicates by query: bug 307425, bug 294612, bug 291135, bug 284521.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-10-15 05:59:37 UTC

*** This bug has been marked as a duplicate of bug 279749 ***