Bug 284521 - kontact crashes when opening a folder with encrypted messages for the first time
Summary: kontact crashes when opening a folder with encrypted messages for the first time
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.7.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-20 07:58 UTC by Hartmut Manz
Modified: 2011-10-20 11:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hartmut Manz 2011-10-20 07:58:20 UTC
Application: kontact (4.7.2)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I have a folder with encrypted messages.

When opening this folder the first time after logging in or when opening it with a new encrypted message it crashes.

After restarting kmail (but without logging off) i can read the encrypted mail.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc63d48b7a0 (LWP 15405))]

Thread 4 (Thread 0x7fc623d6b700 (LWP 15406)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fc639cecc2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fc639cecd59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fc6350ebefc in start_thread (arg=0x7fc623d6b700) at pthread_create.c:304
#4  0x00007fc63a9fa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fc62346a700 (LWP 15407)):
#0  0x00007fc63a9ee773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc63461df68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc63461e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc63be35f3e in QEventDispatcherGlib::processEvents (this=0x25c2e50, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc63be09cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc63be09ef7 in QEventLoop::exec (this=0x7fc623469de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc63bd2127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fc63bd23d05 in QThreadPrivate::start (arg=0x25c2500) at thread/qthread_unix.cpp:331
#8  0x00007fc6350ebefc in start_thread (arg=0x7fc62346a700) at pthread_create.c:304
#9  0x00007fc63a9fa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc5cfa18700 (LWP 15412)):
#0  0x00007fc63a9ee773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc63461df68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc63461e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc63be35f3e in QEventDispatcherGlib::processEvents (this=0x55e6800, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc63be09cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc63be09ef7 in QEventLoop::exec (this=0x7fc5cfa17db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc63bd2127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fc63bdeccbf in QInotifyFileSystemWatcherEngine::run (this=0x54c91c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc63bd23d05 in QThreadPrivate::start (arg=0x54c91c0) at thread/qthread_unix.cpp:331
#9  0x00007fc6350ebefc in start_thread (arg=0x7fc5cfa18700) at pthread_create.c:304
#10 0x00007fc63a9fa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc63d48b7a0 (LWP 15405)):
[KCrash Handler]
#6  0x00007fc631ce7164 in KMime::Content::parent (this=0x5c134e0) at ../../kmime/kmime_content.cpp:921
#7  0x00007fc5da84a995 in MessageCore::NodeHelper::nextSibling (node=0x5c134e0) at ../../messagecore/nodehelper.cpp:32
#8  0x00007fc5d9166067 in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0x7fff9591f1e0, node=0x5c134e0) at ../../messageviewer/objecttreeparser.cpp:278
#9  0x00007fc5d919a8df in MessageViewer::ViewerPrivate::parseContent (this=0x2d74970, content=0x5c134e0) at ../../messageviewer/viewer_p.cpp:857
#10 0x00007fc5d919d434 in MessageViewer::ViewerPrivate::displayMessage (this=0x2d74970) at ../../messageviewer/viewer_p.cpp:729
#11 0x00007fc5d919dce2 in MessageViewer::ViewerPrivate::updateReaderWin (this=0x2d74970) at ../../messageviewer/viewer_p.cpp:1946
#12 0x00007fc5d91a118d in MessageViewer::ViewerPrivate::qt_metacall (this=0x2d74970, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0x7fff9591f6a0) at ./viewer_p.moc:220
#13 0x00007fc63be1deba in QMetaObject::activate (sender=0x2d749f8, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#14 0x00007fc63be21789 in QObject::event (this=0x2d749f8, e=<optimized out>) at kernel/qobject.cpp:1181
#15 0x00007fc63b1bb424 in notify_helper (e=0x7fff9591fc00, receiver=0x2d749f8, this=0x2468870) at kernel/qapplication.cpp:4486
#16 QApplicationPrivate::notify_helper (this=0x2468870, receiver=0x2d749f8, e=0x7fff9591fc00) at kernel/qapplication.cpp:4458
#17 0x00007fc63b1c0291 in QApplication::notify (this=0x7fff9591ff00, receiver=0x2d749f8, e=0x7fff9591fc00) at kernel/qapplication.cpp:4365
#18 0x00007fc63c840126 in KApplication::notify (this=0x7fff9591ff00, receiver=0x2d749f8, event=0x7fff9591fc00) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007fc63be0aafc in QCoreApplication::notifyInternal (this=0x7fff9591ff00, receiver=0x2d749f8, event=0x7fff9591fc00) at kernel/qcoreapplication.cpp:787
#20 0x00007fc63be37d62 in sendEvent (event=0x7fff9591fc00, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QTimerInfoList::activateTimers (this=0x247cc60) at kernel/qeventdispatcher_unix.cpp:603
#22 0x00007fc63be35514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#23 0x00007fc63461da5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fc63461e258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fc63461e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fc63be35ed6 in QEventDispatcherGlib::processEvents (this=0x2468690, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#27 0x00007fc63b26307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fc63be09cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007fc63be09ef7 in QEventLoop::exec (this=0x7fff9591fe90, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007fc63be0e789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#31 0x0000000000403629 in main (argc=1, argv=0x7fff95920528) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 279749.

Possible duplicates by query: bug 279749.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-10-20 11:00:41 UTC

*** This bug has been marked as a duplicate of bug 279749 ***