Bug 307425 - Kmail crashes when I try to open a GPG encrypted mail
Summary: Kmail crashes when I try to open a GPG encrypted mail
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-26 06:21 UTC by Andreas Zuber
Modified: 2012-09-26 07:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Zuber 2012-09-26 06:21:51 UTC
Application: kontact (4.8.5)
KDE Platform Version: 4.8.5 (4.8.5) (Compiled from sources)
Qt Version: 4.8.2
Operating System: Linux 2.6.38-gentoo-r6 x86_64
Distribution: "Gentoo Base System release 2.1"

-- Information about the crash:
- What I was doing when the application crashed:

* Go to the Folder where a new Mail arrived
* A Dialog for the Passphrase appears
* Enter Passphrase and press ok
* Kmail crashes

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5fc2b82780 (LWP 6963))]

Thread 5 (Thread 0x7f5faabfa700 (LWP 6964)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5fbf2f1f26 in ?? () from /usr/lib64/qt4/libQtWebKit.so.4
#2  0x00007f5fbf2f1f55 in ?? () from /usr/lib64/qt4/libQtWebKit.so.4
#3  0x00007f5fbaa26b77 in start_thread (arg=0x7f5faabfa700) at pthread_create.c:305
#4  0x00007f5fc0065bbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f5faa2f9700 (LWP 6965)):
#0  0xffffffffff600132 in ?? ()
#1  0x00007fffd5fd8771 in ?? ()
#2  0x00007f5fb9ad4540 in *__GI_clock_gettime (clock_id=1, tp=0x7f5faa2f8b40) at ../sysdeps/unix/clock_gettime.c:100
#3  0x00007f5fc14109b2 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f5fc14e3a57 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f5fc14e3d6d in ?? () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f5fc14e287e in ?? () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f5fc14e2904 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007f5fb97f6a8e in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f5fb97f7800 in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f5fb97f7d94 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007f5fc14e2fd2 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007f5fc14b3d58 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00007f5fc14b3f98 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#14 0x00007f5fc13b7a6d in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#15 0x00007f5fc13b9bf9 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007f5fbaa26b77 in start_thread (arg=0x7f5faa2f9700) at pthread_create.c:305
#17 0x00007f5fc0065bbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f5f5ef69700 (LWP 7021)):
#0  pthread_cond_timedwait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f5fc13baa67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f5fc13af0c5 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f5fc13b9bf9 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f5fbaa26b77 in start_thread (arg=0x7f5f5ef69700) at pthread_create.c:305
#5  0x00007f5fc0065bbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f5f5d912700 (LWP 7023)):
#0  pthread_cond_timedwait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f5fc13baa67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f5fc13af0c5 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f5fc13b9bf9 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f5fbaa26b77 in start_thread (arg=0x7f5f5d912700) at pthread_create.c:305
#5  0x00007f5fc0065bbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f5fc2b82780 (LWP 6963)):
[KCrash Handler]
#6  KMime::Content::parent (this=0x36c9b10) at /var/tmp/portage/kde-base/kdepimlibs-4.8.5/work/kdepimlibs-4.8.5/kmime/kmime_content.cpp:927
#7  0x00007f5f62e30dcc in MessageCore::NodeHelper::nextSibling (node=0x36c9b10) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5/messagecore/nodehelper.cpp:32
#8  0x00007f5f616fe5fc in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0x7fffd5f1c9d0, node=0x36c9b10) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5/messageviewer/objecttreeparser.cpp:296
#9  0x00007f5f616fefbc in MessageViewer::ObjectTreeParser::stdChildHandling (this=0x7fffd5f1cc90, child=0x36c9b10) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5/messageviewer/objecttreeparser.cpp:1445
#10 0x00007f5f616ff323 in MessageViewer::ObjectTreeParser::processMultiPartMixedSubtype (this=0x7fffd5f1cc90, node=0x3ff24c0) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5/messageviewer/objecttreeparser.cpp:1478
#11 0x00007f5f616fe7bc in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0x7fffd5f1cc90, node=0x3ff24c0) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5/messageviewer/objecttreeparser.cpp:353
#12 0x00007f5f6172f9e4 in MessageViewer::ViewerPrivate::parseContent (this=0xc03e50, content=0x3ff24c0) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5/messageviewer/viewer_p.cpp:918
#13 0x00007f5f61732081 in MessageViewer::ViewerPrivate::displayMessage (this=0xc03e50) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5/messageviewer/viewer_p.cpp:790
#14 0x00007f5f617326cf in MessageViewer::ViewerPrivate::updateReaderWin (this=0xc03e50) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5/messageviewer/viewer_p.cpp:2089
#15 0x00007f5f617353aa in MessageViewer::ViewerPrivate::qt_static_metacall (_o=0xc03e50, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /var/tmp/portage/kde-base/kdepim-common-libs-4.8.5/work/kdepim-common-libs-4.8.5_build/messageviewer/viewer_p.moc:208
#16 0x00007f5fc14cb9f6 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#17 0x00007f5fc14c9a97 in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#18 0x00007f5fc07f314d in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007f5fc07f7ec8 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007f5fc1f430f0 in KApplication::notify (this=0x7fffd5f1dcb0, receiver=0xc03ed8, event=0x7fffd5f1d960) at /var/tmp/portage/kde-base/kdelibs-4.8.5/work/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#21 0x00007f5fc14b5624 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007f5fc14e5c8a in ?? () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007f5fc14e292d in ?? () from /usr/lib64/qt4/libQtCore.so.4
#24 0x00007f5fb97f7492 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f5fb97f7bd8 in ?? () from /usr/lib64/libglib-2.0.so.0
#26 0x00007f5fb97f7d94 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f5fc14e2f9a in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#28 0x00007f5fc089525a in ?? () from /usr/lib64/qt4/libQtGui.so.4
#29 0x00007f5fc14b3d58 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#30 0x00007f5fc14b3f98 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#31 0x00007f5fc14b8b0b in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#32 0x0000000000404373 in main (argc=1, argv=0x7fffd5f1e2d8) at /var/tmp/portage/kde-base/kontact-4.8.5/work/kontact-4.8.5/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 279749.

Possible duplicates by query: bug 294612, bug 291135, bug 284521.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-09-26 07:19:49 UTC

*** This bug has been marked as a duplicate of bug 279749 ***