Bug 291135 - Kontact crashes when opening an encrypted mail for the first time
Summary: Kontact crashes when opening an encrypted mail for the first time
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-10 09:13 UTC by Hartmut Manz
Modified: 2012-01-12 09:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.58 KB, text/plain)
2012-01-12 00:22 UTC, SZÉKELYI Szabolcs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hartmut Manz 2012-01-10 09:13:02 UTC
Application: kontact (4.8 rc2)
KDE Platform Version: 4.7.97 (4.8 RC2 (4.7.97)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

When opening an encrypted mail for the first time, kontact crashes.
After a restart I can read this mail without any problem. However if opening another
encrypted mail (coming from the same source and using the same encryption which is not secured by a password)
kontact crashes again with the same traceback.

This problem is still availabel in the current RC2 Version of Kmail for KDE 4.8

I am using Kubuntu beta build for KDE RC2 4.8 based on a 11.10 Kubuntu system.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe8b9c2e7a0 (LWP 8682))]

Thread 4 (Thread 0x7fe8a04d4700 (LWP 8683)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe8b6490c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fe8b6490d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fe8b1c74efc in start_thread (arg=0x7fe8a04d4700) at pthread_create.c:304
#4  0x00007fe8b719e89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe89fbd3700 (LWP 8684)):
#0  0x00007fe8b7192773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe8b17a2f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe8b17a3429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe8b78faf3e in QEventDispatcherGlib::processEvents (this=0x1d58fc0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe8b78cecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe8b78ceef7 in QEventLoop::exec (this=0x7fe89fbd2de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe8b77e627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe8b77e8d05 in QThreadPrivate::start (arg=0x1d580a0) at thread/qthread_unix.cpp:331
#8  0x00007fe8b1c74efc in start_thread (arg=0x7fe89fbd3700) at pthread_create.c:304
#9  0x00007fe8b719e89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe84d5f8700 (LWP 8697)):
#0  0x00007fe8b7192773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe8b17a2f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe8b17a3429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe8b78faf3e in QEventDispatcherGlib::processEvents (this=0x34c8ba0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe8b78cecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe8b78ceef7 in QEventLoop::exec (this=0x7fe84d5f7db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe8b77e627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe8b78b1cbf in QInotifyFileSystemWatcherEngine::run (this=0x34c7dd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe8b77e8d05 in QThreadPrivate::start (arg=0x34c7dd0) at thread/qthread_unix.cpp:331
#9  0x00007fe8b1c74efc in start_thread (arg=0x7fe84d5f8700) at pthread_create.c:304
#10 0x00007fe8b719e89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe8b9c2e7a0 (LWP 8682)):
[KCrash Handler]
#6  0x00007fe8ae45a234 in KMime::Content::parent (this=0x50c3430) at ../../kmime/kmime_content.cpp:927
#7  0x00007fe857077fd5 in MessageCore::NodeHelper::nextSibling (node=0x50c3430) at ../../messagecore/nodehelper.cpp:32
#8  0x00007fe85597b8a7 in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0x7fff19e43ec0, node=0x50c3430) at ../../messageviewer/objecttreeparser.cpp:296
#9  0x00007fe8559ad2df in MessageViewer::ViewerPrivate::parseContent (this=0x267f050, content=0x50c3430) at ../../messageviewer/viewer_p.cpp:866
#10 0x00007fe8559afdc4 in MessageViewer::ViewerPrivate::displayMessage (this=0x267f050) at ../../messageviewer/viewer_p.cpp:738
#11 0x00007fe8559b0672 in MessageViewer::ViewerPrivate::updateReaderWin (this=0x267f050) at ../../messageviewer/viewer_p.cpp:2015
#12 0x00007fe8559b3cad in MessageViewer::ViewerPrivate::qt_metacall (this=0x267f050, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0x7fff19e44390) at ./viewer_p.moc:226
#13 0x00007fe8b78e2eba in QMetaObject::activate (sender=0x267f0d8, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#14 0x00007fe8b78e6789 in QObject::event (this=0x267f0d8, e=<optimized out>) at kernel/qobject.cpp:1181
#15 0x00007fe8b82d0424 in notify_helper (e=0x7fff19e448f0, receiver=0x267f0d8, this=0x1d53c20) at kernel/qapplication.cpp:4486
#16 QApplicationPrivate::notify_helper (this=0x1d53c20, receiver=0x267f0d8, e=0x7fff19e448f0) at kernel/qapplication.cpp:4458
#17 0x00007fe8b82d5291 in QApplication::notify (this=0x7fff19e44bf0, receiver=0x267f0d8, e=0x7fff19e448f0) at kernel/qapplication.cpp:4365
#18 0x00007fe8b8fe4ae6 in KApplication::notify (this=0x7fff19e44bf0, receiver=0x267f0d8, event=0x7fff19e448f0) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007fe8b78cfafc in QCoreApplication::notifyInternal (this=0x7fff19e44bf0, receiver=0x267f0d8, event=0x7fff19e448f0) at kernel/qcoreapplication.cpp:787
#20 0x00007fe8b78fcd62 in sendEvent (event=0x7fff19e448f0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QTimerInfoList::activateTimers (this=0x1d68740) at kernel/qeventdispatcher_unix.cpp:603
#22 0x00007fe8b78fa514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#23 0x00007fe8b17a2a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fe8b17a3258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fe8b17a3429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fe8b78faed6 in QEventDispatcherGlib::processEvents (this=0x1d515d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#27 0x00007fe8b837807e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fe8b78cecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007fe8b78ceef7 in QEventLoop::exec (this=0x7fff19e44b80, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007fe8b78d3789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#31 0x0000000000403629 in main (argc=1, argv=0x7fff19e45218) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 279749.

Possible duplicates by query: bug 284521, bug 279749.

Reported using DrKonqi
Comment 1 SZÉKELYI Szabolcs 2012-01-12 00:22:05 UTC
Created attachment 67722 [details]
New crash information added by DrKonqi

kontact (4.7.3) on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

Another crash report from the same problem.

-- Backtrace (Reduced):
#6  0x00007f81f544e164 in KMime::Content::parent (this=0x15b8ae10) at ../../kmime/kmime_content.cpp:921
#7  0x00007f819d7f4f05 in MessageCore::NodeHelper::nextSibling (node=0x15b8ae10) at ../../messagecore/nodehelper.cpp:32
#8  0x00007f819c1101d7 in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=0x7fff75b791d0, node=0x15b8ae10) at ../../messageviewer/objecttreeparser.cpp:278
#9  0x00007f819c144cbf in MessageViewer::ViewerPrivate::parseContent (this=0x287fd80, content=0x15b8ae10) at ../../messageviewer/viewer_p.cpp:857
#10 0x00007f819c147814 in MessageViewer::ViewerPrivate::displayMessage (this=0x287fd80) at ../../messageviewer/viewer_p.cpp:729
Comment 2 Christophe Marin 2012-01-12 09:24:03 UTC

*** This bug has been marked as a duplicate of bug 279749 ***