Bug 307998 - Analog clock is broken after logout/reboot if the "show seconds hands" option is enabled
Summary: Analog clock is broken after logout/reboot if the "show seconds hands" option...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-clock (show other bugs)
Version: 4.9.2
Platform: Ubuntu Packages Linux
: NOR normal with 61 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: reproducible
: 307999 309115 309844 (view as bug list)
Depends on:
Blocks: extramile
  Show dependency treegraph
 
Reported: 2012-10-07 04:12 UTC by Zach
Modified: 2012-11-15 13:30 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zach 2012-10-07 04:12:36 UTC
Analog clock widget on desktop disappears on logout/reboot.  Only small pieces of the hands remain.  The widget controls still work, but the widget itself is nearly invisable.

Reproducible: Always

Steps to Reproduce:
1. Put Analog Clock Widget on desktop
2. Reboot or logout
3. Notice that it is gone
Actual Results:  
There is a very broken analog clock widget on the desktop.

Expected Results:  
An intact analog clock would be on the desktop.

http://www.kubuntuforums.net/showthread.php?60364-My-Analogue-Clock-has-disappeared!

Affects multiple users as seen in Kubuntu Forum thread.
Comment 1 NoWorries 2012-10-07 07:29:52 UTC
I have experienced this problem on three different computers with KDE4.9.2.  I found the easiest way to restore the clock was to right click on "Analogue Clock Settings" and then click OK.  This restored the clock.  I have to do this each time I reboot or logout!!
Comment 2 Christoph Feck 2012-10-08 09:19:08 UTC
*** Bug 307999 has been marked as a duplicate of this bug. ***
Comment 3 NoWorries 2012-10-23 09:08:37 UTC
Since my original comment, I have found that the odd behaviour of the Analog Clock only occurs with the selection of the "Show seconds hand".  When this is not selected, the clock behaves as it should.  I personally prefer to have the seconds hand, but for the time being, I do not have this selected for the sake of having the clock displayed correctly.
Comment 4 Mark 2012-10-23 18:36:53 UTC
I also have this problem with the analogue clock widget. It's fine if I do not select "show seconds hands" in the options. However, if I do select to show the seconds hands, on the next reboot the widget has all but disappeared, leaving behind only remnants of the hands. I am running KDE 4.9.2 on Kubuntu 12.10 64 bit, using latest Nvidia proprietary driver provided by Kubuntu.
Comment 5 Juan Ehrenhaus 2012-10-23 21:04:53 UTC
I have the same behavior: system is Opensuse 12.2 KDe 4.9.2 release 511. Proprietary Nvidia driver V. 304.60
It seems also a malfunction when the secondhand is activated.
Comment 6 Karol Slanina 2012-10-23 21:14:34 UTC
The same here: Arch Linux, KDE 4.9.2. Analog clock starts completely distorted when second hand is enabled, but clicking on OK button in the Analog Clock Settings  dialog repairs it. With second hand disabled the clock starts fine right at the beginning of the KDE session.
Comment 7 Jem Orgun 2012-10-23 22:49:30 UTC
Same as everyone else (I'm on Arch, with 4.9.2). The problem still appears if I kill and restart plasma manually.
Comment 8 Juan Ehrenhaus 2012-10-24 07:49:43 UTC
The same miss function happened also under openSuse 12.2, KDE 4.9.2 and the Nvidia Driver V. 304.51 !
Comment 9 Juan Ehrenhaus 2012-10-24 07:55:23 UTC
Observation: the Platform Ubuntu needs to be changed, this problem appear in many other platforms ( Opensuse, Arch linux, etc...?)
Comment 10 Juan Ehrenhaus 2012-10-28 13:49:11 UTC
I have realized that this miss function is also appearing after restore the desktop from sleep modes !!! (OS 12.2, KDe 4.9.2) and this happened without the seconds hand activated !! Please try to solve this in the next release of KDE ! Thank you.
Comment 11 jethawk 2012-10-29 07:12:48 UTC
I'm experiencing the same issue on F17 running KDE 4.9.2 and this looks like an old bug: https://bugs.kde.org/show_bug.cgi?id=198770
Comment 12 frntasbr 2012-10-29 12:58:57 UTC
Same issue here on two different computers. Kubuntu 12.04 KDE 4.9.2 Intel.
Comment 13 Silver Salonen 2012-11-06 15:34:17 UTC
Same issue on all of my 4 different computers (2 x 64-bit PC with openSUSE 12.2, 1 x 64-bit laptop with Kubuntu 12.10, 1 x 32-bit laptop with Kubuntu 12.10). The issue appeared after upgrading to KDE 4.9.
Comment 14 Karol Slanina 2012-11-06 15:48:33 UTC
The issue now occurs even if the 'show seconds hand' option is disabled. KDE 4.9.2, Arch linux, proprietary Nvidia driver.
Comment 15 Silver Salonen 2012-11-06 15:54:36 UTC
On my case Analog Clock gets fixed when changing any options of the widget (eg. disabling seconds' hand) and clicking Apply.
Comment 16 Juan Ehrenhaus 2012-11-06 22:28:58 UTC
I already have updated the KDE V. 4.9.3 --- miss function of analog clock still happened. What is going on ?!
Comment 17 Christoph Feck 2012-11-07 00:33:52 UTC
Lukas, can you check, if this is a regression caused by commit 45bd3bfb ?
Comment 18 Lukáš Tinkl 2012-11-07 10:42:47 UTC
Doubt it, I've seen this long ago in the past; no idea what causes it tho, looks like a gfx driver issue to me, the widget fails to redraw completely. You can verify it by unlocking the widgets and trying to resize the clock.
Comment 19 Karol Slanina 2012-11-07 17:54:42 UTC
Resizing the clock works fine. Only at the startup of plasma the widget is broken and it is only redrawn correctly when you open and close (OK) the 'settings' dialog.
Comment 20 ohad cohen 2012-11-09 07:08:28 UTC
have the same problem
unmarking "show seconds hand" doesn't help
upgraded from 4.9.2 to 4.9.3 and the problem still exists
problem started when upgraded to kubuntu 12.10 64bit on asus ul20a (on 12.04 it was fine)
Comment 21 Jekyll Wu 2012-11-10 09:22:37 UTC
*** Bug 309844 has been marked as a duplicate of this bug. ***
Comment 22 Jekyll Wu 2012-11-10 09:23:37 UTC
*** Bug 309115 has been marked as a duplicate of this bug. ***
Comment 23 Christoph Feck 2012-11-11 02:59:47 UTC
Git commit 1041099dd18cc46d2c801a7b790ce06c6bed9503 by Christoph Feck.
Committed on 11/11/2012 at 03:58.
Pushed by cfeck into branch 'KDE/4.9'.

Fix initial paint for analog clock

Unconditionally setting repaint mode to RepaintHands will clear
the initially needed RepaintAll mode, causing the background
cache not to be initialized.
FIXED-IN: KDE 4.9.4

M  +3    -1    plasma/generic/applets/analog-clock/clock.cpp

http://commits.kde.org/kde-workspace/1041099dd18cc46d2c801a7b790ce06c6bed9503
Comment 24 Christoph Feck 2012-11-11 03:03:58 UTC
Lukas, it was indeed a regression with commit 45bd3bfb.
Comment 25 Lukáš Tinkl 2012-11-11 08:53:00 UTC
Thanks for fixing!
Comment 26 Christoph Feck 2012-11-11 19:54:00 UTC
Git commit c754fa5062f04773af5130fbccffb56b96a54b61 by Christoph Feck.
Committed on 11/11/2012 at 20:51.
Pushed by cfeck into branch 'KDE/4.9'.

Re-apply minute hand caching optimization

(also re-apply lost commit 1041099dd18cc46d2c801a7b790ce06c6bed9503)

M  +4    -1    plasma/generic/applets/analog-clock/clock.cpp

http://commits.kde.org/kde-workspace/c754fa5062f04773af5130fbccffb56b96a54b61
Comment 27 Aaron J. Seigo 2012-11-15 13:30:53 UTC
Git commit 8dc837662cf5bd0d5e1c12b3c31eac43bae8b689 by Aaron Seigo, on behalf of Christoph Feck.
Committed on 11/11/2012 at 20:51.
Pushed by aseigo into branch 'master'.

Re-apply minute hand caching optimization

(also re-apply lost commit 1041099dd18cc46d2c801a7b790ce06c6bed9503)

M  +4    -1    plasma/generic/applets/analog-clock/clock.cpp

http://commits.kde.org/kde-workspace/8dc837662cf5bd0d5e1c12b3c31eac43bae8b689