Bug 305973 - crash if you manually type in value for year into date field
Summary: crash if you manually type in value for year into date field
Status: RESOLVED DUPLICATE of bug 272077
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-clock (show other bugs)
Version: 4.7.4
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-29 09:02 UTC by nicole.hornek
Modified: 2013-01-09 00:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nicole.hornek 2012-08-29 09:02:31 UTC
If you click on the digital clock widget, the calendar widget opens.
and if you try to type in another value for  the year in the date field which is on the bottom of the calendar (dd/MM/YY), then plasma-desktop crashes.

Reproducible: Didn't try

Steps to Reproduce:
1. click on the digital clock widget
2. click into the date field (dd/MM/YY) on the bottom of the calendar
3. type in '14' as value for the year in the date field
Actual Results:  
the plasma-desktop crashes and the panel disappears.

Expected Results:  
The calendar should switch to 2014.

Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 2.6.37.6-0.11-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was right-clicking on the calendar/date widget, then I clicked on the date field (dd/MM/YY) on the bottom and I tried to type in '14' for the year value.
Then the whole panel crashed.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f262578c760 (LWP 2151))]

Thread 6 (Thread 0x7f2609ea1700 (LWP 2152)):
#0  0x00007f262406e0ae in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f261fc71825 in g_main_context_release () from /lib64/libglib-2.0.so.0
#2  0x00007f261fc73148 in ?? () from /lib64/libglib-2.0.so.0
#3  0x00007f261fc73650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007f2624410636 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f26243e4c22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f26243e4e35 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#7  0x00007f26242f9be4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#8  0x00007f26243c6358 in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f26242fc4d5 in ?? () from /usr/lib64/libQtCore.so.4
#10 0x00007f262406ba3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f2622e1b67d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f25fd0b5700 (LWP 26336)):
#0  0x00007f262407038c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f26242fcbbb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f26183a0f44 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f26183a3643 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f26183a241f in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f26183a24a8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f26242fc4d5 in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f262406ba3f in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2622e1b67d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f2609488700 (LWP 26337)):
#0  0x00007f262407038c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f26242fcbbb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f26183a0f44 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f26183a3643 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f26183a241f in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f26183a24a8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f26242fc4d5 in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f262406ba3f in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2622e1b67d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f25fa78f700 (LWP 26338)):
#0  0x00007f262407038c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f26242fcbbb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f26183a0f44 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f26183a3643 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f26183a241f in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f26183a24a8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f26242fc4d5 in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f262406ba3f in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2622e1b67d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f25f9f8e700 (LWP 26339)):
#0  0x00007f262407038c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f26242fcbbb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f26183a0f44 in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f26183a3643 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f26183a241f in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f26183a24a8 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f26242fc4d5 in ?? () from /usr/lib64/libQtCore.so.4
#7  0x00007f262406ba3f in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2622e1b67d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f262578c760 (LWP 2151)):
[KCrash Handler]
#6  0x00007f2623b6dfbb in QGraphicsLinearLayout::removeItem(QGraphicsLayoutItem*) () from /usr/lib64/libQtGui.so.4
#7  0x00007f260bcaef82 in Plasma::Calendar::hideYearSpinBox() () from /usr/lib64/libplasmaclock.so.4
#8  0x00007f260bcafddc in Plasma::Calendar::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libplasmaclock.so.4
#9  0x00007f26243f9e8f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#10 0x00007f26235dcb3c in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#11 0x00007f262358b2c4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#12 0x00007f262359387a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#13 0x00007f2625170e36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#14 0x00007f26243e57cc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#15 0x00007f2623b6ff0a in ?? () from /usr/lib64/libQtGui.so.4
#16 0x00007f261b1a891f in Plasma::SpinBox::focusOutEvent(QFocusEvent*) () from /usr/lib64/libplasma.so.3
#17 0x00007f2623b514b5 in QGraphicsItem::sceneEvent(QEvent*) () from /usr/lib64/libQtGui.so.4
#18 0x00007f2623b7cfb2 in ?? () from /usr/lib64/libQtGui.so.4
#19 0x00007f2623b48a26 in QGraphicsItemPrivate::setFocusHelper(Qt::FocusReason, bool, bool) () from /usr/lib64/libQtGui.so.4
#20 0x00007f2623b7d29e in QGraphicsScene::focusNextPrevChild(bool) () from /usr/lib64/libQtGui.so.4
#21 0x00007f2623baae90 in QGraphicsWidget::focusNextPrevChild(bool) () from /usr/lib64/libQtGui.so.4
#22 0x00007f2623b5aad7 in QGraphicsItemPrivate::setVisibleHelper(bool, bool, bool) () from /usr/lib64/libQtGui.so.4
#23 0x00007f260bcaefb5 in Plasma::Calendar::hideYearSpinBox() () from /usr/lib64/libplasmaclock.so.4
#24 0x00007f260bcafddc in Plasma::Calendar::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libplasmaclock.so.4
#25 0x00007f26243f9e8f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#26 0x00007f262394ba3f in QAbstractSpinBox::keyPressEvent(QKeyEvent*) () from /usr/lib64/libQtGui.so.4
#27 0x00007f26235dcf00 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#28 0x00007f262358b2c4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#29 0x00007f2623593fa4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#30 0x00007f2625170e36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#31 0x00007f26243e57cc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#32 0x00007f2623b6fda5 in ?? () from /usr/lib64/libQtGui.so.4
#33 0x00007f2623b5152a in QGraphicsItem::sceneEvent(QEvent*) () from /usr/lib64/libQtGui.so.4
#34 0x00007f2623b7add4 in QGraphicsScene::keyPressEvent(QKeyEvent*) () from /usr/lib64/libQtGui.so.4
#35 0x00007f2623b8e722 in QGraphicsScene::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#36 0x00007f262358b2c4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#37 0x00007f262359387a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#38 0x00007f2625170e36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#39 0x00007f26243e57cc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#40 0x00007f2623b9d22d in QGraphicsView::keyPressEvent(QKeyEvent*) () from /usr/lib64/libQtGui.so.4
#41 0x00007f26235dcf00 in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#42 0x00007f2623984fb6 in QFrame::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#43 0x00007f2623a0626b in QAbstractScrollArea::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#44 0x00007f262358b2c4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#45 0x00007f2623593fa4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#46 0x00007f2625170e36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#47 0x00007f26243e57cc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#48 0x00007f262362d308 in ?? () from /usr/lib64/libQtGui.so.4
#49 0x00007f262362d78f in ?? () from /usr/lib64/libQtGui.so.4
#50 0x00007f262360941c in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
#51 0x00007f26236317a2 in ?? () from /usr/lib64/libQtGui.so.4
#52 0x00007f261fc72bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#53 0x00007f261fc733b0 in ?? () from /lib64/libglib-2.0.so.0
#54 0x00007f261fc73650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#55 0x00007f26244105df in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#56 0x00007f262363143e in ?? () from /usr/lib64/libQtGui.so.4
#57 0x00007f26243e4c22 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#58 0x00007f26243e4e35 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#59 0x00007f26243e927b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#60 0x00007f261343ada8 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#61 0x0000000000407279 in _start ()

Possible duplicates by query: bug 277576, bug 275014, bug 273309, bug 273286, bug 272077.

Report to https://bugs.kde.org
Comment 1 Chao Feng 2013-01-05 02:56:45 UTC
This should be a duplication of bug 272077. But bug 272077 should already be fixed in KDE 4.6.4, could anyone else using  Opensuse + kde 4.7.4 confirm this bug still exist?
Comment 2 nicole.hornek 2013-01-08 15:34:28 UTC
(In reply to comment #1)
> This should be a duplication of bug 272077. But bug 272077 should already be
> fixed in KDE 4.6.4, could anyone else using  Opensuse + kde 4.7.4 confirm
> this bug still exist?

if it helps...
I can confirm that the bug doesn't exist in KDE 4.8.5.
Comment 3 Chao Feng 2013-01-09 00:25:57 UTC
Mark as duplicate based on the backtrace.
Also the reporter confirm the bug doesn't exist in KDE 4.8.5 anymore.

*** This bug has been marked as a duplicate of bug 272077 ***