Bug 273309 - plasma crash while fiddling with calendar
Summary: plasma crash while fiddling with calendar
Status: RESOLVED DUPLICATE of bug 272077
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-15 00:30 UTC by Vít Tuček
Modified: 2011-05-15 00:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vít Tuček 2011-05-15 00:30:42 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.3
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I wanted to look what day of the week was 9. October of 2010.

1. select October
2. punch in 2010 and enter
3. crash

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3f0bd57760 (LWP 9038))]

Thread 2 (Thread 0x7f3eee7cd700 (LWP 9042)):
#0  0x00007f3f09450503 in poll () from /lib64/libc.so.6
#1  0x00007f3f062b2114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f3f062b2650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f3f0aa46286 in QEventDispatcherGlib::processEvents (this=0xfd9f20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f3f0aa1a8d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3f0aa1aae5 in QEventLoop::exec (this=0x7f3eee7ccde0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f3f0a92f7a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f3f0a9fc008 in QInotifyFileSystemWatcherEngine::run (this=0xfeaa40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f3f0a932095 in QThreadPrivate::start (arg=0xfeaa40) at thread/qthread_unix.cpp:320
#9  0x00007f3f0a6a1a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f3f0945967d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3f0bd57760 (LWP 9038)):
[KCrash Handler]
#6  d_func (this=0x0, item=0x15a7bd0) at graphicsview/qgraphicslinearlayout.h:109
#7  QGraphicsLinearLayout::removeItem (this=0x0, item=0x15a7bd0) at graphicsview/qgraphicslinearlayout.cpp:314
#8  0x00007f3ef147fff2 in Plasma::Calendar::hideYearSpinBox (this=0x14d08a0) at /usr/src/debug/kdebase-workspace-4.6.3/libs/plasmaclock/calendar.cpp:467
#9  0x00007f3ef1480e4c in Plasma::Calendar::qt_metacall (this=0x14d08a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8796cc70) at /usr/src/debug/kdebase-workspace-4.6.3/build/libs/plasmaclock/calendar.moc:112
#10 0x00007f3f0aa2fa5f in QMetaObject::activate (sender=0x15a7fc0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x00007f3f09c1791c in QWidget::event (this=0x15a7fc0, event=0x7fff8796d440) at kernel/qwidget.cpp:8372
#12 0x00007f3f09bc6144 in QApplicationPrivate::notify_helper (this=0x6cfc70, receiver=0x15a7fc0, e=0x7fff8796d440) at kernel/qapplication.cpp:4462
#13 0x00007f3f09bce6fa in QApplication::notify (this=<value optimized out>, receiver=0x15a7fc0, e=0x7fff8796d440) at kernel/qapplication.cpp:4341
#14 0x00007f3f0b6c1006 in KApplication::notify (this=0x6c3bc0, receiver=0x15a7fc0, event=0x7fff8796d440) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#15 0x00007f3f0aa1b47c in QCoreApplication::notifyInternal (this=0x6c3bc0, receiver=0x15a7fc0, event=0x7fff8796d440) at kernel/qcoreapplication.cpp:731
#16 0x00007f3f0a1a770a in sendEvent (this=<value optimized out>, widget=0x15a7fc0, reason=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#17 QGraphicsProxyWidgetPrivate::removeSubFocusHelper (this=<value optimized out>, widget=0x15a7fc0, reason=<value optimized out>) at graphicsview/qgraphicsproxywidget.cpp:335
#18 0x00007f3f0a188d85 in QGraphicsItem::sceneEvent (this=0x15a7bc0, event=0x7fff8796d540) at graphicsview/qgraphicsitem.cpp:6677
#19 0x00007f3f0a1b44d9 in QGraphicsScenePrivate::setFocusItemHelper (this=0x6ce7f0, item=<value optimized out>, focusReason=Qt::TabFocusReason) at graphicsview/qgraphicsscene.cpp:812
#20 0x00007f3f0a180316 in QGraphicsItemPrivate::setFocusHelper (this=0x15dd970, focusReason=Qt::TabFocusReason, climb=<value optimized out>, focusFromHide=<value optimized out>) at graphicsview/qgraphicsitem.cpp:3311
#21 0x00007f3f0a1b491e in QGraphicsScene::focusNextPrevChild (this=0x6cdae0, next=true) at graphicsview/qgraphicsscene.cpp:5439
#22 0x00007f3f0a1e26a0 in QGraphicsWidget::focusNextPrevChild (this=0x190f0f0, next=true) at graphicsview/qgraphicswidget.cpp:1511
#23 0x00007f3f0a1923a7 in QGraphicsItemPrivate::setVisibleHelper (this=0x15a7bf0, newVisible=false, explicitly=<value optimized out>, update=true) at graphicsview/qgraphicsitem.cpp:2311
#24 0x00007f3ef1480025 in hide (this=0x14d08a0) at /usr/include/QtGui/qgraphicsitem.h:221
#25 Plasma::Calendar::hideYearSpinBox (this=0x14d08a0) at /usr/src/debug/kdebase-workspace-4.6.3/libs/plasmaclock/calendar.cpp:469
#26 0x00007f3ef1480e4c in Plasma::Calendar::qt_metacall (this=0x14d08a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8796d890) at /usr/src/debug/kdebase-workspace-4.6.3/build/libs/plasmaclock/calendar.moc:112
#27 0x00007f3f0aa2fa5f in QMetaObject::activate (sender=0x15a7fc0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#28 0x00007f3f09f8347f in QAbstractSpinBox::keyPressEvent (this=0x15a7fc0, event=0x7fff8796f100) at widgets/qabstractspinbox.cpp:1007
#29 0x00007f3f09c17ce0 in QWidget::event (this=0x15a7fc0, event=0x7fff8796f100) at kernel/qwidget.cpp:8294
#30 0x00007f3f09bc6144 in QApplicationPrivate::notify_helper (this=0x6cfc70, receiver=0x15a7fc0, e=0x7fff8796f100) at kernel/qapplication.cpp:4462
#31 0x00007f3f09bcee24 in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=0x7fff8796f100) at kernel/qapplication.cpp:3921
#32 0x00007f3f0b6c1006 in KApplication::notify (this=0x6c3bc0, receiver=0x15a7fc0, event=0x7fff8796f100) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#33 0x00007f3f0aa1b47c in QCoreApplication::notifyInternal (this=0x6c3bc0, receiver=0x15a7fc0, event=0x7fff8796f100) at kernel/qcoreapplication.cpp:731
#34 0x00007f3f0a1a75a5 in sendEvent (this=0x15a7bf0, event=0x7fff8796f100) at ../../src/corelib/kernel/qcoreapplication.h:215
#35 QGraphicsProxyWidgetPrivate::sendWidgetKeyEvent (this=0x15a7bf0, event=0x7fff8796f100) at graphicsview/qgraphicsproxywidget.cpp:321
#36 0x00007f3f0a188dfa in QGraphicsItem::sceneEvent (this=0x15a7bc0, event=0x7fff8796f100) at graphicsview/qgraphicsitem.cpp:6753
#37 0x00007f3f0a1b2364 in QGraphicsScene::keyPressEvent (this=0x6cdae0, keyEvent=0x7fff8796f100) at graphicsview/qgraphicsscene.cpp:3986
#38 0x00007f3f0a1c5fe2 in QGraphicsScene::event (this=0x6cdae0, event=0x7fff8796f100) at graphicsview/qgraphicsscene.cpp:3414
#39 0x00007f3f09bc6144 in QApplicationPrivate::notify_helper (this=0x6cfc70, receiver=0x6cdae0, e=0x7fff8796f100) at kernel/qapplication.cpp:4462
#40 0x00007f3f09bce6fa in QApplication::notify (this=<value optimized out>, receiver=0x6cdae0, e=0x7fff8796f100) at kernel/qapplication.cpp:4341
#41 0x00007f3f0b6c1006 in KApplication::notify (this=0x6c3bc0, receiver=0x6cdae0, event=0x7fff8796f100) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#42 0x00007f3f0aa1b47c in QCoreApplication::notifyInternal (this=0x6c3bc0, receiver=0x6cdae0, event=0x7fff8796f100) at kernel/qcoreapplication.cpp:731
#43 0x00007f3f0a1d4b0d in sendEvent (this=0x1a73ab0, event=0x7fff8796f100) at ../../src/corelib/kernel/qcoreapplication.h:215
#44 QGraphicsView::keyPressEvent (this=0x1a73ab0, event=0x7fff8796f100) at graphicsview/qgraphicsview.cpp:3071
#45 0x00007f3f09c17ce0 in QWidget::event (this=0x1a73ab0, event=0x7fff8796f100) at kernel/qwidget.cpp:8294
#46 0x00007f3f09fbca86 in QFrame::event (this=0x1a73ab0, e=0x7fff8796f100) at widgets/qframe.cpp:557
#47 0x00007f3f0a03dbab in QAbstractScrollArea::event (this=0x1a73ab0, e=0x7fff8796f100) at widgets/qabstractscrollarea.cpp:996
#48 0x00007f3f09bc6144 in QApplicationPrivate::notify_helper (this=0x6cfc70, receiver=0x1a73ab0, e=0x7fff8796f100) at kernel/qapplication.cpp:4462
#49 0x00007f3f09bcee24 in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=0x7fff8796f100) at kernel/qapplication.cpp:3921
#50 0x00007f3f0b6c1006 in KApplication::notify (this=0x6c3bc0, receiver=0x1a73ab0, event=0x7fff8796f100) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#51 0x00007f3f0aa1b47c in QCoreApplication::notifyInternal (this=0x6c3bc0, receiver=0x1a73ab0, event=0x7fff8796f100) at kernel/qcoreapplication.cpp:731
#52 0x00007f3f09c67a78 in QKeyMapper::sendKeyEvent (keyWidget=0x1a73ab0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777220, modifiers=<value optimized out>, text=..., autorepeat=false, count=1, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1866
#53 0x00007f3f09c67eff in QKeyMapperPrivate::translateKeyEvent (this=<value optimized out>, keyWidget=0x1a73ab0, event=<value optimized out>, grab=false) at kernel/qkeymapper_x11.cpp:1836
#54 0x00007f3f09c43fcc in QApplication::x11ProcessEvent (this=0x6c3bc0, event=0x7fff8796fce0) at kernel/qapplication_x11.cpp:3480
#55 0x00007f3f09c6bf12 in x11EventSourceDispatch (s=0x6d74d0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#56 0x00007f3f062b1bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#57 0x00007f3f062b23b0 in ?? () from /lib64/libglib-2.0.so.0
#58 0x00007f3f062b2650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#59 0x00007f3f0aa4622f in QEventDispatcherGlib::processEvents (this=0x6cd120, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#60 0x00007f3f09c6bbae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x00007f3f0aa1a8d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#62 0x00007f3f0aa1aae5 in QEventLoop::exec (this=0x7fff87970000, flags=...) at kernel/qeventloop.cpp:201
#63 0x00007f3f0aa1ef2b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#64 0x00007f3efb0902bd in kdemain (argc=1, argv=0x67f220) at /usr/src/debug/kdebase-workspace-4.6.3/plasma/desktop/shell/main.cpp:120
#65 0x00000000004075c9 in launch (argc=1, _name=0x692988 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b357 "0") at /usr/src/debug/kdelibs-4.6.3/kinit/kinit.cpp:734
#66 0x00000000004080bd in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.6.3/kinit/kinit.cpp:1226
#67 0x000000000040885a in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.6.3/kinit/kinit.cpp:1419
#68 0x00000000004094b0 in main (argc=4, argv=0x7fff87971528, envp=0x7fff87971550) at /usr/src/debug/kdelibs-4.6.3/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 273286.

Possible duplicates by query: bug 273286, bug 272077.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-15 00:39:12 UTC
[Comment from a bug triager]
The bug is fixed for KDE SC 4.6.4. The issue was being tracked at bug 272077, merging.
Thanks

*** This bug has been marked as a duplicate of bug 272077 ***