Bug 273286 - try to select 2016 in calendar widget
Summary: try to select 2016 in calendar widget
Status: RESOLVED DUPLICATE of bug 272077
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-14 19:45 UTC by Mark Lutring
Modified: 2011-05-15 00:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lutring 2011-05-14 19:45:42 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-9-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I tried to select 2016 in calendar widget but it crashed whit plasma shell
- Unusual behavior I noticed:
plasma shell is crashed

-- Backtrace:
Application: Plazma asztali héj (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9e736da7c0 (LWP 2199))]

Thread 3 (Thread 0x7f9e5531c700 (LWP 2202)):
#0  0x00007f9e72fd5f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9e679b7104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9e679b7639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e701e3446 in QEventDispatcherGlib::processEvents (this=0x1b05f70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9e701b7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e701b7abc in QEventLoop::exec (this=0x7f9e5531bcd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9e700ce924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f9e70199c2f in QInotifyFileSystemWatcherEngine::run (this=0x1a9e180) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9e700d1175 in QThreadPrivate::start (arg=0x1a9e180) at thread/qthread_unix.cpp:320
#9  0x00007f9e65a3c853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f9e682bad8c in start_thread (arg=0x7f9e5531c700) at pthread_create.c:304
#11 0x00007f9e72fe304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9e48d20700 (LWP 2204)):
#0  0x00007f9e72fd5f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9e679b7104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9e679b7639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9e701e3446 in QEventDispatcherGlib::processEvents (this=0x1b93780, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9e701b7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e701b7abc in QEventLoop::exec (this=0x7f9e48d1fcd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9e700ce924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f9e70199c2f in QInotifyFileSystemWatcherEngine::run (this=0x1b92c40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9e700d1175 in QThreadPrivate::start (arg=0x1b92c40) at thread/qthread_unix.cpp:320
#9  0x00007f9e65a3c853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f9e682bad8c in start_thread (arg=0x7f9e48d20700) at pthread_create.c:304
#11 0x00007f9e72fe304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9e736da7c0 (LWP 2199)):
[KCrash Handler]
#6  d_func (this=0x0, item=0x1de3db0) at graphicsview/qgraphicslinearlayout.h:109
#7  QGraphicsLinearLayout::removeItem (this=0x0, item=0x1de3db0) at graphicsview/qgraphicslinearlayout.cpp:314
#8  0x00007f9e572ad932 in Plasma::Calendar::hideYearSpinBox (this=0x197f920) at ../../../libs/plasmaclock/calendar.cpp:467
#9  0x00007f9e572ae78c in Plasma::Calendar::qt_metacall (this=0x197f920, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff3714a0b0) at ./calendar.moc:112
#10 0x00007f9e701cd5f8 in QMetaObject::activate (sender=0x1de3a70, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3287
#11 0x00007f9e6f5ca979 in QWidget::event (this=0x1de3a70, event=0x7fff3714a860) at kernel/qwidget.cpp:8372
#12 0x00007f9e6f5799e4 in QApplicationPrivate::notify_helper (this=0x14886a0, receiver=0x1de3a70, e=0x7fff3714a860) at kernel/qapplication.cpp:4462
#13 0x00007f9e6f57e3aa in QApplication::notify (this=<value optimized out>, receiver=0x1de3a70, e=0x7fff3714a860) at kernel/qapplication.cpp:4341
#14 0x00007f9e70e71196 in KApplication::notify (this=0x1470000, receiver=0x1de3a70, event=0x7fff3714a860) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x00007f9e701b849c in QCoreApplication::notifyInternal (this=0x1470000, receiver=0x1de3a70, event=0x7fff3714a860) at kernel/qcoreapplication.cpp:731
#16 0x00007f9e6fb64355 in sendEvent (this=<value optimized out>, widget=0x1de3a70, reason=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#17 QGraphicsProxyWidgetPrivate::removeSubFocusHelper (this=<value optimized out>, widget=0x1de3a70, reason=<value optimized out>) at graphicsview/qgraphicsproxywidget.cpp:335
#18 0x00007f9e6fb46c95 in QGraphicsItem::sceneEvent (this=0x1de3da0, event=0x7fff3714a950) at graphicsview/qgraphicsitem.cpp:6677
#19 0x00007f9e6fb71599 in QGraphicsScenePrivate::setFocusItemHelper (this=0x1553310, item=<value optimized out>, focusReason=Qt::TabFocusReason) at graphicsview/qgraphicsscene.cpp:812
#20 0x00007f9e6fb3e24e in QGraphicsItemPrivate::setFocusHelper (this=0x1ea4320, focusReason=Qt::TabFocusReason, climb=<value optimized out>, focusFromHide=<value optimized out>) at graphicsview/qgraphicsitem.cpp:3311
#21 0x00007f9e6fb719de in QGraphicsScene::focusNextPrevChild (this=0x1537080, next=true) at graphicsview/qgraphicsscene.cpp:5439
#22 0x00007f9e6fb9ed70 in QGraphicsWidget::focusNextPrevChild (this=0x1f83280, next=true) at graphicsview/qgraphicswidget.cpp:1511
#23 0x00007f9e6fb4ffbc in QGraphicsItemPrivate::setVisibleHelper (this=0x1de4720, newVisible=false, explicitly=<value optimized out>, update=true) at graphicsview/qgraphicsitem.cpp:2311
#24 0x00007f9e572ad965 in hide (this=0x197f920) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#25 Plasma::Calendar::hideYearSpinBox (this=0x197f920) at ../../../libs/plasmaclock/calendar.cpp:469
#26 0x00007f9e572ae78c in Plasma::Calendar::qt_metacall (this=0x197f920, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff3714ac90) at ./calendar.moc:112
#27 0x00007f9e701cd5f8 in QMetaObject::activate (sender=0x1de3a70, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3287
#28 0x00007f9e6f941c79 in QAbstractSpinBox::keyPressEvent (this=0x1de3a70, event=0x7fff3714c4a0) at widgets/qabstractspinbox.cpp:1007
#29 0x00007f9e6f5cad3c in QWidget::event (this=0x1de3a70, event=0x7fff3714c4a0) at kernel/qwidget.cpp:8294
#30 0x00007f9e6f5799e4 in QApplicationPrivate::notify_helper (this=0x14886a0, receiver=0x1de3a70, e=0x7fff3714c4a0) at kernel/qapplication.cpp:4462
#31 0x00007f9e6f57ec31 in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=0x7fff3714c4a0) at kernel/qapplication.cpp:3921
#32 0x00007f9e70e71196 in KApplication::notify (this=0x1470000, receiver=0x1de3a70, event=0x7fff3714c4a0) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007f9e701b849c in QCoreApplication::notifyInternal (this=0x1470000, receiver=0x1de3a70, event=0x7fff3714c4a0) at kernel/qcoreapplication.cpp:731
#34 0x00007f9e6fb64205 in sendEvent (this=0x1de4720, event=0x7fff3714c4a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QGraphicsProxyWidgetPrivate::sendWidgetKeyEvent (this=0x1de4720, event=0x7fff3714c4a0) at graphicsview/qgraphicsproxywidget.cpp:321
#36 0x00007f9e6fb46d0a in QGraphicsItem::sceneEvent (this=0x1de3da0, event=0x7fff3714c4a0) at graphicsview/qgraphicsitem.cpp:6753
#37 0x00007f9e6fb6f4c4 in QGraphicsScene::keyPressEvent (this=0x1537080, keyEvent=0x7fff3714c4a0) at graphicsview/qgraphicsscene.cpp:3986
#38 0x00007f9e6fb82a32 in QGraphicsScene::event (this=0x1537080, event=0x7fff3714c4a0) at graphicsview/qgraphicsscene.cpp:3414
#39 0x00007f9e6f5799e4 in QApplicationPrivate::notify_helper (this=0x14886a0, receiver=0x1537080, e=0x7fff3714c4a0) at kernel/qapplication.cpp:4462
#40 0x00007f9e6f57e3aa in QApplication::notify (this=<value optimized out>, receiver=0x1537080, e=0x7fff3714c4a0) at kernel/qapplication.cpp:4341
#41 0x00007f9e70e71196 in KApplication::notify (this=0x1470000, receiver=0x1537080, event=0x7fff3714c4a0) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00007f9e701b849c in QCoreApplication::notifyInternal (this=0x1470000, receiver=0x1537080, event=0x7fff3714c4a0) at kernel/qcoreapplication.cpp:731
#43 0x00007f9e6fb9138d in sendEvent (this=0x1d53870, event=0x7fff3714c4a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QGraphicsView::keyPressEvent (this=0x1d53870, event=0x7fff3714c4a0) at graphicsview/qgraphicsview.cpp:3071
#45 0x00007f9e6f5cad3c in QWidget::event (this=0x1d53870, event=0x7fff3714c4a0) at kernel/qwidget.cpp:8294
#46 0x00007f9e6f97aa66 in QFrame::event (this=0x1d53870, e=0x7fff3714c4a0) at widgets/qframe.cpp:557
#47 0x00007f9e6f9fc1fb in QAbstractScrollArea::event (this=0x1d53870, e=0x7fff3714c4a0) at widgets/qabstractscrollarea.cpp:996
#48 0x00007f9e6f5799e4 in QApplicationPrivate::notify_helper (this=0x14886a0, receiver=0x1d53870, e=0x7fff3714c4a0) at kernel/qapplication.cpp:4462
#49 0x00007f9e6f57ec31 in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=0x7fff3714c4a0) at kernel/qapplication.cpp:3921
#50 0x00007f9e70e71196 in KApplication::notify (this=0x1470000, receiver=0x1d53870, event=0x7fff3714c4a0) at ../../kdeui/kernel/kapplication.cpp:311
#51 0x00007f9e701b849c in QCoreApplication::notifyInternal (this=0x1470000, receiver=0x1d53870, event=0x7fff3714c4a0) at kernel/qcoreapplication.cpp:731
#52 0x00007f9e6f61ccf9 in QKeyMapper::sendKeyEvent (keyWidget=0x1d53870, grab=<value optimized out>, type=QEvent::KeyPress, code=16777220, modifiers=..., text=..., autorepeat=false, count=1, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1866
#53 0x00007f9e6f61d176 in QKeyMapperPrivate::translateKeyEvent (this=0x14c5850, keyWidget=0x1d53870, event=0x7fff3714d030, grab=false) at kernel/qkeymapper_x11.cpp:1836
#54 0x00007f9e6f5f8f03 in QApplication::x11ProcessEvent (this=0x1470000, event=0x7fff3714d030) at kernel/qapplication_x11.cpp:3571
#55 0x00007f9e6f621162 in x11EventSourceDispatch (s=0x14833b0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#56 0x00007f9e679b6bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#57 0x00007f9e679b73a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#58 0x00007f9e679b7639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#59 0x00007f9e701e33ef in QEventDispatcherGlib::processEvents (this=0x1394340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#60 0x00007f9e6f620dfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x00007f9e701b7882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#62 0x00007f9e701b7abc in QEventLoop::exec (this=0x7fff3714d330, flags=...) at kernel/qeventloop.cpp:201
#63 0x00007f9e701bbecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#64 0x00007f9e732cfb2c in kdemain (argc=1, argv=0x7fff3714d738) at ../../../../plasma/desktop/shell/main.cpp:120
#65 0x00007f9e72f1beff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=1, ubp_av=0x7fff3714d738, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff3714d728) at libc-start.c:226
#66 0x0000000000400669 in _start ()

Possible duplicates by query: bug 272077.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-15 00:39:13 UTC
[Comment from a bug triager]
The bug is fixed for KDE SC 4.6.4. The issue was being tracked at bug 272077, merging.
Thanks

*** This bug has been marked as a duplicate of bug 272077 ***