Bug 277576 - Plasma crashes when setting a date in calendar and pressing enter
Summary: Plasma crashes when setting a date in calendar and pressing enter
Status: RESOLVED DUPLICATE of bug 272077
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-11 19:46 UTC by Kalsan
Modified: 2011-07-11 21:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kalsan 2011-07-11 19:46:35 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Single clicked calendar, Double clicked the year "2011" in calendar, Entered "2012" and pressed Enter, Plasma crashes and restarts. Happened 2x in a row.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7703ad0 (LWP 1493))]

Thread 4 (Thread 0xb0214b70 (LWP 1562)):
#0  0x02a4cd41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x031e1dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x032ae4f2 in updateCurrentTime (this=0xaf901abc, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xaf901abc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x032acd32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb02140cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x032acdcd in timerSourcePrepare (source=0xaf901a88, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x08118fd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x08119e63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0811a524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x032ad577 in QEventDispatcherGlib::processEvents (this=0xaf900468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x0327f289 in QEventLoop::processEvents (this=0xb0214280, flags=...) at kernel/qeventloop.cpp:149
#12 0x0327f522 in QEventLoop::exec (this=0xb0214280, flags=...) at kernel/qeventloop.cpp:201
#13 0x031892a0 in QThread::exec (this=0x9d488e0) at thread/qthread.cpp:492
#14 0x03260fdb in QInotifyFileSystemWatcherEngine::run (this=0x9d488e0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0318bda2 in QThreadPrivate::start (arg=0x9d488e0) at thread/qthread_unix.cpp:320
#16 0x051d6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xad7e7b70 (LWP 1569)):
#0  0x08119909 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x0811a270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0811a524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x032ad577 in QEventDispatcherGlib::processEvents (this=0xa2551e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x0327f289 in QEventLoop::processEvents (this=0xad7e7280, flags=...) at kernel/qeventloop.cpp:149
#5  0x0327f522 in QEventLoop::exec (this=0xad7e7280, flags=...) at kernel/qeventloop.cpp:201
#6  0x031892a0 in QThread::exec (this=0xa255880) at thread/qthread.cpp:492
#7  0x03260fdb in QInotifyFileSystemWatcherEngine::run (this=0xa255880) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0318bda2 in QThreadPrivate::start (arg=0xa255880) at thread/qthread_unix.cpp:320
#9  0x051d6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xac7e4b70 (LWP 1571)):
#0  0x051d9374 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x001ee616 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x08118802 in g_main_context_release () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0811a04f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0811a92b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0425f304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0x081432df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x051d6e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7703ad0 (LWP 1493)):
[KCrash Handler]
#7  d_func (this=0x0, item=0xa292818) at graphicsview/qgraphicslinearlayout.h:109
#8  QGraphicsLinearLayout::removeItem (this=0x0, item=0xa292818) at graphicsview/qgraphicslinearlayout.cpp:314
#9  0x081deb2b in Plasma::Calendar::hideYearSpinBox (this=0xa2e60f0) at ../../../libs/plasmaclock/calendar.cpp:467
#10 0x081dfc13 in Plasma::Calendar::qt_metacall (this=0xa2e60f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbffccbec) at ./calendar.moc:112
#11 0x032866ba in QMetaObject::metacall (object=0xa2e60f0, cl=QMetaObject::InvokeMetaMethod, idx=35, argv=0xbffccbec) at kernel/qmetaobject.cpp:237
#12 0x032964ff in QMetaObject::activate (sender=0xa295a78, m=0x739cb64, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3287
#13 0x06e728a7 in QAbstractSpinBox::editingFinished (this=0xa295a78) at .moc/release-shared/moc_qabstractspinbox.cpp:177
#14 0x06e72925 in QAbstractSpinBox::focusOutEvent (this=0xa295a78, event=0xbffcd20c) at widgets/qabstractspinbox.cpp:1133
#15 0x06ac0340 in QWidget::event (this=0xa295a78, event=0xbffcd20c) at kernel/qwidget.cpp:8372
#16 0x06e6e01c in QAbstractSpinBox::event (this=0xa295a78, event=0xbffcd20c) at widgets/qabstractspinbox.cpp:757
#17 0x06f10626 in QSpinBox::event (this=0xa295a78, event=0xbffcd20c) at widgets/qspinbox.cpp:1319
#18 0x06a67d24 in QApplicationPrivate::notify_helper (this=0x97bc190, receiver=0xa295a78, e=0xbffcd20c) at kernel/qapplication.cpp:4462
#19 0x06a6c97b in QApplication::notify (this=0x97b1c70, receiver=0xa295a78, e=0xbffcd20c) at kernel/qapplication.cpp:4427
#20 0x00c313ca in KApplication::notify (this=0x97b1c70, receiver=0xa295a78, event=0xbffcd20c) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x032800bb in QCoreApplication::notifyInternal (this=0x97b1c70, receiver=0xa295a78, event=0xbffcd20c) at kernel/qcoreapplication.cpp:731
#22 0x070c1318 in sendEvent (this=0xa29b3c0, widget=0xa295a78, reason=Qt::TabFocusReason) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QGraphicsProxyWidgetPrivate::removeSubFocusHelper (this=0xa29b3c0, widget=0xa295a78, reason=Qt::TabFocusReason) at graphicsview/qgraphicsproxywidget.cpp:335
#24 0x070c13f3 in QGraphicsProxyWidget::focusOutEvent (this=0xa292808, event=0xbffcd398) at graphicsview/qgraphicsproxywidget.cpp:1395
#25 0x0071dc77 in Plasma::SpinBox::focusOutEvent (this=0xa292808, event=0xbffcd398) at ../../plasma/widgets/spinbox.cpp:212
#26 0x070a3344 in QGraphicsItem::sceneEvent (this=0xa292810, event=0xbffcd398) at graphicsview/qgraphicsitem.cpp:6677
#27 0x070febd7 in QGraphicsWidget::sceneEvent (this=0xa292808, event=0xbffcd398) at graphicsview/qgraphicswidget.cpp:1191
#28 0x070cc950 in QGraphicsScenePrivate::sendEvent (this=0x97be100, item=0xa292810, event=0xbffcd398) at graphicsview/qgraphicsscene.cpp:1207
#29 0x070cf044 in QGraphicsScenePrivate::setFocusItemHelper (this=0x97be100, item=<value optimized out>, focusReason=Qt::TabFocusReason) at graphicsview/qgraphicsscene.cpp:812
#30 0x0709a838 in QGraphicsItemPrivate::setFocusHelper (this=0xa309148, focusReason=Qt::TabFocusReason, climb=true, focusFromHide=false) at graphicsview/qgraphicsitem.cpp:3311
#31 0x0709aa47 in QGraphicsItem::setFocus (this=0xa2fe310, focusReason=Qt::TabFocusReason) at graphicsview/qgraphicsitem.cpp:3252
#32 0x070cf2be in QGraphicsScene::setFocusItem (this=0x97bd9d0, item=0xa2fe310, focusReason=Qt::TabFocusReason) at graphicsview/qgraphicsscene.cpp:3011
#33 0x070cf487 in QGraphicsScene::focusNextPrevChild (this=0x97bd9d0, next=true) at graphicsview/qgraphicsscene.cpp:5439
#34 0x070ff233 in QGraphicsWidget::focusNextPrevChild (this=0xa2e8018, next=true) at graphicsview/qgraphicswidget.cpp:1511
#35 0x070ff2b2 in QGraphicsWidget::focusNextPrevChild (this=0xa0e60d8, next=true) at graphicsview/qgraphicswidget.cpp:1508
#36 0x070ff2b2 in QGraphicsWidget::focusNextPrevChild (this=0xa32b768, next=true) at graphicsview/qgraphicswidget.cpp:1508
#37 0x070ff2b2 in QGraphicsWidget::focusNextPrevChild (this=0xa330198, next=true) at graphicsview/qgraphicswidget.cpp:1508
#38 0x070ff2b2 in QGraphicsWidget::focusNextPrevChild (this=0xa332b38, next=true) at graphicsview/qgraphicswidget.cpp:1508
#39 0x070ff2b2 in QGraphicsWidget::focusNextPrevChild (this=0xa2e60f0, next=true) at graphicsview/qgraphicswidget.cpp:1508
#40 0x070ff2b2 in QGraphicsWidget::focusNextPrevChild (this=0xa292808, next=true) at graphicsview/qgraphicswidget.cpp:1508
#41 0x070c15ff in QGraphicsProxyWidget::focusNextPrevChild (this=0xa292808, next=true) at graphicsview/qgraphicsproxywidget.cpp:1415
#42 0x070ace9d in QGraphicsItemPrivate::setVisibleHelper (this=0xa29b3c0, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2311
#43 0x070acf38 in QGraphicsItem::setVisible (this=0xa292810, visible=false) at graphicsview/qgraphicsitem.cpp:2438
#44 0x081deb69 in hide (this=0xa2e60f0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#45 Plasma::Calendar::hideYearSpinBox (this=0xa2e60f0) at ../../../libs/plasmaclock/calendar.cpp:469
#46 0x081dfc13 in Plasma::Calendar::qt_metacall (this=0xa2e60f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbffcd8cc) at ./calendar.moc:112
#47 0x032866ba in QMetaObject::metacall (object=0xa2e60f0, cl=QMetaObject::InvokeMetaMethod, idx=35, argv=0xbffcd8cc) at kernel/qmetaobject.cpp:237
#48 0x032964ff in QMetaObject::activate (sender=0xa295a78, m=0x739cb64, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3287
#49 0x06e728a7 in QAbstractSpinBox::editingFinished (this=0xa295a78) at .moc/release-shared/moc_qabstractspinbox.cpp:177
#50 0x06e72fd0 in QAbstractSpinBox::keyPressEvent (this=0xa295a78, event=0xbffcebf4) at widgets/qabstractspinbox.cpp:1007
#51 0x06abfd28 in QWidget::event (this=0xa295a78, event=0xbffcebf4) at kernel/qwidget.cpp:8294
#52 0x06e6e01c in QAbstractSpinBox::event (this=0xa295a78, event=0xbffcebf4) at widgets/qabstractspinbox.cpp:757
#53 0x06f10626 in QSpinBox::event (this=0xa295a78, event=0xbffcebf4) at widgets/qspinbox.cpp:1319
#54 0x06a67d24 in QApplicationPrivate::notify_helper (this=0x97bc190, receiver=0xa295a78, e=0xbffcebf4) at kernel/qapplication.cpp:4462
#55 0x06a6d081 in QApplication::notify (this=0x97b1c70, receiver=0xa295a78, e=0xbffcebf4) at kernel/qapplication.cpp:3921
#56 0x00c313ca in KApplication::notify (this=0x97b1c70, receiver=0xa295a78, event=0xbffcebf4) at ../../kdeui/kernel/kapplication.cpp:311
#57 0x032800bb in QCoreApplication::notifyInternal (this=0x97b1c70, receiver=0xa295a78, event=0xbffcebf4) at kernel/qcoreapplication.cpp:731
#58 0x070c11a8 in sendEvent (this=0xa29b3c0, event=0xbffcebf4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#59 QGraphicsProxyWidgetPrivate::sendWidgetKeyEvent (this=0xa29b3c0, event=0xbffcebf4) at graphicsview/qgraphicsproxywidget.cpp:321
#60 0x070a33af in QGraphicsItem::sceneEvent (this=0xa292810, event=0xbffcebf4) at graphicsview/qgraphicsitem.cpp:6753
#61 0x070febd7 in QGraphicsWidget::sceneEvent (this=0xa292808, event=0xbffcebf4) at graphicsview/qgraphicswidget.cpp:1191
#62 0x070cc950 in QGraphicsScenePrivate::sendEvent (this=0x97be100, item=0xa292810, event=0xbffcebf4) at graphicsview/qgraphicsscene.cpp:1207
#63 0x070cceb5 in QGraphicsScene::keyPressEvent (this=0x97bd9d0, keyEvent=0xbffcebf4) at graphicsview/qgraphicsscene.cpp:3986
#64 0x070e080e in QGraphicsScene::event (this=0x97bd9d0, event=0xbffcebf4) at graphicsview/qgraphicsscene.cpp:3414
#65 0x06a67d24 in QApplicationPrivate::notify_helper (this=0x97bc190, receiver=0x97bd9d0, e=0xbffcebf4) at kernel/qapplication.cpp:4462
#66 0x06a6c8ce in QApplication::notify (this=0x97b1c70, receiver=0x97bd9d0, e=0xbffcebf4) at kernel/qapplication.cpp:3862
#67 0x00c313ca in KApplication::notify (this=0x97b1c70, receiver=0x97bd9d0, event=0xbffcebf4) at ../../kdeui/kernel/kapplication.cpp:311
#68 0x032800bb in QCoreApplication::notifyInternal (this=0x97b1c70, receiver=0x97bd9d0, event=0xbffcebf4) at kernel/qcoreapplication.cpp:731
#69 0x070f035a in sendEvent (this=0xa2e5fa8, event=0xbffcebf4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#70 QGraphicsView::keyPressEvent (this=0xa2e5fa8, event=0xbffcebf4) at graphicsview/qgraphicsview.cpp:3071
#71 0x06abfd28 in QWidget::event (this=0xa2e5fa8, event=0xbffcebf4) at kernel/qwidget.cpp:8294
#72 0x06eb1f63 in QFrame::event (this=0xa2e5fa8, e=0xbffcebf4) at widgets/qframe.cpp:557
#73 0x06f4233f in QAbstractScrollArea::event (this=0xa2e5fa8, e=0xbffcebf4) at widgets/qabstractscrollarea.cpp:996
#74 0x070f0686 in QGraphicsView::event (this=0xa2e5fa8, event=0xbffcebf4) at graphicsview/qgraphicsview.cpp:2741
#75 0x06a67d24 in QApplicationPrivate::notify_helper (this=0x97bc190, receiver=0xa2e5fa8, e=0xbffcebf4) at kernel/qapplication.cpp:4462
#76 0x06a6d081 in QApplication::notify (this=0x97b1c70, receiver=0xa2e5fa8, e=0xbffcebf4) at kernel/qapplication.cpp:3921
#77 0x00c313ca in KApplication::notify (this=0x97b1c70, receiver=0xa2e5fa8, event=0xbffcebf4) at ../../kdeui/kernel/kapplication.cpp:311
#78 0x032800bb in QCoreApplication::notifyInternal (this=0x97b1c70, receiver=0xa2e5fa8, event=0xbffcebf4) at kernel/qcoreapplication.cpp:731
#79 0x06a65b3e in sendSpontaneousEvent (receiver=0xa2e5fa8, event=0xbffcebf4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#80 qt_sendSpontaneousEvent (receiver=0xa2e5fa8, event=0xbffcebf4) at kernel/qapplication.cpp:5456
#81 0x06b1766d in QKeyMapper::sendKeyEvent (keyWidget=0xa2e5fa8, grab=false, type=QEvent::KeyPress, code=16777220, modifiers=..., text=..., autorepeat=false, count=1, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1866
#82 0x06b17abe in QKeyMapperPrivate::translateKeyEvent (this=0x97e7840, keyWidget=0xa2e5fa8, event=0xbffcf2bc, grab=false) at kernel/qkeymapper_x11.cpp:1836
#83 0x06af0560 in QApplication::x11ProcessEvent (this=0x97b1c70, event=0xbffcf2bc) at kernel/qapplication_x11.cpp:3571
#84 0x06b1bb84 in x11EventSourceDispatch (s=0x97bcb10, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#85 0x08119aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#86 0x0811a270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#87 0x0811a524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#88 0x032ad53c in QEventDispatcherGlib::processEvents (this=0x9763ac0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#89 0x06b1b775 in QGuiEventDispatcherGlib::processEvents (this=0x9763ac0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#90 0x0327f289 in QEventLoop::processEvents (this=0xbffcf584, flags=...) at kernel/qeventloop.cpp:149
#91 0x0327f522 in QEventLoop::exec (this=0xbffcf584, flags=...) at kernel/qeventloop.cpp:201
#92 0x03283ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#93 0x06a658e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#94 0x00e685a5 in kdemain (argc=1, argv=0xbffcf794) at ../../../../plasma/desktop/shell/main.cpp:118
#95 0x080485cb in main (argc=1, argv=0xbffcf794) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 272077.

Possible duplicates by query: bug 273309, bug 273286, bug 272077.

Reported using DrKonqi
Comment 1 Nicolas L. 2011-07-11 21:41:32 UTC

*** This bug has been marked as a duplicate of bug 272077 ***