Bug 304208 - Plasma crash after changing locale
Summary: Plasma crash after changing locale
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-28 21:21 UTC by Loïc Grobol
Modified: 2012-07-29 00:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Loïc Grobol 2012-07-28 21:21:54 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.90 (4.8.90)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: I removed French from the favorite language list, and right after applying the new settings, plasma crashed.

-- Backtrace:
Application: Outil de gestion de fenêtres Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f72b1265780 (LWP 2783))]

Thread 4 (Thread 0x7f72859c1700 (LWP 2790)):
#0  0x00007f72b0b55b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f72a46d1036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f72a46d1164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f72ad791426 in QEventDispatcherGlib::processEvents (this=0x7f72800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f72ad760c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f72ad760ed7 in QEventLoop::exec (this=0x7f72859c0dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f72ad65ffa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f72ad7409ff in QInotifyFileSystemWatcherEngine::run (this=0x2ca2f10) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f72ad662fcb in QThreadPrivate::start (arg=0x2ca2f10) at thread/qthread_unix.cpp:298
#9  0x00007f72a4dcde9a in start_thread (arg=0x7f72859c1700) at pthread_create.c:308
#10 0x00007f72b0b614bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f7284a7d700 (LWP 2793)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f72aa545222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f72aa545259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f72a4dcde9a in start_thread (arg=0x7f7284a7d700) at pthread_create.c:308
#4  0x00007f72b0b614bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7278faf700 (LWP 2884)):
#0  0x00007f72b0b55b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f72a46d1036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f72a46d1164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f72ad791426 in QEventDispatcherGlib::processEvents (this=0x7f72740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f72ad760c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f72ad760ed7 in QEventLoop::exec (this=0x7f7278faedd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f72ad65ffa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f72ad7409ff in QInotifyFileSystemWatcherEngine::run (this=0x4289e10) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f72ad662fcb in QThreadPrivate::start (arg=0x4289e10) at thread/qthread_unix.cpp:298
#9  0x00007f72a4dcde9a in start_thread (arg=0x7f7278faf700) at pthread_create.c:308
#10 0x00007f72b0b614bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f72b1265780 (LWP 2783)):
[KCrash Handler]
#6  0x000000000dd514d3 in ?? ()
#7  0x00007f7293b5fccc in Plasma::CalendarTable::setDate (this=0x2ae9c20, newDate=...) at ../../../libs/plasmaclock/calendartable.cpp:495
#8  0x00007f7293b5c2a1 in Plasma::Calendar::setDate (this=0x2ae9ca0, toDate=...) at ../../../libs/plasmaclock/calendar.cpp:279
#9  0x00007f7293b53d83 in ClockApplet::updateClockApplet (this=0x1ea52e0, data=...) at ../../../libs/plasmaclock/clockapplet.cpp:342
#10 0x00007f7293d80d08 in Clock::dataUpdated (this=0x1ea52e0, source=..., data=...) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:257
#11 0x00007f7293d8114d in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./clock.moc:64
#12 Clock::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./clock.moc:58
#13 0x00007f72ad776281 in QMetaObject::activate (sender=0x2b629b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8884ec60) at kernel/qobject.cpp:3547
#14 0x00007f72b06b16b7 in Plasma::SignalRelay::dataUpdated (this=<optimized out>, _t1=..., _t2=...) at ./datacontainer_p.moc:99
#15 0x00007f72b06b17d9 in timerEvent (this=0x2b629b0, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:157
#16 Plasma::SignalRelay::timerEvent (this=0x2b629b0, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:137
#17 0x00007f72ad77b179 in QObject::event (this=0x2b629b0, e=<optimized out>) at kernel/qobject.cpp:1157
#18 0x00007f72acae4894 in notify_helper (e=0x7fff8884f350, receiver=0x2b629b0, this=0x1937fe0) at kernel/qapplication.cpp:4559
#19 QApplicationPrivate::notify_helper (this=0x1937fe0, receiver=0x2b629b0, e=0x7fff8884f350) at kernel/qapplication.cpp:4531
#20 0x00007f72acae9713 in QApplication::notify (this=0x191cd30, receiver=0x2b629b0, e=0x7fff8884f350) at kernel/qapplication.cpp:4420
#21 0x00007f72ae4459e6 in KApplication::notify (this=0x191cd30, receiver=0x2b629b0, event=0x7fff8884f350) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007f72ad761e9c in QCoreApplication::notifyInternal (this=0x191cd30, receiver=0x2b629b0, event=0x7fff8884f350) at kernel/qcoreapplication.cpp:876
#23 0x00007f72ad7931f2 in sendEvent (event=0x7fff8884f350, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QTimerInfoList::activateTimers (this=0x191b0a0) at kernel/qeventdispatcher_unix.cpp:611
#25 0x00007f72ad790c0d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#26 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#27 0x00007f72ad790c31 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#28 0x00007f72a46d0d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f72a46d10a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f72a46d1164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f72ad7913bf in QEventDispatcherGlib::processEvents (this=0x1899ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#32 0x00007f72acb8cd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f72ad760c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f72ad760ed7 in QEventLoop::exec (this=0x7fff8884f5c0, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007f72ad765f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#36 0x00007f72b0e67b43 in kdemain (argc=1, argv=0x7fff8884f9a8) at ../../../../plasma/desktop/shell/main.cpp:120
#37 0x00007f72b0a9076d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff8884f9a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff8884f998) at libc-start.c:226
#38 0x0000000000400671 in _start ()

This bug may be a duplicate of or related to bug 299237.

Possible duplicates by query: bug 303526, bug 302706, bug 302687, bug 302406, bug 301882.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-29 00:39:09 UTC

*** This bug has been marked as a duplicate of bug 299237 ***