Bug 302406 - Conf KOrganizer
Summary: Conf KOrganizer
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-23 14:25 UTC by geophil3
Modified: 2012-06-26 11:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description geophil3 2012-06-23 14:25:52 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: Trying to configure KOrganizer and...bla bla bla bla bla bla ok know?

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd4528827c0 (LWP 2104))]

Thread 5 (Thread 0x7fd42b352700 (LWP 2106)):
#0  _dl_update_slotinfo (req_modid=2) at dl-tls.c:688
#1  0x00007fd4526c05bd in __tls_get_addr (ti=0x7fd44f652970) at dl-tls.c:757
#2  0x00007fd44f1fe0da in get_thread_data () at thread/qthread_unix.cpp:174
#3  QThreadData::current () at thread/qthread_unix.cpp:200
#4  0x00007fd44f32cb89 in postEventSourcePrepare (s=0x7fd4240012f0, timeout=0x7fd42b351b6c) at kernel/qeventdispatcher_glib.cpp:256
#5  0x00007fd446309846 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fd446309f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fd44630a164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fd44f32d426 in QEventDispatcherGlib::processEvents (this=0x7fd4240008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#9  0x00007fd44f2fcc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#10 0x00007fd44f2fced7 in QEventLoop::exec (this=0x7fd42b351cd0, flags=...) at kernel/qeventloop.cpp:204
#11 0x00007fd44f1fbfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#12 0x00007fd44f2dc9ff in QInotifyFileSystemWatcherEngine::run (this=0x152a910) at io/qfilesystemwatcher_inotify.cpp:248
#13 0x00007fd44f1fefcb in QThreadPrivate::start (arg=0x152a910) at thread/qthread_unix.cpp:298
#14 0x00007fd443603b74 in ?? () from /usr/lib/nvidia-current-updates/libGL.so.1
#15 0x00007fd446c0ee9a in start_thread (arg=0x7fd42b352700) at pthread_create.c:308
#16 0x00007fd45215c4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fd42a85c700 (LWP 2107)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd44c0e1222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fd44c0e1259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fd443603b74 in ?? () from /usr/lib/nvidia-current-updates/libGL.so.1
#4  0x00007fd446c0ee9a in start_thread (arg=0x7fd42a85c700) at pthread_create.c:308
#5  0x00007fd45215c4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fd4237fe700 (LWP 2109)):
#0  0x00007fd452150b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd44630a036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd44630a49a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd428980406 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fd44632b9e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fd443603b74 in ?? () from /usr/lib/nvidia-current-updates/libGL.so.1
#6  0x00007fd446c0ee9a in start_thread (arg=0x7fd4237fe700) at pthread_create.c:308
#7  0x00007fd45215c4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd420b42700 (LWP 2115)):
#0  0x00007fd45214f0bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fd4436020bc in ?? () from /usr/lib/nvidia-current-updates/libGL.so.1
#2  0x00007fd440e80b27 in ?? () from /usr/lib/nvidia-current-updates/tls/libnvidia-tls.so.295.49
#3  0x00007fd4463448cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fd446309ba4 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fd446309fd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fd44630a164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fd44f32d426 in QEventDispatcherGlib::processEvents (this=0x7fd40c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#8  0x00007fd44f2fcc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007fd44f2fced7 in QEventLoop::exec (this=0x7fd420b41cd0, flags=...) at kernel/qeventloop.cpp:204
#10 0x00007fd44f1fbfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#11 0x00007fd44f2dc9ff in QInotifyFileSystemWatcherEngine::run (this=0x1aca210) at io/qfilesystemwatcher_inotify.cpp:248
#12 0x00007fd44f1fefcb in QThreadPrivate::start (arg=0x1aca210) at thread/qthread_unix.cpp:298
#13 0x00007fd443603b74 in ?? () from /usr/lib/nvidia-current-updates/libGL.so.1
#14 0x00007fd446c0ee9a in start_thread (arg=0x7fd420b42700) at pthread_create.c:308
#15 0x00007fd45215c4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#16 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd4528827c0 (LWP 2104)):
[KCrash Handler]
#6  0x000000000241ea10 in ?? ()
#7  0x00007fd433941b6c in Plasma::CalendarTable::setDate (this=0x12957b0, newDate=...) at ../../../libs/plasmaclock/calendartable.cpp:492
#8  0x00007fd43393e1c1 in Plasma::Calendar::setDate (this=0xdbdb70, toDate=...) at ../../../libs/plasmaclock/calendar.cpp:279
#9  0x00007fd433935ca3 in ClockApplet::updateClockApplet (this=0xdc1430, data=...) at ../../../libs/plasmaclock/clockapplet.cpp:342
#10 0x00007fd433b62eb8 in Clock::dataUpdated (this=0xdc1430, source=..., data=...) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:257
#11 0x00007fd433b632fd in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./clock.moc:64
#12 Clock::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./clock.moc:58
#13 0x00007fd44f312281 in QMetaObject::activate (sender=0x1323e30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffeb7fe390) at kernel/qobject.cpp:3547
#14 0x00007fd451cac677 in Plasma::SignalRelay::dataUpdated (this=<optimized out>, _t1=..., _t2=...) at ./datacontainer_p.moc:99
#15 0x00007fd451cac799 in timerEvent (this=0x1323e30, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:157
#16 Plasma::SignalRelay::timerEvent (this=0x1323e30, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:137
#17 0x00007fd44f317179 in QObject::event (this=0x1323e30, e=<optimized out>) at kernel/qobject.cpp:1157
#18 0x00007fd44e680894 in notify_helper (e=0x7fffeb7fea80, receiver=0x1323e30, this=0xae1b40) at kernel/qapplication.cpp:4559
#19 QApplicationPrivate::notify_helper (this=0xae1b40, receiver=0x1323e30, e=0x7fffeb7fea80) at kernel/qapplication.cpp:4531
#20 0x00007fd44e685713 in QApplication::notify (this=0xa968f0, receiver=0x1323e30, e=0x7fffeb7fea80) at kernel/qapplication.cpp:4420
#21 0x00007fd44ffdbbb6 in KApplication::notify (this=0xa968f0, receiver=0x1323e30, event=0x7fffeb7fea80) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007fd44f2fde9c in QCoreApplication::notifyInternal (this=0xa968f0, receiver=0x1323e30, event=0x7fffeb7fea80) at kernel/qcoreapplication.cpp:876
#23 0x00007fd44f32f1f2 in sendEvent (event=0x7fffeb7fea80, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QTimerInfoList::activateTimers (this=0xae4d60) at kernel/qeventdispatcher_unix.cpp:611
#25 0x00007fd44f32cc0d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#26 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#27 0x00007fd44f32cc31 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#28 0x00007fd446309d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fd44630a0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fd44630a164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fd44f32d3bf in QEventDispatcherGlib::processEvents (this=0x9efad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#32 0x00007fd44e728d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fd44f2fcc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fd44f2fced7 in QEventLoop::exec (this=0x7fffeb7fecf0, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007fd44f301f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#36 0x00007fd452468a13 in kdemain (argc=1, argv=0x7fffeb7ff0d8) at ../../../../plasma/desktop/shell/main.cpp:120
#37 0x00007fd45208b76d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fffeb7ff0d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffeb7ff0c8) at libc-start.c:226
#38 0x0000000000400671 in _start ()

Possible duplicates by query: bug 301882, bug 301761, bug 301720, bug 301623, bug 301596.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-26 11:51:47 UTC

*** This bug has been marked as a duplicate of bug 299237 ***