Bug 302706 - error 299237
Summary: error 299237
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-28 16:26 UTC by Confederación Nacional de Familias
Modified: 2012-06-28 16:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Confederación Nacional de Familias 2012-06-28 16:26:57 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Me encontraba trabajando en Preferencias del sistema en la Opción Local cuando salió el mensaje de error en KDE.

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb770b740 (LWP 2002))]

Thread 6 (Thread 0xb033bb40 (LWP 2003)):
#0  0x037bc3b1 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x0377c87c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0377cfaf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0377d201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01cae8e7 in QEventDispatcherGlib::processEvents (this=0xafa00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x01c7a50d in QEventLoop::processEvents (this=0xb033b240, flags=...) at kernel/qeventloop.cpp:149
#6  0x01c7a7a9 in QEventLoop::exec (this=0xb033b240, flags=...) at kernel/qeventloop.cpp:204
#7  0x01b6394c in QThread::exec (this=0x8262410) at thread/qthread.cpp:501
#8  0x01c57b5d in QInotifyFileSystemWatcherEngine::run (this=0x8262410) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x01b66de0 in QThreadPrivate::start (arg=0x8262410) at thread/qthread_unix.cpp:298
#10 0x01a89d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x001faace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xae2d2b40 (LWP 2006)):
#0  0x0374b8b7 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xad900478 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xad1dcb40 (LWP 2008)):
#0  0x00c96416 in __kernel_vsyscall ()
#1  0x01a8d96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x002083dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0151a029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0x0151a06f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0x01a89d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x001faace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xac43fb40 (LWP 2012)):
#0  0x00c96416 in __kernel_vsyscall ()
#1  0x01a8d96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x002083dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x02ff9263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0x02ff937f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0x01a89d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x001faace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xabc3eb40 (LWP 2013)):
#0  0x001ea17c in read () from /lib/i386-linux-gnu/libc.so.6
#1  0x037bb6ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0377cbd2 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0377d042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0377d201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x01cae8e7 in QEventDispatcherGlib::processEvents (this=0x8e8d100, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x01c7a50d in QEventLoop::processEvents (this=0xabc3e270, flags=...) at kernel/qeventloop.cpp:149
#7  0x01c7a7a9 in QEventLoop::exec (this=0xabc3e270, flags=...) at kernel/qeventloop.cpp:204
#8  0x01b6394c in QThread::exec (this=0x8e8ccc8) at thread/qthread.cpp:501
#9  0x01b63a3b in QThread::run (this=0x8e8ccc8) at thread/qthread.cpp:568
#10 0x01b66de0 in QThreadPrivate::start (arg=0x8e8ccc8) at thread/qthread_unix.cpp:298
#11 0x01a89d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x001faace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb770b740 (LWP 2002)):
[KCrash Handler]
#7  0x0eb752d4 in ?? ()
#8  0x060210cf in Plasma::CalendarTable::setDate (this=0x88ed118, newDate=...) at ../../../libs/plasmaclock/calendartable.cpp:492
#9  0x0601c874 in Plasma::Calendar::setDate (this=0x8951500, toDate=...) at ../../../libs/plasmaclock/calendar.cpp:279
#10 0x060134f8 in ClockApplet::updateClockApplet (this=0x8558788, data=...) at ../../../libs/plasmaclock/clockapplet.cpp:342
#11 0x05ffb902 in Clock::dataUpdated (this=0x8558788, source=..., data=...) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:257
#12 0x05ffbd6e in qt_static_metacall (_a=0xbfa27924, _id=0, _o=0x8558788, _c=<optimized out>) at ./clock.moc:64
#13 Clock::qt_static_metacall (_o=0x8558788, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa27924) at ./clock.moc:58
#14 0x01c926b1 in QMetaObject::activate (sender=0x88ff9e8, m=0x59b878, local_signal_index=0, argv=0xbfa27924) at kernel/qobject.cpp:3547
#15 0x003d469d in Plasma::SignalRelay::dataUpdated (this=0x88ff9e8, _t1=..., _t2=...) at ./datacontainer_p.moc:99
#16 0x003d482f in timerEvent (this=0x88ff9e8, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:157
#17 Plasma::SignalRelay::timerEvent (this=0x88ff9e8, event=0xbfa27e1c) at ../../plasma/private/datacontainer_p.cpp:137
#18 0x01c96ac4 in QObject::event (this=0x88ff9e8, e=0xbfa27e1c) at kernel/qobject.cpp:1157
#19 0x0517ded4 in notify_helper (e=0xbfa27e1c, receiver=0x88ff9e8, this=0x80ba440) at kernel/qapplication.cpp:4559
#20 QApplicationPrivate::notify_helper (this=0x80ba440, receiver=0x88ff9e8, e=0xbfa27e1c) at kernel/qapplication.cpp:4531
#21 0x0518330d in QApplication::notify (this=0xbfa27e1c, receiver=0x88ff9e8, e=0xbfa27e1c) at kernel/qapplication.cpp:4288
#22 0x0114fb61 in KApplication::notify (this=0x80a46f0, receiver=0x88ff9e8, event=0xbfa27e1c) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x01c7b97e in QCoreApplication::notifyInternal (this=0x80a46f0, receiver=0x88ff9e8, event=0xbfa27e1c) at kernel/qcoreapplication.cpp:876
#24 0x01cb0990 in sendEvent (event=0xbfa27e1c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#25 QTimerInfoList::activateTimers (this=0x80bb75c) at kernel/qeventdispatcher_unix.cpp:611
#26 0x01cae0f8 in timerSourceDispatch (source=0x80bb728) at kernel/qeventdispatcher_glib.cpp:186
#27 timerSourceDispatch (source=0x80bb728) at kernel/qeventdispatcher_glib.cpp:180
#28 0x01cae132 in idleTimerSourceDispatch (source=0x80bb790) at kernel/qeventdispatcher_glib.cpp:233
#29 0x0377cd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0x0377d125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x0377d201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0x01cae887 in QEventDispatcherGlib::processEvents (this=0x8061eb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#33 0x05236aaa in QGuiEventDispatcherGlib::processEvents (this=0x8061eb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x01c7a50d in QEventLoop::processEvents (this=0xbfa280a4, flags=...) at kernel/qeventloop.cpp:149
#35 0x01c7a7a9 in QEventLoop::exec (this=0xbfa280a4, flags=...) at kernel/qeventloop.cpp:204
#36 0x01c7feba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#37 0x0517ba74 in QApplication::exec () at kernel/qapplication.cpp:3820
#38 0x00a83a7b in kdemain (argc=1, argv=0xbfa282a4) at ../../../../plasma/desktop/shell/main.cpp:120
#39 0x0804850b in main (argc=1, argv=0xbfa282a4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 299237.

Possible duplicates by query: bug 302687, bug 302406, bug 301882, bug 301761, bug 301720.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-28 16:37:53 UTC

*** This bug has been marked as a duplicate of bug 299237 ***