Bug 303526 - Shell Crash after altering settings on Plasma panel
Summary: Shell Crash after altering settings on Plasma panel
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-14 15:11 UTC by Suzanna
Modified: 2012-07-14 15:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Suzanna 2012-07-14 15:11:19 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.90 (4.8.90)
Qt Version: 4.8.1
Operating System: Linux 3.5.0-4-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:I was working in the panel settings. I started with the clock to adjust color, 24 instead of 12 hour; Then I adjusted numbers (neg sign in currency) and Date formats;  When I went to close out the crash report happened.

I know there is a bug thread that is very similar but the report I looked at was NOT fully multiarch and I think were older releases of  Ubuntu and  Plasma. So i wanted to be sure that  this gets attached only if it is still the same underlying bug!

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fce760d57c0 (LWP 2259))]

Thread 3 (Thread 0x7fce55f47700 (LWP 2260)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fce6f393222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fce6f393259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fce66e5c6c4 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007fce69c17e9a in start_thread (arg=0x7fce55f47700) at pthread_create.c:308
#5  0x00007fce759b24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fce4df7c700 (LWP 2261)):
#0  0x00007fce759a6b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fce6951b036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fce6951b164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fce725e0426 in QEventDispatcherGlib::processEvents (this=0x7fce480008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fce725afc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fce725afed7 in QEventLoop::exec (this=0x7fce4df7bcd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fce724aefa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fce7258f9ff in QInotifyFileSystemWatcherEngine::run (this=0x1cae830) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fce724b1fcb in QThreadPrivate::start (arg=0x1cae830) at thread/qthread_unix.cpp:298
#9  0x00007fce66e5c6c4 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007fce69c17e9a in start_thread (arg=0x7fce4df7c700) at pthread_create.c:308
#11 0x00007fce759b24bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fce760d57c0 (LWP 2259)):
[KCrash Handler]
#6  0x0000014000000099 in ?? ()
#7  0x00007fce5619cccc in Plasma::CalendarTable::setDate (this=0x1af4cf0, newDate=...) at ../../../libs/plasmaclock/calendartable.cpp:495
#8  0x00007fce561992a1 in Plasma::Calendar::setDate (this=0x1af4db0, toDate=...) at ../../../libs/plasmaclock/calendar.cpp:279
#9  0x00007fce56190d83 in ClockApplet::updateClockApplet (this=0x1a0e120, data=...) at ../../../libs/plasmaclock/clockapplet.cpp:342
#10 0x00007fce563bdd08 in Clock::dataUpdated (this=0x1a0e120, source=..., data=...) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:257
#11 0x00007fce563be14d in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./clock.moc:64
#12 Clock::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./clock.moc:58
#13 0x00007fce725c5281 in QMetaObject::activate (sender=0x1b9f890, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffffa6fba10) at kernel/qobject.cpp:3547
#14 0x00007fce755026b7 in Plasma::SignalRelay::dataUpdated (this=<optimized out>, _t1=..., _t2=...) at ./datacontainer_p.moc:99
#15 0x00007fce755027d9 in timerEvent (this=0x1b9f890, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:157
#16 Plasma::SignalRelay::timerEvent (this=0x1b9f890, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:137
#17 0x00007fce725ca179 in QObject::event (this=0x1b9f890, e=<optimized out>) at kernel/qobject.cpp:1157
#18 0x00007fce71933894 in notify_helper (e=0x7ffffa6fc100, receiver=0x1b9f890, this=0x161a610) at kernel/qapplication.cpp:4559
#19 QApplicationPrivate::notify_helper (this=0x161a610, receiver=0x1b9f890, e=0x7ffffa6fc100) at kernel/qapplication.cpp:4531
#20 0x00007fce71938713 in QApplication::notify (this=0x160f580, receiver=0x1b9f890, e=0x7ffffa6fc100) at kernel/qapplication.cpp:4420
#21 0x00007fce732949e6 in KApplication::notify (this=0x160f580, receiver=0x1b9f890, event=0x7ffffa6fc100) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007fce725b0e9c in QCoreApplication::notifyInternal (this=0x160f580, receiver=0x1b9f890, event=0x7ffffa6fc100) at kernel/qcoreapplication.cpp:876
#23 0x00007fce725e21f2 in sendEvent (event=0x7ffffa6fc100, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QTimerInfoList::activateTimers (this=0x165f360) at kernel/qeventdispatcher_unix.cpp:611
#25 0x00007fce725dfc0d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#26 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#27 0x00007fce6951ad53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fce6951b0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fce6951b164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fce725e03bf in QEventDispatcherGlib::processEvents (this=0x155bad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0x00007fce719dbd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007fce725afc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fce725afed7 in QEventLoop::exec (this=0x7ffffa6fc360, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007fce725b4f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#35 0x00007fce75cb8b43 in kdemain (argc=1, argv=0x7ffffa6fc748) at ../../../../plasma/desktop/shell/main.cpp:120
#36 0x00007fce758e176d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7ffffa6fc748, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffffa6fc738) at libc-start.c:226
#37 0x0000000000400671 in _start ()

This bug may be a duplicate of or related to bug 299237.

Possible duplicates by query: bug 302706, bug 302687, bug 302406, bug 301882, bug 301761.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-14 15:14:54 UTC

*** This bug has been marked as a duplicate of bug 299237 ***