Bug 289946 - KMail crash while selecting messagse
Summary: KMail crash while selecting messagse
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-27 19:21 UTC by graham
Modified: 2012-01-02 19:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description graham 2011-12-27 19:21:21 UTC
Application: kmail (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.1-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

Selecting multiple messages in my Inbox by holding "shift" and clicking to select multiple messages.

This release of KMail as provided by the Fedora-16 "kde-4.7.4" update crashes far *more* than the previous 4.7.3 release did; it crashes for me several times per hour (which is far cry from the "never crashed at all" that I used to experience w/kmail pre-akonadi)

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fbdfe0ea840 (LWP 23006))]

Thread 3 (Thread 0x7fbdf06e4700 (LWP 23010)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000304f3973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x304fd90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x000000304f3974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003029207d90 in start_thread (arg=0x7fbdf06e4700) at pthread_create.c:309
#4  0x0000003028aef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fbdefdcb700 (LWP 23011)):
#0  0x0000003029209dd5 in __pthread_mutex_lock (mutex=0x7fbde80009a8) at pthread_mutex_lock.c:65
#1  0x000000302b244381 in g_main_context_query (context=0x7fbde80009a0, max_priority=2147483647, timeout=0x7fbdefdcac1c, fds=0x7fbde80013e0, n_fds=1) at gmain.c:2815
#2  0x000000302b244e8a in g_main_context_iterate (context=0x7fbde80009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3055
#3  0x000000302b24544c in g_main_context_iteration (context=0x7fbde80009a0, may_block=1) at gmain.c:3136
#4  0x00000030337a79c6 in QEventDispatcherGlib::processEvents (this=0x7fbde80008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003033777dc2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003033778017 in QEventLoop::exec (this=0x7fbdefdcad40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003033678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000303367bb1b in QThreadPrivate::start (arg=0x28de7d0) at thread/qthread_unix.cpp:298
#9  0x0000003029207d90 in start_thread (arg=0x7fbdefdcb700) at pthread_create.c:309
#10 0x0000003028aef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fbdfe0ea840 (LWP 23006)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff9c904600) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff9c904920) at access/qabstractnetworkcache.cpp:240
#8  0x000000303586edbc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x4a0bc70, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x0000003035870554 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4a0bc70, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00000030358f4e99 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4a0bc70, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x0000003033791b26 in QObject::event (this=0x4a0bc70, e=<optimized out>) at kernel/qobject.cpp:1194
#12 0x00000030365c96f4 in notify_helper (e=0x7fbd8c0095a0, receiver=0x4a0bc70, this=0x18e9e10) at kernel/qapplication.cpp:4518
#13 QApplicationPrivate::notify_helper (this=0x18e9e10, receiver=0x4a0bc70, e=0x7fbd8c0095a0) at kernel/qapplication.cpp:4490
#14 0x00000030365ce573 in QApplication::notify (this=0x7fff9c905460, receiver=0x4a0bc70, e=0x7fbd8c0095a0) at kernel/qapplication.cpp:4379
#15 0x0000003039650766 in KApplication::notify (this=0x7fff9c905460, receiver=0x4a0bc70, event=0x7fbd8c0095a0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#16 0x0000003033778c8c in QCoreApplication::notifyInternal (this=0x7fff9c905460, receiver=0x4a0bc70, event=0x7fbd8c0095a0) at kernel/qcoreapplication.cpp:876
#17 0x000000303377c71a in sendEvent (event=0x7fbd8c0095a0, receiver=0x4a0bc70) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x18a02d0) at kernel/qcoreapplication.cpp:1500
#19 0x00000030337a7533 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x18ec950) at kernel/qeventdispatcher_glib.cpp:279
#21 0x000000302b244a7d in g_main_dispatch (context=0x18ec860) at gmain.c:2425
#22 g_main_context_dispatch (context=0x18ec860) at gmain.c:2995
#23 0x000000302b245278 in g_main_context_iterate (context=0x18ec860, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#24 0x000000302b24544c in g_main_context_iteration (context=0x18ec860, may_block=1) at gmain.c:3136
#25 0x00000030337a795f in QEventDispatcherGlib::processEvents (this=0x18a1af0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#26 0x000000303666c2ce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#27 0x0000003033777dc2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x0000003033778017 in QEventLoop::exec (this=0x7fff9c905330, flags=...) at kernel/qeventloop.cpp:204
#29 0x000000303377ca15 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x0000000000402d23 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.7.4/kmail/main.cpp:145

Possible duplicates by query: bug 289179.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-01-02 19:44:23 UTC

*** This bug has been marked as a duplicate of bug 286307 ***