Bug 301623 - Plasma crash after setting change
Summary: Plasma crash after setting change
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-11 08:00 UTC by ytsedragyn
Modified: 2012-06-11 08:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ytsedragyn 2012-06-11 08:00:11 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I uninstalled and reinstalled KDE but when I tried to log into the Plasma desktop, it failed to load at all. I could right click and get a very limited menu so I logged out and tried installing Kubuntu instead of the separate KDE files and that got the desktop back the way I used to have it. Then I had been changing the desktop settings around after installing KDE when Plasma crashed a second time and this report got generated.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f15c730b780 (LWP 2940))]

Thread 8 (Thread 0x7f15a762c700 (LWP 2975)):
#0  __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:41
#1  __pthread_mutex_unlock (mutex=0x7f15a0000a60) at pthread_mutex_unlock.c:290
#2  0x00007f15badd5591 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f15bad99fea in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f15bad9a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f15c3dbd426 in QEventDispatcherGlib::processEvents (this=0x7f15a00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f15c3d8cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f15c3d8ced7 in QEventLoop::exec (this=0x7f15a762bdd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f15c3c8bfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f15c3d6c9ff in QInotifyFileSystemWatcherEngine::run (this=0xbbdb00) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f15c3c8efcb in QThreadPrivate::start (arg=0xbbdb00) at thread/qthread_unix.cpp:298
#11 0x00007f15bb69ee9a in start_thread (arg=0x7f15a762c700) at pthread_create.c:308
#12 0x00007f15c6bec4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f15a6052700 (LWP 2976)):
#0  0x00007f15bad99a45 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f15bad99f96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f15bad9a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f15c3dbd426 in QEventDispatcherGlib::processEvents (this=0x7f15940008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f15c3d8cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f15c3d8ced7 in QEventLoop::exec (this=0x7f15a6051dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f15c3c8bfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f15c3d6c9ff in QInotifyFileSystemWatcherEngine::run (this=0x15bd650) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f15c3c8efcb in QThreadPrivate::start (arg=0x15bd650) at thread/qthread_unix.cpp:298
#9  0x00007f15bb69ee9a in start_thread (arg=0x7f15a6052700) at pthread_create.c:308
#10 0x00007f15c6bec4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f15a556c700 (LWP 2977)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f15c0b71222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f15c0b71259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f15bb69ee9a in start_thread (arg=0x7f15a556c700) at pthread_create.c:308
#4  0x00007f15c6bec4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f1592dce700 (LWP 3393)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f15c3c8f4db in wait (time=18446744073709551615, this=0x165a810) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x162ec60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f15bf83a0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1738050, th=0x1f98150) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f15bf83c9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1630660, th=0x1f98150) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f15bf83b84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f1592dcde20, parent=0x1738050, th=0x1f98150) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f15bf83b8db in ThreadWeaver::Thread::run (this=0x1f98150) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f15c3c8efcb in QThreadPrivate::start (arg=0x1f98150) at thread/qthread_unix.cpp:298
#8  0x00007f15bb69ee9a in start_thread (arg=0x7f1592dce700) at pthread_create.c:308
#9  0x00007f15c6bec4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f1590f61700 (LWP 3394)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f15c3c8f4db in wait (time=18446744073709551615, this=0x165a810) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x162ec60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f15bf83a0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1738050, th=0x1ef34d0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f15bf83c9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1630660, th=0x1ef34d0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f15bf83b84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f1590f60e20, parent=0x1738050, th=0x1ef34d0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f15bf83b8db in ThreadWeaver::Thread::run (this=0x1ef34d0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f15c3c8efcb in QThreadPrivate::start (arg=0x1ef34d0) at thread/qthread_unix.cpp:298
#8  0x00007f15bb69ee9a in start_thread (arg=0x7f1590f61700) at pthread_create.c:308
#9  0x00007f15c6bec4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1587fff700 (LWP 3395)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f15c3c8f4db in wait (time=18446744073709551615, this=0x165a810) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x162ec60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f15bf83a0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1738050, th=0x161c620) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f15bf83c9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1630660, th=0x161c620) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f15bf83b84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f1587ffee20, parent=0x1738050, th=0x161c620) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f15bf83b8db in ThreadWeaver::Thread::run (this=0x161c620) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f15c3c8efcb in QThreadPrivate::start (arg=0x161c620) at thread/qthread_unix.cpp:298
#8  0x00007f15bb69ee9a in start_thread (arg=0x7f1587fff700) at pthread_create.c:308
#9  0x00007f15c6bec4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f15877fe700 (LWP 3396)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f15c3c8f4db in wait (time=18446744073709551615, this=0x165a810) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x162ec60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f15bf83a0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1738050, th=0x16c93c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f15bf83c9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1630660, th=0x16c93c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f15bf83c9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1630660, th=0x16c93c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f15bf83b84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f15877fde20, parent=0x1738050, th=0x16c93c0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f15bf83b8db in ThreadWeaver::Thread::run (this=0x16c93c0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f15c3c8efcb in QThreadPrivate::start (arg=0x16c93c0) at thread/qthread_unix.cpp:298
#9  0x00007f15bb69ee9a in start_thread (arg=0x7f15877fe700) at pthread_create.c:308
#10 0x00007f15c6bec4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f15c730b780 (LWP 2940)):
[KCrash Handler]
#6  0x00007f1500000001 in ?? ()
#7  0x00007f15aac12b6c in Plasma::CalendarTable::setDate (this=0x1286990, newDate=...) at ../../../libs/plasmaclock/calendartable.cpp:492
#8  0x00007f15aac0f1c1 in Plasma::Calendar::setDate (this=0x11481b0, toDate=...) at ../../../libs/plasmaclock/calendar.cpp:279
#9  0x00007f15aac06ca3 in ClockApplet::updateClockApplet (this=0x112ac10, data=...) at ../../../libs/plasmaclock/clockapplet.cpp:342
#10 0x00007f15aae33eb8 in Clock::dataUpdated (this=0x112ac10, source=..., data=...) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:257
#11 0x00007f15aae342fd in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./clock.moc:64
#12 Clock::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./clock.moc:58
#13 0x00007f15c3da2281 in QMetaObject::activate (sender=0x149cb40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff86602390) at kernel/qobject.cpp:3547
#14 0x00007f15c673c677 in Plasma::SignalRelay::dataUpdated (this=<optimized out>, _t1=..., _t2=...) at ./datacontainer_p.moc:99
#15 0x00007f15c673c799 in timerEvent (this=0x149cb40, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:157
#16 Plasma::SignalRelay::timerEvent (this=0x149cb40, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:137
#17 0x00007f15c3da7179 in QObject::event (this=0x149cb40, e=<optimized out>) at kernel/qobject.cpp:1157
#18 0x00007f15c3110894 in notify_helper (e=0x7fff86602a80, receiver=0x149cb40, this=0xa4a070) at kernel/qapplication.cpp:4559
#19 QApplicationPrivate::notify_helper (this=0xa4a070, receiver=0x149cb40, e=0x7fff86602a80) at kernel/qapplication.cpp:4531
#20 0x00007f15c3115713 in QApplication::notify (this=0xa466b0, receiver=0x149cb40, e=0x7fff86602a80) at kernel/qapplication.cpp:4420
#21 0x00007f15c4a6bbb6 in KApplication::notify (this=0xa466b0, receiver=0x149cb40, event=0x7fff86602a80) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007f15c3d8de9c in QCoreApplication::notifyInternal (this=0xa466b0, receiver=0x149cb40, event=0x7fff86602a80) at kernel/qcoreapplication.cpp:876
#23 0x00007f15c3dbf1f2 in sendEvent (event=0x7fff86602a80, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QTimerInfoList::activateTimers (this=0xa50460) at kernel/qeventdispatcher_unix.cpp:611
#25 0x00007f15c3dbcc0d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#26 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#27 0x00007f15bad99c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f15bad9a060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f15bad9a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f15c3dbd3bf in QEventDispatcherGlib::processEvents (this=0x9ccad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0x00007f15c31b8d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f15c3d8cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f15c3d8ced7 in QEventLoop::exec (this=0x7fff86602ce0, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007f15c3d91f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#35 0x00007f15c6ef8a13 in kdemain (argc=1, argv=0x7fff866030c8) at ../../../../plasma/desktop/shell/main.cpp:120
#36 0x00007f15c6b1b76d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff866030c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff866030b8) at libc-start.c:226
#37 0x0000000000400671 in _start ()

This bug may be a duplicate of or related to bug 299237.

Possible duplicates by query: bug 301596, bug 301296, bug 301288, bug 300888, bug 299237.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2012-06-11 08:58:46 UTC
Duplicate, thanks for your report!

*** This bug has been marked as a duplicate of bug 299237 ***