Bug 301596 - KDE crash when trying to install french language
Summary: KDE crash when trying to install french language
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-10 20:17 UTC by Xavier Besnard
Modified: 2012-06-10 20:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Besnard 2012-06-10 20:17:44 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.80 (4.8.80)
Qt Version: 4.8.2
Operating System: Linux 3.4.0-5-generic i686
Distribution: Ubuntu quantal (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I got a warning that the installation of French was incomplete when I tried to update my configuration using the loCalisation configutaion tool.

Then I tried to uninstall French and I got this crash.

Conf: Kubuntu Quantal 12.10 alpha 1

-- Backtrace:
Application: Outil de gestion de fenêtres Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1ac8740 (LWP 1630))]

Thread 5 (Thread 0xa978cb40 (LWP 1634)):
#0  0xb2c7ddcd in __GI_clock_gettime (clock_id=1, tp=0xa978bfa8) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb636de75 in do_gettime (frac=0xa978bfa0, sec=0xa978bf98) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb64535de in QTimerInfoList::updateCurrentTime (this=0xa8e02074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xa8e004e0 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xa8c75b40 (LWP 1635)):
#0  0xb76135c1 in pthread_mutex_lock (mutex=0xa8300550) at forward.c:182
#1  0xb2c05b50 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2bc588d in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2bc5d42 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2bc5f11 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6452c0f in QEventDispatcherGlib::processEvents (this=0xa8300468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb641f3dc in QEventLoop::processEvents (this=this@entry=0xa8c75248, flags=...) at kernel/qeventloop.cpp:149
#7  0xb641f6d1 in QEventLoop::exec (this=0xa8c75248, flags=...) at kernel/qeventloop.cpp:204
#8  0xb630c5ac in QThread::exec (this=0x8d1c010) at thread/qthread.cpp:501
#9  0xb63fdb6d in QInotifyFileSystemWatcherEngine::run (this=0x8d1c010) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb630f950 in QThreadPrivate::start (arg=0x8d1c010) at thread/qthread_unix.cpp:307
#11 0xb2cd7d4c in start_thread (arg=0xa8c75b40) at pthread_create.c:308
#12 0xb7605ace in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xa71e8b40 (LWP 1638)):
#0  0xb775d424 in __kernel_vsyscall ()
#1  0xb2cdb96b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0xb76133dc in __pthread_cond_wait (cond=0xb3d93650, mutex=0xb3d93638) at forward.c:139
#3  0xb3c80b4d in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3c80b7f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2cd7d4c in start_thread (arg=0xa71e8b40) at pthread_create.c:308
#6  0xb7605ace in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xa5b51b40 (LWP 1643)):
#0  0xb775d424 in __kernel_vsyscall ()
#1  0xb75f7380 in __GI___poll (fds=0xa7d03f08, nfds=3, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb2bd453b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2bc5db0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2bc628b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xa644b19a in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb2bea2f3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb2cd7d4c in start_thread (arg=0xa5b51b40) at pthread_create.c:308
#8  0xb7605ace in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb1ac8740 (LWP 1630)):
[KCrash Handler]
#7  0x00000017 in ?? ()
#8  0xaef11c8f in Plasma::CalendarTable::setDate(QDate const&) () from /usr/lib/libplasmaclock.so.4abi3
#9  0xaef0de64 in Plasma::Calendar::setDate(QDate const&) () from /usr/lib/libplasmaclock.so.4abi3
#10 0xaef06ae0 in ClockApplet::updateClockApplet(QHash<QString, QVariant> const&) () from /usr/lib/libplasmaclock.so.4abi3
#11 0xaef512f6 in ?? () from /usr/lib/kde4/plasma_applet_dig_clock.so
#12 0xaef51746 in ?? () from /usr/lib/kde4/plasma_applet_dig_clock.so
#13 0xb6439046 in QMetaObject::activate (sender=0x8c6abd0, m=0xb75108b8, local_signal_index=0, argv=0xbfc70864) at kernel/qobject.cpp:3547
#14 0xb734afdd in Plasma::SignalRelay::dataUpdated (this=this@entry=0x8c6abd0, _t1=..., _t2=...) at ./datacontainer_p.moc:99
#15 0xb734b16f in timerEvent (this=0x8c6abd0, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:157
#16 Plasma::SignalRelay::timerEvent (this=0x8c6abd0, event=0xbfc70d50) at ../../plasma/private/datacontainer_p.cpp:137
#17 0xb6436ea4 in QObject::event (this=0x8c6abd0, e=0xbfc70d50) at kernel/qobject.cpp:1157
#18 0xb59132ec in QApplicationPrivate::notify_helper (this=0x8703628, receiver=0x8c6abd0, e=0xbfc70d50) at kernel/qapplication.cpp:4556
#19 0xb5917d0f in QApplication::notify (this=0xbfc70d50, receiver=0x8c6abd0, e=0xbfc70d50) at kernel/qapplication.cpp:3938
#20 0xb6aac721 in KApplication::notify (this=0x86f23c0, receiver=0x8c6abd0, event=0xbfc70d50) at ../../kdeui/kernel/kapplication.cpp:311
#21 0xb64208fe in QCoreApplication::notifyInternal (this=0x86f23c0, receiver=0x8c6abd0, event=0xbfc70d50) at kernel/qcoreapplication.cpp:915
#22 0xb6455430 in sendEvent (event=0xbfc70d50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 QTimerInfoList::activateTimers (this=0x87034b4) at kernel/qeventdispatcher_unix.cpp:611
#24 0xb6452578 in timerSourceDispatch (source=0x8703480) at kernel/qeventdispatcher_glib.cpp:186
#25 timerSourceDispatch (source=0x8703480) at kernel/qeventdispatcher_glib.cpp:180
#26 0xb64525b2 in idleTimerSourceDispatch (source=0x8700c38) at kernel/qeventdispatcher_glib.cpp:233
#27 0xb2bc5a93 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#28 0xb2bc5e30 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0xb2bc5f11 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb6452c0f in QEventDispatcherGlib::processEvents (this=0x86abeb8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#31 0xb59c98fa in QGuiEventDispatcherGlib::processEvents (this=0x86abeb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0xb641f3dc in QEventLoop::processEvents (this=this@entry=0xbfc70fd8, flags=...) at kernel/qeventloop.cpp:149
#33 0xb641f6d1 in QEventLoop::exec (this=0xbfc70fd8, flags=...) at kernel/qeventloop.cpp:204
#34 0xb6424e2a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#35 0xb5910ef4 in QApplication::exec () at kernel/qapplication.cpp:3817
#36 0xb7712c53 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#37 0x0804855b in ?? ()
#38 0xb75344d3 in __libc_start_main (main=0x8048540, argc=1, ubp_av=0xbfc71194, init=0x8048660 <__libc_csu_init>, fini=0x80486d0 <__libc_csu_fini>, rtld_fini=0xb776d270 <_dl_fini>, stack_end=0xbfc7118c) at libc-start.c:226
#39 0x08048581 in _start ()

Possible duplicates by query: bug 301296, bug 301288, bug 300888, bug 299237.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2012-06-10 20:34:28 UTC
Duplicate of 299237, thanks for your report!

*** This bug has been marked as a duplicate of bug 299237 ***