Bug 301720 - Plasma crashed after changing system Local to THe netherlands
Summary: Plasma crashed after changing system Local to THe netherlands
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-12 10:34 UTC by Ko van Zeeland
Modified: 2012-06-12 11:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ko van Zeeland 2012-06-12 10:34:52 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Did change the screen layout, did set the language and other setting to Local Netherlands. afther doing that a screen came up telling new items to update the system where available . After installing and reboot the crash came up

-- Backtrace:
Application: Plasma bureaublad-shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1a41740 (LWP 1861))]

Thread 5 (Thread 0xa9805b40 (LWP 1862)):
#0  0xb7706424 in __kernel_vsyscall ()
#1  0xb75aa17b in read () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b7766e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b38af0 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b39002 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2b391c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb63de8e7 in QEventDispatcherGlib::processEvents (this=0xa8f00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb63aa50d in QEventLoop::processEvents (this=0xa9805240, flags=...) at kernel/qeventloop.cpp:149
#8  0xb63aa7a9 in QEventLoop::exec (this=0xa9805240, flags=...) at kernel/qeventloop.cpp:204
#9  0xb629394c in QThread::exec (this=0x8ef1b80) at thread/qthread.cpp:501
#10 0xb6387b5d in QInotifyFileSystemWatcherEngine::run (this=0x8ef1b80) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb6296de0 in QThreadPrivate::start (arg=0x8ef1b80) at thread/qthread_unix.cpp:298
#12 0xb2c49d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb75baace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xa8d27b40 (LWP 1863)):
#0  0xb2c4bdc8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb75c85f4 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b78390 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b38262 in g_main_context_release () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b39018 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2b391c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb63de8e7 in QEventDispatcherGlib::processEvents (this=0xa8400468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb63aa50d in QEventLoop::processEvents (this=0xa8d27240, flags=...) at kernel/qeventloop.cpp:149
#8  0xb63aa7a9 in QEventLoop::exec (this=0xa8d27240, flags=...) at kernel/qeventloop.cpp:204
#9  0xb629394c in QThread::exec (this=0x883dec0) at thread/qthread.cpp:501
#10 0xb6387b5d in QInotifyFileSystemWatcherEngine::run (this=0x883dec0) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb6296de0 in QThreadPrivate::start (arg=0x883dec0) at thread/qthread_unix.cpp:298
#12 0xb2c49d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb75baace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa831bb40 (LWP 1864)):
#0  0xb7706424 in __kernel_vsyscall ()
#1  0xb2c4d96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75c83dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb3c0c029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3c0c06f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2c49d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb75baace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa69ffb40 (LWP 1866)):
#0  0xb75c87e0 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0xb75ac392 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b46a3b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b3906e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b3952b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xa748d0ea in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb2b5c673 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb2c49d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb75baace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb1a41740 (LWP 1861)):
[KCrash Handler]
#7  0x00000006 in ?? ()
#8  0xaef7e0cf in Plasma::CalendarTable::setDate (this=0x8be0e98, newDate=...) at ../../../libs/plasmaclock/calendartable.cpp:492
#9  0xaef79874 in Plasma::Calendar::setDate (this=0x8bde2c8, toDate=...) at ../../../libs/plasmaclock/calendar.cpp:279
#10 0xaef704f8 in ClockApplet::updateClockApplet (this=0x8bc62a8, data=...) at ../../../libs/plasmaclock/clockapplet.cpp:342
#11 0xaef9e902 in Clock::dataUpdated (this=0x8bc62a8, source=..., data=...) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:257
#12 0xaef9ed6e in qt_static_metacall (_a=0xbfc175d4, _id=0, _o=0x8bc62a8, _c=<optimized out>) at ./clock.moc:64
#13 Clock::qt_static_metacall (_o=0x8bc62a8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc175d4) at ./clock.moc:58
#14 0xb63c26b1 in QMetaObject::activate (sender=0x8ec4740, m=0xb74c5878, local_signal_index=0, argv=0xbfc175d4) at kernel/qobject.cpp:3547
#15 0xb72fe69d in Plasma::SignalRelay::dataUpdated (this=0x8ec4740, _t1=..., _t2=...) at ./datacontainer_p.moc:99
#16 0xb72fe82f in timerEvent (this=0x8ec4740, event=<optimized out>) at ../../plasma/private/datacontainer_p.cpp:157
#17 Plasma::SignalRelay::timerEvent (this=0x8ec4740, event=0xbfc17acc) at ../../plasma/private/datacontainer_p.cpp:137
#18 0xb63c6ac4 in QObject::event (this=0x8ec4740, e=0xbfc17acc) at kernel/qobject.cpp:1157
#19 0xb5896ed4 in notify_helper (e=0xbfc17acc, receiver=0x8ec4740, this=0x880eeb0) at kernel/qapplication.cpp:4559
#20 QApplicationPrivate::notify_helper (this=0x880eeb0, receiver=0x8ec4740, e=0xbfc17acc) at kernel/qapplication.cpp:4531
#21 0xb589c30d in QApplication::notify (this=0xbfc17acc, receiver=0x8ec4740, e=0xbfc17acc) at kernel/qapplication.cpp:4288
#22 0xb6a45b61 in KApplication::notify (this=0x88062c8, receiver=0x8ec4740, event=0xbfc17acc) at ../../kdeui/kernel/kapplication.cpp:311
#23 0xb63ab97e in QCoreApplication::notifyInternal (this=0x88062c8, receiver=0x8ec4740, event=0xbfc17acc) at kernel/qcoreapplication.cpp:876
#24 0xb63e0990 in sendEvent (event=0xbfc17acc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#25 QTimerInfoList::activateTimers (this=0x8810cb4) at kernel/qeventdispatcher_unix.cpp:611
#26 0xb63de0f8 in timerSourceDispatch (source=0x8810c80) at kernel/qeventdispatcher_glib.cpp:186
#27 timerSourceDispatch (source=0x8810c80) at kernel/qeventdispatcher_glib.cpp:180
#28 0xb2b38cda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0xb2b390e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb2b391c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb63de887 in QEventDispatcherGlib::processEvents (this=0x87b9eb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#32 0xb594faaa in QGuiEventDispatcherGlib::processEvents (this=0x87b9eb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0xb63aa50d in QEventLoop::processEvents (this=0xbfc17d34, flags=...) at kernel/qeventloop.cpp:149
#34 0xb63aa7a9 in QEventLoop::exec (this=0xbfc17d34, flags=...) at kernel/qeventloop.cpp:204
#35 0xb63afeba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#36 0xb5894a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#37 0xb76baa7b in kdemain (argc=1, argv=0xbfc17f34) at ../../../../plasma/desktop/shell/main.cpp:120
#38 0x0804850b in main (argc=1, argv=0xbfc17f34) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 299237.

Possible duplicates by query: bug 301623, bug 301596, bug 301296, bug 301288, bug 300888.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-12 11:13:49 UTC

*** This bug has been marked as a duplicate of bug 299237 ***