Bug 302020 - KMail crashes when user clicks on the sendername
Summary: KMail crashes when user clicks on the sendername
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-16 19:01 UTC by Russ Hay
Modified: 2012-06-25 06:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Hay 2012-06-16 19:01:11 UTC
Application: kmail (4.9 beta1)
KDE Platform Version: 4.8.3 (4.8.3) "release 1"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-1.9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
I clicked on the senders name in the mail list - kmail was using the fancy theme, clickable status at the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9aca3eb780 (LWP 4201))]

Thread 4 (Thread 0x7f9aac049700 (LWP 4273)):
#0  0x00007f9ac5515e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9abb943c12 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9abc2e21a0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007f9abb943c49 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007f9ac5511f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9ac770d10d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9aab730700 (LWP 4275)):
#0  0x00007f9ac7703ff3 in poll () from /lib64/libc.so.6
#1  0x00007f9abf671a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9abf671f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9ac8d6be36 in QEventDispatcherGlib::processEvents (this=0x7f9aa40008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9ac8d3b842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9ac8d3ba97 in QEventLoop::exec (this=0x7f9aab72fe00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9ac8c3b5f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9ac8c3e61b in QThreadPrivate::start (arg=0xb0f550) at thread/qthread_unix.cpp:307
#8  0x00007f9ac5511f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9ac770d10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9aa9c15700 (LWP 4892)):
#0  0x00007f9ac55161eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9ac8c3ea8f in wait (time=30000, this=0xd8bad0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xd8ba78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9ac8c31e9f in QThreadPoolThread::run (this=0xd95930) at concurrent/qthreadpool.cpp:141
#4  0x00007f9ac8c3e61b in QThreadPrivate::start (arg=0xd95930) at thread/qthread_unix.cpp:307
#5  0x00007f9ac5511f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f9ac770d10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9aca3eb780 (LWP 4201)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x1efa080, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#7  0x00007f9ac675d509 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x1efa080, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f9ac8d55e06 in QObject::event (this=0x1efa080, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f9ac80bffe4 in notify_helper (e=0x7f9a38026680, receiver=0x1efa080, this=0x66c400) at kernel/qapplication.cpp:4551
#10 QApplicationPrivate::notify_helper (this=0x66c400, receiver=0x1efa080, e=0x7f9a38026680) at kernel/qapplication.cpp:4523
#11 0x00007f9ac80c4db3 in QApplication::notify (this=0x7fff6fea5390, receiver=0x1efa080, e=0x7f9a38026680) at kernel/qapplication.cpp:4412
#12 0x00007f9ac9e02926 in KApplication::notify (this=0x7fff6fea5390, receiver=0x1efa080, event=0x7f9a38026680) at /usr/src/debug/kdelibs-4.8.80_20120529/kdeui/kernel/kapplication.cpp:311
#13 0x00007f9ac8d3cd0c in QCoreApplication::notifyInternal (this=0x7fff6fea5390, receiver=0x1efa080, event=0x7f9a38026680) at kernel/qcoreapplication.cpp:915
#14 0x00007f9ac8d405ba in sendEvent (event=0x7f9a38026680, receiver=0x1efa080) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b740) at kernel/qcoreapplication.cpp:1539
#16 0x00007f9ac8d6b9a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x66ed60) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f9abf67158d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f9abf671d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f9abf671f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f9ac8d6bdcf in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f9ac816369e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f9ac8d3b842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f9ac8d3ba97 in QEventLoop::exec (this=0x7fff6fea5260, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f9ac8d408b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#26 0x0000000000402df3 in ?? ()
#27 0x00007f9ac765323d in __libc_start_main () from /lib64/libc.so.6
#28 0x00000000004032d5 in _start ()

Possible duplicates by query: bug 301840, bug 301561, bug 301377, bug 301066, bug 300858.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-06-25 06:59:16 UTC

*** This bug has been marked as a duplicate of bug 286307 ***