Bug 301561 - KMail crashed after deleting mail-messages
Summary: KMail crashed after deleting mail-messages
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-10 08:39 UTC by Alexander
Modified: 2012-06-10 12:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2012-06-10 08:39:50 UTC
Application: kmail (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
KMail crashed after listing mail-boxes.
KMail crashed after deleting mail-messages.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Illegal instruction
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb14a1740 (LWP 14302))]

Thread 4 (Thread 0xae65ab40 (LWP 14352)):
#0  0xb7770424 in __kernel_vsyscall ()
#1  0xb587296b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb5eda3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb3883263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb388337f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb586ed4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb5eccace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xadd31b40 (LWP 14353)):
#0  0xb7770424 in __kernel_vsyscall ()
#1  0xb5ebe380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb44eca3b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb44df06e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb44df1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb623a8e7 in QEventDispatcherGlib::processEvents (this=0xad400468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb620650d in QEventLoop::processEvents (this=0xadd31270, flags=...) at kernel/qeventloop.cpp:149
#7  0xb62067a9 in QEventLoop::exec (this=0xadd31270, flags=...) at kernel/qeventloop.cpp:204
#8  0xb60ef94c in QThread::exec (this=0x8e5f808) at thread/qthread.cpp:501
#9  0xb60efa3b in QThread::run (this=0x8e5f808) at thread/qthread.cpp:568
#10 0xb60f2de0 in QThreadPrivate::start (arg=0x8e5f808) at thread/qthread_unix.cpp:298
#11 0xb586ed4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5eccace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xac0f6b40 (LWP 14373)):
#0  0xb451e0ac in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb451e388 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb44de76c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb44def6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb44df1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb623a8e7 in QEventDispatcherGlib::processEvents (this=0xab700468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb620650d in QEventLoop::processEvents (this=0xac0f6240, flags=...) at kernel/qeventloop.cpp:149
#7  0xb62067a9 in QEventLoop::exec (this=0xac0f6240, flags=...) at kernel/qeventloop.cpp:204
#8  0xb60ef94c in QThread::exec (this=0x91e6158) at thread/qthread.cpp:501
#9  0xb61e3b5d in QInotifyFileSystemWatcherEngine::run (this=0x91e6158) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb60f2de0 in QThreadPrivate::start (arg=0x91e6158) at thread/qthread_unix.cpp:298
#11 0xb586ed4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5eccace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb14a1740 (LWP 14302)):
[KCrash Handler]
#7  0xb0838b28 in icudt48_dat () from /usr/lib/libicudata.so.48
#8  0xb5a76254 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x94ba500, hm=..., sc=-1081457240, rp=..., pu=40, db=..., contentLength=-1246674500) at access/qnetworkaccesshttpbackend.cpp:827
#9  0xb5b0d37d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x94ba500, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xac61d7a8) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#10 0xb6219c01 in QMetaCallEvent::placeMetaCall (this=0xac60e4f8, object=0x94ba500) at kernel/qobject.cpp:525
#11 0xb6222c7b in QObject::event (this=0x94ba500, e=0xac60e4f8) at kernel/qobject.cpp:1195
#12 0xb64a2ed4 in notify_helper (e=0xac60e4f8, receiver=0x94ba500, this=0x8a0fbf8) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0x8a0fbf8, receiver=0x94ba500, e=0xac60e4f8) at kernel/qapplication.cpp:4531
#14 0xb64a830d in QApplication::notify (this=0xac60e4f8, receiver=0x94ba500, e=0xac60e4f8) at kernel/qapplication.cpp:4288
#15 0xb74ffb61 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#16 0xb620797e in QCoreApplication::notifyInternal (this=0xbf8a4e5c, receiver=0x94ba500, event=0xac60e4f8) at kernel/qcoreapplication.cpp:876
#17 0xb620bad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x89cb150) at kernel/qcoreapplication.cpp:1500
#19 0xb620be0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#20 0xb623a494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0x8a10f80) at kernel/qeventdispatcher_glib.cpp:279
#22 0xb44decda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb44df0e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb44df1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb623a887 in QEventDispatcherGlib::processEvents (this=0x89cbec0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0xb655baaa in QGuiEventDispatcherGlib::processEvents (this=0x89cbec0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0xb620650d in QEventLoop::processEvents (this=0xbf8a4d84, flags=...) at kernel/qeventloop.cpp:149
#28 0xb62067a9 in QEventLoop::exec (this=0xbf8a4d84, flags=...) at kernel/qeventloop.cpp:204
#29 0xb620beba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0xb64a0a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#31 0x0804a266 in ?? ()
#32 0xb5dfb4d3 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#33 0x0804a6e9 in _start ()

This bug may be a duplicate of or related to bug 299923.

Possible duplicates by query: bug 299923.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-10 12:47:08 UTC

*** This bug has been marked as a duplicate of bug 286307 ***