Bug 301377 - KMail crashed while moving a message to a IMAP folder
Summary: KMail crashed while moving a message to a IMAP folder
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 16:34 UTC by Bigey
Modified: 2012-06-07 16:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bigey 2012-06-07 16:34:00 UTC
Application: kmail (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Select a message,
move the message to an IMAP folder,
the the application crashed.

This is the second times that bug occured.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0fb15097c0 (LWP 1772))]

Thread 4 (Thread 0x7f0f8a779700 (LWP 1833)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0fa37eadec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f0fa37eaf19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f0fac322e9a in start_thread (arg=0x7f0f8a779700) at pthread_create.c:308
#4  0x00007f0fae8534bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f0f89e60700 (LWP 1834)):
#0  0x00007f0fae847b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0fa70f6ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0fa70f7124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0faf1de426 in QEventDispatcherGlib::processEvents (this=0x7f0f840008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f0faf1adc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0faf1aded7 in QEventLoop::exec (this=0x7f0f89e5fdc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f0faf0acfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f0faf0affcb in QThreadPrivate::start (arg=0x1482de0) at thread/qthread_unix.cpp:298
#8  0x00007f0fac322e9a in start_thread (arg=0x7f0f89e60700) at pthread_create.c:308
#9  0x00007f0fae8534bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0f3b771700 (LWP 2053)):
#0  0x00007f0fae847b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0fa70f6ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0fa70f7124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0faf1de426 in QEventDispatcherGlib::processEvents (this=0x7f0f300008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f0faf1adc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0faf1aded7 in QEventLoop::exec (this=0x7f0f3b770d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f0faf0acfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f0faf18d9ff in QInotifyFileSystemWatcherEngine::run (this=0x1f752d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0faf0affcb in QThreadPrivate::start (arg=0x1f752d0) at thread/qthread_unix.cpp:298
#9  0x00007f0fac322e9a in start_thread (arg=0x7f0f3b771700) at pthread_create.c:308
#10 0x00007f0fae8534bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0fb15097c0 (LWP 1772)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x25474b0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f0fad888709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x25474b0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f0faf1c8446 in QObject::event (this=0x25474b0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f0faf6d1894 in notify_helper (e=0x7f0f3c045300, receiver=0x25474b0, this=0xf16f10) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0xf16f10, receiver=0x25474b0, e=0x7f0f3c045300) at kernel/qapplication.cpp:4531
#11 0x00007f0faf6d6713 in QApplication::notify (this=0x7fffa19fcf00, receiver=0x25474b0, e=0x7f0f3c045300) at kernel/qapplication.cpp:4420
#12 0x00007f0fb0f0bbb6 in KApplication::notify (this=0x7fffa19fcf00, receiver=0x25474b0, event=0x7f0f3c045300) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f0faf1aee9c in QCoreApplication::notifyInternal (this=0x7fffa19fcf00, receiver=0x25474b0, event=0x7f0f3c045300) at kernel/qcoreapplication.cpp:876
#14 0x00007f0faf1b2c6a in sendEvent (event=0x7f0f3c045300, receiver=0x25474b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xeba220) at kernel/qcoreapplication.cpp:1500
#16 0x00007f0faf1ddf93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f0fa70f6c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f0fa70f7060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f0fa70f7124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f0faf1de3bf in QEventDispatcherGlib::processEvents (this=0xebbb00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f0faf779d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f0faf1adc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f0faf1aded7 in QEventLoop::exec (this=0x7fffa19fcde0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f0faf1b2f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in main (argc=<optimized out>, argv=<optimized out>) at ../../kmail/main.cpp:145

This bug may be a duplicate of or related to bug 299769.

Possible duplicates by query: bug 301066, bug 300858, bug 300639, bug 300508, bug 300423.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-06-07 16:42:31 UTC

*** This bug has been marked as a duplicate of bug 286307 ***