Bug 301066 - Kmail crashes
Summary: Kmail crashes
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-02 17:43 UTC by Rodrigo Otavio
Modified: 2012-06-06 13:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Otavio 2012-06-02 17:43:05 UTC
Application: kmail (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
Kmail crash where start's every time, it run by 5 minutes aprox. and crashs!

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fdee590b7c0 (LWP 2928))]

Thread 4 (Thread 0x7fdec30b3700 (LWP 2932)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fded7bfddec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fded7bfdf19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fdee0735e9a in start_thread (arg=0x7fdec30b3700) at pthread_create.c:308
#4  0x00007fdee2c664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fdec279a700 (LWP 2933)):
#0  0x00007fdee2c5ab03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fdedb509ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdedb50a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdee35f1426 in QEventDispatcherGlib::processEvents (this=0x7fdebc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fdee35c0c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fdee35c0ed7 in QEventLoop::exec (this=0x7fdec2799dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fdee34bffa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fdee34c2fcb in QThreadPrivate::start (arg=0x1666770) at thread/qthread_unix.cpp:298
#8  0x00007fdee0735e9a in start_thread (arg=0x7fdec279a700) at pthread_create.c:308
#9  0x00007fdee2c664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fde7b70a700 (LWP 2938)):
#0  0x00007fdee2c5ab03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fdedb509ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdedb50a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdee35f1426 in QEventDispatcherGlib::processEvents (this=0x7fde700008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fdee35c0c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fdee35c0ed7 in QEventLoop::exec (this=0x7fde7b709d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fdee34bffa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fdee35a09ff in QInotifyFileSystemWatcherEngine::run (this=0x1b56870) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fdee34c2fcb in QThreadPrivate::start (arg=0x1b56870) at thread/qthread_unix.cpp:298
#9  0x00007fdee0735e9a in start_thread (arg=0x7fde7b70a700) at pthread_create.c:308
#10 0x00007fdee2c664bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fdee590b7c0 (LWP 2928)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x388a810, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fdee1c9b709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x388a810, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fdee35db446 in QObject::event (this=0x388a810, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fdee3ae4894 in notify_helper (e=0x7fde60017e30, receiver=0x388a810, this=0x1062330) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x1062330, receiver=0x388a810, e=0x7fde60017e30) at kernel/qapplication.cpp:4531
#11 0x00007fdee3ae9713 in QApplication::notify (this=0x7fffad1e03d0, receiver=0x388a810, e=0x7fde60017e30) at kernel/qapplication.cpp:4420
#12 0x00007fdee531ebb6 in KApplication::notify (this=0x7fffad1e03d0, receiver=0x388a810, event=0x7fde60017e30) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007fdee35c1e9c in QCoreApplication::notifyInternal (this=0x7fffad1e03d0, receiver=0x388a810, event=0x7fde60017e30) at kernel/qcoreapplication.cpp:876
#14 0x00007fdee35c5c6a in sendEvent (event=0x7fde60017e30, receiver=0x388a810) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x100f220) at kernel/qcoreapplication.cpp:1500
#16 0x00007fdee35f0f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fdedb509c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fdedb50a060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fdedb50a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fdee35f13bf in QEventDispatcherGlib::processEvents (this=0x1070070, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fdee3b8cd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fdee35c0c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fdee35c0ed7 in QEventLoop::exec (this=0x7fffad1e02b0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fdee35c5f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in main (argc=<optimized out>, argv=<optimized out>) at ../../kmail/main.cpp:145

Possible duplicates by query: bug 300858, bug 300639, bug 300508, bug 300423, bug 299923.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-06-06 13:01:07 UTC

*** This bug has been marked as a duplicate of bug 286307 ***