Bug 301555 - Plasma Desktop crash when changing the byte size units in Locale on systemsettings
Summary: Plasma Desktop crash when changing the byte size units in Locale on systemset...
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-10 06:15 UTC by JoseLuisT
Modified: 2012-06-10 07:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JoseLuisT 2012-06-10 06:15:50 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I opened systemsettings the I went to Locale, then in the "country/region Language" module y went to the "Other" tab and set another option from default in "Byte size units", then plasma-desktop crashed. 

It happens always when I change settings in locale, thus my suggestion of a possible duplcate of 299237

I'm using KDE 4.8.3 
systemsettings 1.0 
Ubuntu 12.04 64 bits.

The crash can be reproduced every time.

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb60d36f7c0 (LWP 7243))]

Thread 4 (Thread 0x7fb5e488a700 (LWP 7301)):
#0  0x00007fb60170405d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7fb5d4000a80) at pthread_mutex_unlock.c:290
#2  0x00007fb600e37591 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb600dfbb59 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb600dfc060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fb600dfc124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fb609e1f426 in QEventDispatcherGlib::processEvents (this=0x7fb5d40008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007fb609deec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007fb609deeed7 in QEventLoop::exec (this=0x7fb5e4889cd0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007fb609cedfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#10 0x00007fb609dce9ff in QInotifyFileSystemWatcherEngine::run (this=0x352eb70) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x00007fb609cf0fcb in QThreadPrivate::start (arg=0x352eb70) at thread/qthread_unix.cpp:298
#12 0x00007fb5fe0f5b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#13 0x00007fb601700e9a in start_thread (arg=0x7fb5e488a700) at pthread_create.c:308
#14 0x00007fb60cc4e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#15 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb5d96ea700 (LWP 7302)):
#0  0x00007fb601702f69 in __pthread_mutex_lock (mutex=0x7fb5cc000a80) at pthread_mutex_lock.c:92
#1  0x00007fb600e37561 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb600dfbef5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb600dfc124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb609e1f426 in QEventDispatcherGlib::processEvents (this=0x7fb5cc0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fb609deec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fb609deeed7 in QEventLoop::exec (this=0x7fb5d96e9cd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fb609cedfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fb609dce9ff in QInotifyFileSystemWatcherEngine::run (this=0x3a7e130) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fb609cf0fcb in QThreadPrivate::start (arg=0x3a7e130) at thread/qthread_unix.cpp:298
#10 0x00007fb5fe0f5b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#11 0x00007fb601700e9a in start_thread (arg=0x7fb5d96ea700) at pthread_create.c:308
#12 0x00007fb60cc4e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb5d8c04700 (LWP 7311)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb606bd3222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fb606bd3259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fb5fe0f5b74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007fb601700e9a in start_thread (arg=0x7fb5d8c04700) at pthread_create.c:308
#5  0x00007fb60cc4e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb60d36f7c0 (LWP 7243)):
[KCrash Handler]
#6  0x0000000005174ff0 in ?? ()
#7  0x00007fb5ecf44230 in Clock::paintInterface (this=0x2650720, p=0x7fff79b3ec20, contentsRect=..., option=<optimized out>) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:476
#8  0x00007fb60c732146 in Plasma::Applet::paint (this=0x2650720, painter=0x7fff79b3ec20, option=0x246b048, widget=0x0) at ../../plasma/applet.cpp:1466
#9  0x00007fb60977897d in _q_paintItem (item=<optimized out>, painter=0x7fff79b3ec20, option=0x246b048, widget=0x0, useWindowOpacity=<optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4335
#10 0x00007fb60977954a in _q_paintIntoCache (pix=0x7fff79b3f1b0, item=0x2650730, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x246b048, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4373
#11 0x00007fb609791988 in QGraphicsScenePrivate::drawItemHelper (this=0x246ae20, item=0x2650730, painter=0x7fff79b40650, option=0x246b048, widget=<optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4694
#12 0x00007fb60979234b in QGraphicsScenePrivate::draw (this=0x246ae20, item=0x2650730, painter=0x7fff79b40650, viewTransform=0x7fff79b40320, transformPtr=0x7fff79b3f7a0, exposedRegion=0x287aae8, widget=0x288f630, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4966
#13 0x00007fb6097933d5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x246ae20, item=0x2650730, painter=0x7fff79b40650, viewTransform=0x7fff79b40320, exposedRegion=0x287aae8, widget=0x288f630, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4857
#14 0x00007fb609792420 in QGraphicsScenePrivate::draw (this=0x246ae20, item=0x265b3d0, painter=0x7fff79b40650, viewTransform=0x7fff79b40320, transformPtr=0x7fff79b3fdf0, exposedRegion=0x287aae8, widget=0x288f630, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4996
#15 0x00007fb6097933d5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x246ae20, item=0x265b3d0, painter=0x7fff79b40650, viewTransform=0x7fff79b40320, exposedRegion=0x287aae8, widget=0x288f630, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x00007fb609793bf1 in QGraphicsScenePrivate::drawItems (this=0x246ae20, painter=0x7fff79b40650, viewTransform=0x7fff79b40320, exposedRegion=0x287aae8, widget=0x288f630) at graphicsview/qgraphicsscene.cpp:4739
#17 0x00007fb6097ac870 in QGraphicsView::paintEvent (this=<optimized out>, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x00007fb6091c30f6 in QWidget::event (this=0x2878650, event=0x7fff79b40ff0) at kernel/qwidget.cpp:8508
#19 0x00007fb6095833b6 in QFrame::event (this=0x2878650, e=0x7fff79b40ff0) at widgets/qframe.cpp:557
#20 0x00007fb6097adb2b in QGraphicsView::viewportEvent (this=0x2878650, event=0x7fff79b40ff0) at graphicsview/qgraphicsview.cpp:2866
#21 0x00007fb609df0028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x288f630, event=0x7fff79b40ff0) at kernel/qcoreapplication.cpp:986
#22 0x00007fb60917285f in notify_helper (e=0x7fff79b40ff0, receiver=0x288f630, this=0x228e580) at kernel/qapplication.cpp:4555
#23 QApplicationPrivate::notify_helper (this=0x228e580, receiver=0x288f630, e=0x7fff79b40ff0) at kernel/qapplication.cpp:4531
#24 0x00007fb609177713 in QApplication::notify (this=0x2280ad0, receiver=0x288f630, e=0x7fff79b40ff0) at kernel/qapplication.cpp:4420
#25 0x00007fb60aacdbb6 in KApplication::notify (this=0x2280ad0, receiver=0x288f630, event=0x7fff79b40ff0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007fb609defe9c in QCoreApplication::notifyInternal (this=0x2280ad0, receiver=0x288f630, event=0x7fff79b40ff0) at kernel/qcoreapplication.cpp:876
#27 0x00007fb6091bed96 in sendSpontaneousEvent (event=0x7fff79b40ff0, receiver=0x288f630) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#28 QWidgetPrivate::drawWidget (this=0x288f660, pdev=0x3b256a0, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x288fbf0) at kernel/qwidget.cpp:5585
#29 0x00007fb6091bfa0f in QWidgetPrivate::paintSiblingsRecursive (this=0x287a660, pdev=0x3b256a0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x288fbf0) at kernel/qwidget.cpp:5794
#30 0x00007fb6091beacc in QWidgetPrivate::drawWidget (this=0x287a660, pdev=0x3b256a0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x288fbf0) at kernel/qwidget.cpp:5638
#31 0x00007fb60938fb58 in QWidgetBackingStore::sync (this=0x288fbf0) at painting/qbackingstore.cpp:1373
#32 0x00007fb6091b5ac0 in QWidgetPrivate::syncBackingStore (this=0x287a660) at kernel/qwidget.cpp:1891
#33 0x00007fb6091c360c in QWidget::event (this=0x2878650, event=0x30d37b0) at kernel/qwidget.cpp:8655
#34 0x00007fb6095833b6 in QFrame::event (this=0x2878650, e=0x30d37b0) at widgets/qframe.cpp:557
#35 0x00007fb6096054c3 in QAbstractScrollArea::event (this=0x2878650, e=0x30d37b0) at widgets/qabstractscrollarea.cpp:996
#36 0x00007fb609172894 in notify_helper (e=0x30d37b0, receiver=0x2878650, this=0x228e580) at kernel/qapplication.cpp:4559
#37 QApplicationPrivate::notify_helper (this=0x228e580, receiver=0x2878650, e=0x30d37b0) at kernel/qapplication.cpp:4531
#38 0x00007fb609177713 in QApplication::notify (this=0x2280ad0, receiver=0x2878650, e=0x30d37b0) at kernel/qapplication.cpp:4420
#39 0x00007fb60aacdbb6 in KApplication::notify (this=0x2280ad0, receiver=0x2878650, event=0x30d37b0) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x00007fb609defe9c in QCoreApplication::notifyInternal (this=0x2280ad0, receiver=0x2878650, event=0x30d37b0) at kernel/qcoreapplication.cpp:876
#41 0x00007fb609df3c6a in sendEvent (event=0x30d37b0, receiver=0x2878650) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x2878650, event_type=77, data=0x21bb1f0) at kernel/qcoreapplication.cpp:1500
#43 0x00007fb60978890a in dispatchPendingUpdateRequests (this=0x287a660) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:200
#44 QGraphicsScenePrivate::_q_processDirtyItems (this=0x246ae20) at graphicsview/qgraphicsscene.cpp:515
#45 0x00007fb609788a61 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:107
#46 QGraphicsScene::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:86
#47 0x00007fb609e09446 in QObject::event (this=0x2497eb0, e=<optimized out>) at kernel/qobject.cpp:1195
#48 0x00007fb60978f5d9 in QGraphicsScene::event (this=0x2497eb0, event=0x391e8f0) at graphicsview/qgraphicsscene.cpp:3565
#49 0x00007fb609172894 in notify_helper (e=0x391e8f0, receiver=0x2497eb0, this=0x228e580) at kernel/qapplication.cpp:4559
#50 QApplicationPrivate::notify_helper (this=0x228e580, receiver=0x2497eb0, e=0x391e8f0) at kernel/qapplication.cpp:4531
#51 0x00007fb609177713 in QApplication::notify (this=0x2280ad0, receiver=0x2497eb0, e=0x391e8f0) at kernel/qapplication.cpp:4420
#52 0x00007fb60aacdbb6 in KApplication::notify (this=0x2280ad0, receiver=0x2497eb0, event=0x391e8f0) at ../../kdeui/kernel/kapplication.cpp:311
#53 0x00007fb609defe9c in QCoreApplication::notifyInternal (this=0x2280ad0, receiver=0x2497eb0, event=0x391e8f0) at kernel/qcoreapplication.cpp:876
#54 0x00007fb609df3c6a in sendEvent (event=0x391e8f0, receiver=0x2497eb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x21bb1f0) at kernel/qcoreapplication.cpp:1500
#56 0x00007fb609e1ef93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#57 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#58 0x00007fb600dfbc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#59 0x00007fb600dfc060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#60 0x00007fb600dfc124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#61 0x00007fb609e1f3bf in QEventDispatcherGlib::processEvents (this=0x21bcad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#62 0x00007fb60921ad5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#63 0x00007fb609deec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#64 0x00007fb609deeed7 in QEventLoop::exec (this=0x7fff79b42da0, flags=...) at kernel/qeventloop.cpp:204
#65 0x00007fb609df3f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#66 0x00007fb60cf5aa13 in kdemain (argc=1, argv=0x7fff79b43188) at ../../../../plasma/desktop/shell/main.cpp:120
#67 0x00007fb60cb7d76d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff79b43188, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff79b43178) at libc-start.c:226
#68 0x0000000000400671 in _start ()

This bug may be a duplicate of or related to bug 299237.

Possible duplicates by query: bug 300970, bug 300910, bug 299237, bug 284131, bug 283688.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2012-06-10 07:40:04 UTC
Duplicate of 299237, thanks for your report

*** This bug has been marked as a duplicate of bug 299237 ***