Bug 284131 - Crash with World Clock widget
Summary: Crash with World Clock widget
Status: RESOLVED DUPLICATE of bug 275819
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-15 20:33 UTC by Cristian Zanna
Modified: 2011-10-16 21:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian Zanna 2011-10-15 20:33:59 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.7-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:I add the widget of the world clock on my desktop and KDe crashed

-- Backtrace:
Application: Shell del desktop di Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5813710 (LWP 2412))]

Thread 4 (Thread 0xaa701b70 (LWP 2419)):
#0  0xb5b3122b in clock_gettime () from /lib/librt.so.1
#1  0xb6d2aae5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6dfd706 in updateCurrentTime (this=0xa9e01074, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xa9e01074, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6dfbf4b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaa70111c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6dfbfed in timerSourcePrepare (source=0xa9e01040, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5a7ba70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb5a7c8e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb5a7cfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb6dfc797 in QEventDispatcherGlib::processEvents (this=0x855d260, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6dcd29d in QEventLoop::processEvents (this=0xaa7012b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6dcd4c9 in QEventLoop::exec (this=0xaa7012b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6cce7b9 in QThread::exec (this=0x84ac670) at thread/qthread.cpp:490
#14 0xb6dad21d in QInotifyFileSystemWatcherEngine::run (this=0x84ac670) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6cd13aa in QThreadPrivate::start (arg=0x84ac670) at thread/qthread_unix.cpp:285
#16 0xb6c55b05 in start_thread () from /lib/libpthread.so.0
#17 0xb6012d1e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa9de6b70 (LWP 8038)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6c5a105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb44e3c87 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0xb6c55b05 in start_thread () from /lib/libpthread.so.0
#4  0xb6012d1e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa2d83b70 (LWP 8070)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6007ffe in poll () from /lib/libc.so.6
#2  0xb5a8d0bb in g_poll () from /lib/libglib-2.0.so.0
#3  0xb5a7cc46 in ?? () from /lib/libglib-2.0.so.0
#4  0xb5a7cfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6dfc797 in QEventDispatcherGlib::processEvents (this=0x96e6900, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6dcd29d in QEventLoop::processEvents (this=0xa2d832b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6dcd4c9 in QEventLoop::exec (this=0xa2d832b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6cce7b9 in QThread::exec (this=0x969d6d8) at thread/qthread.cpp:490
#9  0xb6dad21d in QInotifyFileSystemWatcherEngine::run (this=0x969d6d8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6cd13aa in QThreadPrivate::start (arg=0x969d6d8) at thread/qthread_unix.cpp:285
#11 0xb6c55b05 in start_thread () from /lib/libpthread.so.0
#12 0xb6012d1e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5813710 (LWP 2412)):
[KCrash Handler]
#7  0xa23fa8fb in Marble::AbstractTile::setUsed (this=0xb0156e8, used=true) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractTile.cpp:62
#8  0xa23ea0fb in Marble::AbstractScanlineTextureMapper::nextTile (this=0x986aff8, posX=@0xbf99d15c, posY=@0xbf99d158) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:496
#9  0xa23ea234 in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x986aff8, lon=2.7925268885049559, lat=1.5707963267948966, scanLine=0xa4e7618) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:159
#10 0xa23ecce3 in Marble::EquirectScanlineTextureMapper::mapTexture (this=0x986aff8, viewParams=0x99252a4, texColorizer=0x0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/EquirectScanlineTextureMapper.cpp:180
#11 0xa23ecf24 in Marble::EquirectScanlineTextureMapper::mapTexture (this=0x986aff8, painter=0xbf99d530, viewParams=0x99252a4, dirtyRect=..., texColorizer=0x0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/EquirectScanlineTextureMapper.cpp:52
#12 0xa23e12e9 in Marble::TextureLayer::paintGlobe (this=0x99252c4, painter=0xbf99d530, viewParams=0x99252a4, dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/TextureLayer.cpp:161
#13 0xa2353b9d in Marble::MarbleMapPrivate::paintGround (this=0x9925298, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#14 0xa2354a65 in Marble::MarbleMap::paint (this=0x97f28f8, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:828
#15 0xa2537168 in Marble::WorldClock::paintInterface (this=0x945e780, p=0xbf99d8ec, option=0x811f580, contentsRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/plasmoid/worldclock.cpp:354
#16 0xb4b97138 in Plasma::Applet::paint (this=0x945e780, painter=0xbf99d8ec, option=0x811f580, widget=0x0) at /usr/src/debug/kdelibs-4.6.0/plasma/applet.cpp:1443
#17 0xb696b6a5 in _q_paintItem (item=<value optimized out>, painter=0xbf99d8ec, option=0x811f580, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#18 0xb696b9fa in _q_paintIntoCache (pix=0xbf99ddcc, item=0x945e788, pixmapExposed=..., itemToPixmap=..., renderHints=) at graphicsview/qgraphicsscene.cpp:4352
#19 0xb6980b10 in QGraphicsScenePrivate::drawItemHelper (this=0x811f430, item=0x945e788, painter=0xbf99ec04, option=0x811f580, widget=0x86bc718, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#20 0xb698147d in QGraphicsScenePrivate::draw (this=0x811f430, item=0x945e788, painter=0xbf99ec04, viewTransform=0x0, transformPtr=0x979a390, exposedRegion=0x855a138, widget=0x86bc718, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4931
#21 0xb69821ee in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x811f430, item=0x945e788, painter=0xbf99ec04, viewTransform=0x0, exposedRegion=0x855a138, widget=0x86bc718, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0xb6981517 in QGraphicsScenePrivate::draw (this=0x811f430, item=0x8326438, painter=0xbf99ec04, viewTransform=0x0, transformPtr=0x82c27f0, exposedRegion=0x855a138, widget=0x86bc718, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#23 0xb69821ee in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x811f430, item=0x8326438, painter=0xbf99ec04, viewTransform=0x0, exposedRegion=0x855a138, widget=0x86bc718, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0xb6982a77 in QGraphicsScenePrivate::drawItems (this=0x811f430, painter=0xbf99ec04, viewTransform=0x0, exposedRegion=0x855a138, widget=0x86bc718) at graphicsview/qgraphicsscene.cpp:4735
#25 0xb69a39ae in QGraphicsView::paintEvent (this=0x8782e68, event=0x1) at graphicsview/qgraphicsview.cpp:3469
#26 0xb633560a in QWidget::event (this=0x8782e68, event=0xbf99f2c4) at kernel/qwidget.cpp:8346
#27 0xb6743ed5 in QFrame::event (this=0x8782e68, e=0xbf99f2c4) at widgets/qframe.cpp:557
#28 0xb67d58a1 in QAbstractScrollArea::viewportEvent (this=0x8782e68, e=0xbf99f2c4) at widgets/qabstractscrollarea.cpp:1043
#29 0xb69a4dbc in QGraphicsView::viewportEvent (this=0x8782e68, event=0xbf99f2c4) at graphicsview/qgraphicsview.cpp:2864
#30 0xb67d8196 in viewportEvent (this=0x87552d0, o=0x86bc718, e=0xbf99f2c4) at widgets/qabstractscrollarea_p.h:100
#31 QAbstractScrollAreaFilter::eventFilter (this=0x87552d0, o=0x86bc718, e=0xbf99f2c4) at widgets/qabstractscrollarea_p.h:116
#32 0xb6dce156 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80c8ae0, receiver=0x86bc718, event=0xbf99f2c4) at kernel/qcoreapplication.cpp:847
#33 0xb62da3e4 in QApplicationPrivate::notify_helper (this=0x80c8ae0, receiver=0x86bc718, e=0xbf99f2c4) at kernel/qapplication.cpp:4441
#34 0xb62e3174 in QApplication::notify (this=0x80c1c50, receiver=0x86bc718, e=0xbf99f2c4) at kernel/qapplication.cpp:4324
#35 0xb74281f1 in KApplication::notify (this=0x80c1c50, receiver=0x86bc718, event=0xbf99f2c4) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#36 0xb6dcdfbe in QCoreApplication::notifyInternal (this=0x80c1c50, receiver=0x86bc718, event=0xbf99f2c4) at kernel/qcoreapplication.cpp:732
#37 0xb63322a2 in sendSpontaneousEvent (this=0x88156c8, pdev=0x8390d14, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8494028) at ../../src/corelib/kernel/qcoreapplication.h:218
#38 QWidgetPrivate::drawWidget (this=0x88156c8, pdev=0x8390d14, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8494028) at kernel/qwidget.cpp:5433
#39 0xb6520627 in QWidgetBackingStore::sync (this=0x8494028) at painting/qbackingstore.cpp:1325
#40 0xb632703b in QWidgetPrivate::syncBackingStore (this=0x8559de8) at kernel/qwidget.cpp:1816
#41 0xb63360da in QWidget::event (this=0x8782e68, event=0x9ab6aa8) at kernel/qwidget.cpp:8493
#42 0xb6743ed5 in QFrame::event (this=0x8782e68, e=0x9ab6aa8) at widgets/qframe.cpp:557
#43 0xb67d7624 in QAbstractScrollArea::event (this=0x8782e68, e=0x9ab6aa8) at widgets/qabstractscrollarea.cpp:996
#44 0xb6997578 in QGraphicsView::event (this=0x8782e68, event=0x9ab6aa8) at graphicsview/qgraphicsview.cpp:2741
#45 0xb62da414 in QApplicationPrivate::notify_helper (this=0x80c8ae0, receiver=0x8782e68, e=0x9ab6aa8) at kernel/qapplication.cpp:4445
#46 0xb62e3174 in QApplication::notify (this=0x80c1c50, receiver=0x8782e68, e=0x9ab6aa8) at kernel/qapplication.cpp:4324
#47 0xb74281f1 in KApplication::notify (this=0x80c1c50, receiver=0x8782e68, event=0x9ab6aa8) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#48 0xb6dcdfbe in QCoreApplication::notifyInternal (this=0x80c1c50, receiver=0x8782e68, event=0x9ab6aa8) at kernel/qcoreapplication.cpp:732
#49 0xb6dd1d4c in sendEvent (receiver=0x8782e68, event_type=77, data=0x80582a0) at kernel/qcoreapplication.h:215
#50 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8782e68, event_type=77, data=0x80582a0) at kernel/qcoreapplication.cpp:1373
#51 0xb6dd1e9c in QCoreApplication::sendPostedEvents (receiver=0x8782e68, event_type=77) at kernel/qcoreapplication.cpp:1266
#52 0xb6978ace in dispatchPendingUpdateRequests (this=0x811f430) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#53 QGraphicsScenePrivate::_q_processDirtyItems (this=0x811f430) at graphicsview/qgraphicsscene.cpp:510
#54 0xb6978ee3 in QGraphicsScene::qt_metacall (this=0x811e720, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x919def8) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#55 0xb4bcc1a2 in Plasma::Corona::qt_metacall (this=0x811e720, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x919def8) at /usr/src/debug/kdelibs-4.6.0/build/plasma/corona.moc:109
#56 0xb240df62 in DesktopCorona::qt_metacall (this=0x811e720, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x919def8) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/desktop/shell/desktopcorona.moc:101
#57 0xb6dd48ad in QMetaObject::metacall (object=0x811e720, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x919def8) at kernel/qmetaobject.cpp:237
#58 0xb6ddf385 in QMetaCallEvent::placeMetaCall (this=0x9888fc8, object=0x811e720) at kernel/qobject.cpp:534
#59 0xb6de358f in QObject::event (this=0x811e720, e=0x9888fc8) at kernel/qobject.cpp:1211
#60 0xb6986750 in QGraphicsScene::event (this=0x811e720, event=0x9888fc8) at graphicsview/qgraphicsscene.cpp:3544
#61 0xb62da414 in QApplicationPrivate::notify_helper (this=0x80c8ae0, receiver=0x811e720, e=0x9888fc8) at kernel/qapplication.cpp:4445
#62 0xb62e30c7 in QApplication::notify (this=0x80c1c50, receiver=0x811e720, e=0x9888fc8) at kernel/qapplication.cpp:3845
#63 0xb74281f1 in KApplication::notify (this=0x80c1c50, receiver=0x811e720, event=0x9888fc8) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#64 0xb6dcdfbe in QCoreApplication::notifyInternal (this=0x80c1c50, receiver=0x811e720, event=0x9888fc8) at kernel/qcoreapplication.cpp:732
#65 0xb6dd1d4c in sendEvent (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.h:215
#66 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.cpp:1373
#67 0xb6dd1e9c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#68 0xb6dfc5c4 in sendPostedEvents (s=0x80c88d0) at kernel/qcoreapplication.h:220
#69 postEventSourceDispatch (s=0x80c88d0) at kernel/qeventdispatcher_glib.cpp:277
#70 0xb5a7c509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#71 0xb5a7cd10 in ?? () from /lib/libglib-2.0.so.0
#72 0xb5a7cfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#73 0xb6dfc74b in QEventDispatcherGlib::processEvents (this=0x805cc30, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#74 0xb639055a in QGuiEventDispatcherGlib::processEvents (this=0x805cc30, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#75 0xb6dcd29d in QEventLoop::processEvents (this=0xbf9a0744, flags=...) at kernel/qeventloop.cpp:149
#76 0xb6dcd4c9 in QEventLoop::exec (this=0xbf9a0744, flags=...) at kernel/qeventloop.cpp:201
#77 0xb6dd1f70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#78 0xb62d8104 in QApplication::exec () at kernel/qapplication.cpp:3719
#79 0xb24158aa in kdemain (argc=1, argv=0x80b2320) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#80 0x0804e531 in _start ()

This bug may be a duplicate of or related to bug 275819.

Possible duplicates by query: bug 276402, bug 275819.

Reported using DrKonqi
Comment 1 Nicolas L. 2011-10-16 21:04:19 UTC

*** This bug has been marked as a duplicate of bug 275819 ***