Bug 283688 - Plasma crash on login
Summary: Plasma crash on login
Status: RESOLVED DUPLICATE of bug 281441
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-10 07:04 UTC by Bob K
Modified: 2011-10-10 10:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob K 2011-10-10 07:04:00 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I'm just only logged in to KDE, then after the login fade out the crash reporter greeted me...

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c8720 (LWP 1712))]

Thread 3 (Thread 0xb0a23b70 (LWP 1714)):
#0  0x008dc017 in ?? () from /usr/lib/i386-linux-gnu/libgthread-2.0.so.0
#1  0x04e95482 in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x04e69572 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x04e6adde in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x04e6b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0522f577 in QEventDispatcherGlib::processEvents (this=0x8b1d120, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x05201289 in QEventLoop::processEvents (this=0xb0a23280, flags=...) at kernel/qeventloop.cpp:149
#7  0x05201522 in QEventLoop::exec (this=0xb0a23280, flags=...) at kernel/qeventloop.cpp:201
#8  0x0510b2a0 in QThread::exec (this=0x8f92858) at thread/qthread.cpp:492
#9  0x051e2fdb in QInotifyFileSystemWatcherEngine::run (this=0x8f92858) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0510dda2 in QThreadPrivate::start (arg=0x8f92858) at thread/qthread_unix.cpp:320
#11 0x01b85e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00f1b73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xaf680b70 (LWP 1720)):
#0  0x00a83d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x05163dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x052304f2 in updateCurrentTime (this=0x9195eb4, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x9195eb4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0522ed32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaf6800cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0522edcd in timerSourcePrepare (source=0x9195e80, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x04e69fd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x04e6ae63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x04e6b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0522f577 in QEventDispatcherGlib::processEvents (this=0x9194898, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x05201289 in QEventLoop::processEvents (this=0xaf680280, flags=...) at kernel/qeventloop.cpp:149
#12 0x05201522 in QEventLoop::exec (this=0xaf680280, flags=...) at kernel/qeventloop.cpp:201
#13 0x0510b2a0 in QThread::exec (this=0x91934a0) at thread/qthread.cpp:492
#14 0x051e2fdb in QInotifyFileSystemWatcherEngine::run (this=0x91934a0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0510dda2 in QThreadPrivate::start (arg=0x91934a0) at thread/qthread_unix.cpp:320
#16 0x01b85e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00f1b73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb77c8720 (LWP 1712)):
[KCrash Handler]
#7  0x01bb3942 in ?? () from /usr/lib/i386-linux-gnu/libfontconfig.so.1
#8  0x01bb3ce4 in FcStrCmpIgnoreCase () from /usr/lib/i386-linux-gnu/libfontconfig.so.1
#9  0x01ba0610 in ?? () from /usr/lib/i386-linux-gnu/libfontconfig.so.1
#10 0x01ba1382 in FcConfigSubstituteWithPat () from /usr/lib/i386-linux-gnu/libfontconfig.so.1
#11 0x01ba18e7 in FcConfigSubstitute () from /usr/lib/i386-linux-gnu/libfontconfig.so.1
#12 0x03ca51b9 in tryPatternLoad (p=<value optimized out>, screen=0, request=..., script=0, matchedPattern=0xbfbfd3e4) at text/qfontdatabase_x11.cpp:1602
#13 0x03cad9bd in loadFc (d=0x8af8810, script=0) at text/qfontdatabase_x11.cpp:1709
#14 QFontDatabase::load (d=0x8af8810, script=0) at text/qfontdatabase_x11.cpp:1960
#15 0x03c8972f in QFontPrivate::engineForScript (this=0x8af8810, script=0) at text/qfont.cpp:270
#16 0x03c9ff77 in QFontMetricsF::leading (this=0xbfbffe78) at text/qfontmetrics.cpp:1215
#17 0x03bb8534 in qt_format_text (fnt=..., _r=..., tf=134234385, option=0x0, str=..., brect=0xbfbfffe8, tabstops=0, tabarraylen=0, painter=0x0) at painting/qpainter.cpp:8028
#18 0x03bb9221 in qt_format_text (fnt=..., _r=..., tf=16640, str=..., brect=0xbfbfffe8, tabstops=0, ta=0x0, tabarraylen=0, painter=0x0) at painting/qpainter.cpp:7876
#19 0x03c9f663 in QFontMetrics::boundingRect (this=0xbfc000bc, rect=..., flags=256, text=..., tabStops=0, tabArray=0x0) at text/qfontmetrics.cpp:798
#20 0x049a1d54 in Clock::prepareFont (this=0x8c1bf20, font=..., rect=..., text=..., singleline=true) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:713
#21 0x049a32f1 in Clock::preparePainter (this=0x8c1bf20, p=0xbfc0071c, rect=..., font=..., text=..., singleline=true) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:725
#22 0x049a3a73 in Clock::paintInterface (this=0x8c1bf20, p=0xbfc0071c, option=0x8b573b0, contentsRect=...) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:573
#23 0x00b70f0a in Plasma::Applet::paint (this=0x8c1bf20, painter=0xbfc0071c, option=0x8b573b0, widget=0x0) at ../../plasma/applet.cpp:1458
#24 0x040b247c in _q_paintItem (item=<value optimized out>, painter=0xbfc0071c, option=0x8b573b0, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#25 0x040b2782 in _q_paintIntoCache (pix=0xbfc00bec, item=0x8c1bf28, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x8b573b0, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#26 0x040c6490 in QGraphicsScenePrivate::drawItemHelper (this=0x8b57260, item=0x8c1bf28, painter=0xbfc01a94, option=0x8b573b0, widget=0x924afc8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#27 0x040c7152 in QGraphicsScenePrivate::draw (this=0x8b57260, item=0x8c1bf28, painter=0xbfc01a94, viewTransform=0xbfc0187c, transformPtr=0xbfc00fd0, exposedRegion=0x9417430, widget=0x924afc8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#28 0x040c7e92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8b57260, item=0x8c1bf28, painter=0xbfc01a94, viewTransform=0xbfc0187c, exposedRegion=0x9417430, widget=0x924afc8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#29 0x040c6f7c in QGraphicsScenePrivate::draw (this=0x8b57260, item=0x8b65270, painter=0xbfc01a94, viewTransform=0xbfc0187c, transformPtr=0xbfc01470, exposedRegion=0x9417430, widget=0x924afc8, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#30 0x040c7e92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8b57260, item=0x8b65270, painter=0xbfc01a94, viewTransform=0xbfc0187c, exposedRegion=0x9417430, widget=0x924afc8, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#31 0x040c8696 in QGraphicsScenePrivate::drawItems (this=0x8b57260, painter=0xbfc01a94, viewTransform=0xbfc0187c, exposedRegion=0x9417430, widget=0x924afc8) at graphicsview/qgraphicsscene.cpp:4735
#32 0x040e7931 in QGraphicsView::paintEvent (this=0x93ff1f0, event=0xbfc021a4) at graphicsview/qgraphicsview.cpp:3469
#33 0x0091a104 in PanelView::paintEvent (this=0x93ff1f0, event=0xbfc021a4) at ../../../../plasma/desktop/shell/panelview.cpp:1442
#34 0x03aa918e in QWidget::event (this=0x93ff1f0, event=0xbfc021a4) at kernel/qwidget.cpp:8405
#35 0x03e9d9f3 in QFrame::event (this=0x93ff1f0, e=0xbfc021a4) at widgets/qframe.cpp:557
#36 0x03f2c062 in QAbstractScrollArea::viewportEvent (this=0x93ff1f0, e=0xbfc021a4) at widgets/qabstractscrollarea.cpp:1043
#37 0x040e8dff in QGraphicsView::viewportEvent (this=0x93ff1f0, event=0xbfc021a4) at graphicsview/qgraphicsview.cpp:2864
#38 0x03f2e965 in viewportEvent (this=0x8d882e0, o=0x924afc8, e=0xbfc021a4) at widgets/qabstractscrollarea_p.h:100
#39 QAbstractScrollAreaFilter::eventFilter (this=0x8d882e0, o=0x924afc8, e=0xbfc021a4) at widgets/qabstractscrollarea_p.h:116
#40 0x0520225a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8a2f440, receiver=0x924afc8, event=0xbfc021a4) at kernel/qcoreapplication.cpp:846
#41 0x03a50d00 in QApplicationPrivate::notify_helper (this=0x8a2f440, receiver=0x924afc8, e=0xbfc021a4) at kernel/qapplication.cpp:4458
#42 0x03a5597b in QApplication::notify (this=0x8a03188, receiver=0x924afc8, e=0xbfc021a4) at kernel/qapplication.cpp:4427
#43 0x01183c9a in KApplication::notify (this=0x8a03188, receiver=0x924afc8, event=0xbfc021a4) at ../../kdeui/kernel/kapplication.cpp:311
#44 0x052020bb in QCoreApplication::notifyInternal (this=0x8a03188, receiver=0x924afc8, event=0xbfc021a4) at kernel/qcoreapplication.cpp:731
#45 0x03aa5f0c in sendSpontaneousEvent (this=0x924afe0, pdev=0x8e00c3c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8f6afc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#46 QWidgetPrivate::drawWidget (this=0x924afe0, pdev=0x8e00c3c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8f6afc0) at kernel/qwidget.cpp:5492
#47 0x03aa6b7c in QWidgetPrivate::paintSiblingsRecursive (this=0x94170e0, pdev=0x8e00c3c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8f6afc0) at kernel/qwidget.cpp:5699
#48 0x03aa5c80 in QWidgetPrivate::drawWidget (this=0x94170e0, pdev=0x8e00c3c, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8f6afc0) at kernel/qwidget.cpp:5545
#49 0x03c84398 in QWidgetBackingStore::sync (this=0x8f6afc0) at painting/qbackingstore.cpp:1333
#50 0x03c8475a in QWidgetBackingStore::sync (this=0x8f6afc0, exposedWidget=0x93ff1f0, exposedRegion=...) at painting/qbackingstore.cpp:1130
#51 0x03a9b782 in QWidgetPrivate::syncBackingStore (this=0x94170e0, region=...) at kernel/qwidget.cpp:1857
#52 0x03ada696 in QETWidget::translatePaintEvent (this=0x93ff1f0, event=0xbfc02cac) at kernel/qapplication_x11.cpp:5457
#53 0x03adb332 in QApplication::x11ProcessEvent (this=0x8a03188, event=0xbfc02cac) at kernel/qapplication_x11.cpp:3580
#54 0x03b075f4 in x11EventSourceDispatch (s=0x8a2d3b0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#55 0x04e6aaa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#56 0x04e6b270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#57 0x04e6b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#58 0x0522f53c in QEventDispatcherGlib::processEvents (this=0x89aea60, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#59 0x03b071e5 in QGuiEventDispatcherGlib::processEvents (this=0x89aea60, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#60 0x05201289 in QEventLoop::processEvents (this=0xbfc02f74, flags=...) at kernel/qeventloop.cpp:149
#61 0x05201522 in QEventLoop::exec (this=0xbfc02f74, flags=...) at kernel/qeventloop.cpp:201
#62 0x05205ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#63 0x03a4e8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#64 0x009140db in kdemain (argc=1, argv=0xbfc03194) at ../../../../plasma/desktop/shell/main.cpp:120
#65 0x080485bb in main (argc=1, argv=0xbfc03194) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 281441.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-10 10:23:31 UTC

*** This bug has been marked as a duplicate of bug 281441 ***