Bug 300970 - Crash upon digital clock setting short date display change.
Summary: Crash upon digital clock setting short date display change.
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-31 23:00 UTC by Bill S.
Modified: 2012-05-31 23:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bill S. 2012-05-31 23:00:10 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Adjusting digital clock settings. Changed (Canadian) [short] date display to MM/DD/YY instead of DD/MM/YY. Crash upon OK.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f665a798780 (LWP 2997))]

Thread 5 (Thread 0x7f663f2b0700 (LWP 2998)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f6654003222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f6654003259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f664eb30e9a in start_thread (arg=0x7f663f2b0700) at pthread_create.c:308
#4  0x00007f665a07e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f663c981700 (LWP 2999)):
#0  __pthread_mutex_lock (mutex=0x7f6638000a60) at pthread_mutex_lock.c:87
#1  0x00007f664e267561 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f664e22b729 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f664e22bf1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f664e22c124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f665724f426 in QEventDispatcherGlib::processEvents (this=0x7f66380008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f665721ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f665721eed7 in QEventLoop::exec (this=0x7f663c980dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f665711dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f66571fe9ff in QInotifyFileSystemWatcherEngine::run (this=0x21e60d0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f6657120fcb in QThreadPrivate::start (arg=0x21e60d0) at thread/qthread_unix.cpp:298
#11 0x00007f664eb30e9a in start_thread (arg=0x7f663c981700) at pthread_create.c:308
#12 0x00007f665a07e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6632b08700 (LWP 3000)):
#0  0x00007f664eb32f69 in __pthread_mutex_lock (mutex=0x7f662c000a60) at pthread_mutex_lock.c:92
#1  0x00007f664e267561 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f664e22b729 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f664e22bf1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f664e22c124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f665724f426 in QEventDispatcherGlib::processEvents (this=0x7f662c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f665721ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f665721eed7 in QEventLoop::exec (this=0x7f6632b07dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f665711dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f66571fe9ff in QInotifyFileSystemWatcherEngine::run (this=0x24774a0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f6657120fcb in QThreadPrivate::start (arg=0x24774a0) at thread/qthread_unix.cpp:298
#11 0x00007f664eb30e9a in start_thread (arg=0x7f6632b08700) at pthread_create.c:308
#12 0x00007f665a07e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6623fff700 (LWP 3002)):
#0  0x00007f665a072b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f664e22bff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f664e22c45a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6628ce62c6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f664e24d9a5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f664eb30e9a in start_thread (arg=0x7f6623fff700) at pthread_create.c:308
#6  0x00007f665a07e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f665a798780 (LWP 2997)):
[KCrash Handler]
#6  0x0000000004ed0220 in ?? ()
#7  0x00007f6630567230 in Clock::paintInterface (this=0x2725640, p=0x7fffedf6ab00, contentsRect=..., option=<optimized out>) at ../../../../../plasma/generic/applets/digital-clock/clock.cpp:476
#8  0x00007f6659b62146 in Plasma::Applet::paint (this=0x2725640, painter=0x7fffedf6ab00, option=0x2143bf8, widget=0x0) at ../../plasma/applet.cpp:1466
#9  0x00007f6656ba897d in _q_paintItem (item=<optimized out>, painter=0x7fffedf6ab00, option=0x2143bf8, widget=0x0, useWindowOpacity=<optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4335
#10 0x00007f6656ba954a in _q_paintIntoCache (pix=0x7fffedf6b090, item=0x2725650, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x2143bf8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4373
#11 0x00007f6656bc1988 in QGraphicsScenePrivate::drawItemHelper (this=0x21439d0, item=0x2725650, painter=0x7fffedf6c530, option=0x2143bf8, widget=<optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4694
#12 0x00007f6656bc234b in QGraphicsScenePrivate::draw (this=0x21439d0, item=0x2725650, painter=0x7fffedf6c530, viewTransform=0x7fffedf6c200, transformPtr=0x7fffedf6b680, exposedRegion=0x233a9d8, widget=0x2373ce0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4966
#13 0x00007f6656bc33d5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x21439d0, item=0x2725650, painter=0x7fffedf6c530, viewTransform=0x7fffedf6c200, exposedRegion=0x233a9d8, widget=0x2373ce0, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4857
#14 0x00007f6656bc2420 in QGraphicsScenePrivate::draw (this=0x21439d0, item=0x23a5380, painter=0x7fffedf6c530, viewTransform=0x7fffedf6c200, transformPtr=0x7fffedf6bcd0, exposedRegion=0x233a9d8, widget=0x2373ce0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4996
#15 0x00007f6656bc33d5 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x21439d0, item=0x23a5380, painter=0x7fffedf6c530, viewTransform=0x7fffedf6c200, exposedRegion=0x233a9d8, widget=0x2373ce0, parentOpacity=<optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x00007f6656bc3bf1 in QGraphicsScenePrivate::drawItems (this=0x21439d0, painter=0x7fffedf6c530, viewTransform=0x7fffedf6c200, exposedRegion=0x233a9d8, widget=0x2373ce0) at graphicsview/qgraphicsscene.cpp:4739
#17 0x00007f6656bdc870 in QGraphicsView::paintEvent (this=<optimized out>, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x00007f66565f30f6 in QWidget::event (this=0x23710f0, event=0x7fffedf6ced0) at kernel/qwidget.cpp:8508
#19 0x00007f66569b33b6 in QFrame::event (this=0x23710f0, e=0x7fffedf6ced0) at widgets/qframe.cpp:557
#20 0x00007f6656bddb2b in QGraphicsView::viewportEvent (this=0x23710f0, event=0x7fffedf6ced0) at graphicsview/qgraphicsview.cpp:2866
#21 0x00007f6657220028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x2373ce0, event=0x7fffedf6ced0) at kernel/qcoreapplication.cpp:986
#22 0x00007f66565a285f in notify_helper (e=0x7fffedf6ced0, receiver=0x2373ce0, this=0x1f3e220) at kernel/qapplication.cpp:4555
#23 QApplicationPrivate::notify_helper (this=0x1f3e220, receiver=0x2373ce0, e=0x7fffedf6ced0) at kernel/qapplication.cpp:4531
#24 0x00007f66565a7713 in QApplication::notify (this=0x1f23e20, receiver=0x2373ce0, e=0x7fffedf6ced0) at kernel/qapplication.cpp:4420
#25 0x00007f6657efdbb6 in KApplication::notify (this=0x1f23e20, receiver=0x2373ce0, event=0x7fffedf6ced0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f665721fe9c in QCoreApplication::notifyInternal (this=0x1f23e20, receiver=0x2373ce0, event=0x7fffedf6ced0) at kernel/qcoreapplication.cpp:876
#27 0x00007f66565eed96 in sendSpontaneousEvent (event=0x7fffedf6ced0, receiver=0x2373ce0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#28 QWidgetPrivate::drawWidget (this=0x2373d10, pdev=0x2c384f0, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1f825e0) at kernel/qwidget.cpp:5585
#29 0x00007f66565efa0f in QWidgetPrivate::paintSiblingsRecursive (this=0x233a550, pdev=0x2c384f0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1f825e0) at kernel/qwidget.cpp:5794
#30 0x00007f66565eeacc in QWidgetPrivate::drawWidget (this=0x233a550, pdev=0x2c384f0, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x1f825e0) at kernel/qwidget.cpp:5638
#31 0x00007f66567bfb58 in QWidgetBackingStore::sync (this=0x1f825e0) at painting/qbackingstore.cpp:1373
#32 0x00007f66565e5ac0 in QWidgetPrivate::syncBackingStore (this=0x233a550) at kernel/qwidget.cpp:1891
#33 0x00007f66565f360c in QWidget::event (this=0x23710f0, event=0x3711680) at kernel/qwidget.cpp:8655
#34 0x00007f66569b33b6 in QFrame::event (this=0x23710f0, e=0x3711680) at widgets/qframe.cpp:557
#35 0x00007f6656a354c3 in QAbstractScrollArea::event (this=0x23710f0, e=0x3711680) at widgets/qabstractscrollarea.cpp:996
#36 0x00007f66565a2894 in notify_helper (e=0x3711680, receiver=0x23710f0, this=0x1f3e220) at kernel/qapplication.cpp:4559
#37 QApplicationPrivate::notify_helper (this=0x1f3e220, receiver=0x23710f0, e=0x3711680) at kernel/qapplication.cpp:4531
#38 0x00007f66565a7713 in QApplication::notify (this=0x1f23e20, receiver=0x23710f0, e=0x3711680) at kernel/qapplication.cpp:4420
#39 0x00007f6657efdbb6 in KApplication::notify (this=0x1f23e20, receiver=0x23710f0, event=0x3711680) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x00007f665721fe9c in QCoreApplication::notifyInternal (this=0x1f23e20, receiver=0x23710f0, event=0x3711680) at kernel/qcoreapplication.cpp:876
#41 0x00007f6657223c6a in sendEvent (event=0x3711680, receiver=0x23710f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x23710f0, event_type=77, data=0x1ecd1f0) at kernel/qcoreapplication.cpp:1500
#43 0x00007f6656bb890a in dispatchPendingUpdateRequests (this=0x233a550) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:200
#44 QGraphicsScenePrivate::_q_processDirtyItems (this=0x21439d0) at graphicsview/qgraphicsscene.cpp:515
#45 0x00007f6656bb8a61 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:107
#46 QGraphicsScene::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:86
#47 0x00007f6657239446 in QObject::event (this=0x206eb70, e=<optimized out>) at kernel/qobject.cpp:1195
#48 0x00007f6656bbf5d9 in QGraphicsScene::event (this=0x206eb70, event=0x48e16d0) at graphicsview/qgraphicsscene.cpp:3565
#49 0x00007f66565a2894 in notify_helper (e=0x48e16d0, receiver=0x206eb70, this=0x1f3e220) at kernel/qapplication.cpp:4559
#50 QApplicationPrivate::notify_helper (this=0x1f3e220, receiver=0x206eb70, e=0x48e16d0) at kernel/qapplication.cpp:4531
#51 0x00007f66565a7713 in QApplication::notify (this=0x1f23e20, receiver=0x206eb70, e=0x48e16d0) at kernel/qapplication.cpp:4420
#52 0x00007f6657efdbb6 in KApplication::notify (this=0x1f23e20, receiver=0x206eb70, event=0x48e16d0) at ../../kdeui/kernel/kapplication.cpp:311
#53 0x00007f665721fe9c in QCoreApplication::notifyInternal (this=0x1f23e20, receiver=0x206eb70, event=0x48e16d0) at kernel/qcoreapplication.cpp:876
#54 0x00007f6657223c6a in sendEvent (event=0x48e16d0, receiver=0x206eb70) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1ecd1f0) at kernel/qcoreapplication.cpp:1500
#56 0x00007f665724ef93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#57 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#58 0x00007f664e22bc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#59 0x00007f664e22c060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#60 0x00007f664e22c124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#61 0x00007f665724f3bf in QEventDispatcherGlib::processEvents (this=0x1ecead0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#62 0x00007f665664ad5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#63 0x00007f665721ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#64 0x00007f665721eed7 in QEventLoop::exec (this=0x7fffedf6ec80, flags=...) at kernel/qeventloop.cpp:204
#65 0x00007f6657223f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#66 0x00007f665a38aa13 in kdemain (argc=1, argv=0x7fffedf6f068) at ../../../../plasma/desktop/shell/main.cpp:120
#67 0x00007f6659fad76d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fffedf6f068, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffedf6f058) at libc-start.c:226
#68 0x0000000000400671 in _start ()

Possible duplicates by query: bug 300910, bug 299237, bug 284131, bug 283688, bug 280792.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-05-31 23:27:09 UTC

*** This bug has been marked as a duplicate of bug 299237 ***