Bug 299817 - Crash after deleting multiple messages in succession
Summary: Crash after deleting multiple messages in succession
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-11 13:01 UTC by Patrick Grimm
Modified: 2012-05-17 12:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Grimm 2012-05-11 13:01:32 UTC
Application: kmail (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I had two new emails and was deleting them without reading. After deletion the inbox advanced to a previously read email which I also quickly deleted via the "move to trash" toolbar button. Kmail may have been in the process of displaying the email which consisted of a single url, or it may have not completed the previous delete. These messages were deleted quickly via individual mouse clicks. Upon kmail restart the 3rd message is still in the inbox.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ffd8e5d57c0 (LWP 5610))]

Thread 4 (Thread 0x7ffd6c180700 (LWP 5620)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffd808cddec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007ffd808cdf19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007ffd893ffe9a in start_thread (arg=0x7ffd6c180700) at pthread_create.c:308
#4  0x00007ffd8b9304bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ffd6b87f700 (LWP 5621)):
#0  0x00007ffd8b924b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffd841d9ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffd841da124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffd8c2bb426 in QEventDispatcherGlib::processEvents (this=0x7ffd640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ffd8c28ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ffd8c28aed7 in QEventLoop::exec (this=0x7ffd6b87edc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ffd8c189fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007ffd8c18cfcb in QThreadPrivate::start (arg=0x1df8c30) at thread/qthread_unix.cpp:298
#8  0x00007ffd893ffe9a in start_thread (arg=0x7ffd6b87f700) at pthread_create.c:308
#9  0x00007ffd8b9304bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffd21f45700 (LWP 5951)):
#0  0x00007ffd8b9230bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007ffd8421488f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffd841d9abd in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffd841d9f96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffd841da124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ffd8c2bb426 in QEventDispatcherGlib::processEvents (this=0x7ffd100008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007ffd8c28ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007ffd8c28aed7 in QEventLoop::exec (this=0x7ffd21f44d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007ffd8c189fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007ffd8c26a9ff in QInotifyFileSystemWatcherEngine::run (this=0x3952950) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007ffd8c18cfcb in QThreadPrivate::start (arg=0x3952950) at thread/qthread_unix.cpp:298
#11 0x00007ffd893ffe9a in start_thread (arg=0x7ffd21f45700) at pthread_create.c:308
#12 0x00007ffd8b9304bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffd8e5d57c0 (LWP 5610)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3b97db0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007ffd8a965709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3b97db0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007ffd8c2a5446 in QObject::event (this=0x3b97db0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007ffd8c7ae894 in notify_helper (e=0x7ffd04008de0, receiver=0x3b97db0, this=0x17c0e30) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x17c0e30, receiver=0x3b97db0, e=0x7ffd04008de0) at kernel/qapplication.cpp:4531
#11 0x00007ffd8c7b3713 in QApplication::notify (this=0x7fff26d5b0f0, receiver=0x3b97db0, e=0x7ffd04008de0) at kernel/qapplication.cpp:4420
#12 0x00007ffd8dfe7b46 in KApplication::notify (this=0x7fff26d5b0f0, receiver=0x3b97db0, event=0x7ffd04008de0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007ffd8c28be9c in QCoreApplication::notifyInternal (this=0x7fff26d5b0f0, receiver=0x3b97db0, event=0x7ffd04008de0) at kernel/qcoreapplication.cpp:876
#14 0x00007ffd8c28fc6a in sendEvent (event=0x7ffd04008de0, receiver=0x3b97db0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1763220) at kernel/qcoreapplication.cpp:1500
#16 0x00007ffd8c2baf93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007ffd841d9c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007ffd841da060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007ffd841da124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007ffd8c2bb3bf in QEventDispatcherGlib::processEvents (this=0x1764b00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007ffd8c856d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007ffd8c28ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007ffd8c28aed7 in QEventLoop::exec (this=0x7fff26d5afd0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007ffd8c28ff67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in ?? ()
#27 0x00007ffd8b85f76d in __libc_start_main (main=0x4021a0, argc=3, ubp_av=0x7fff26d5b548, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff26d5b538) at libc-start.c:226
#28 0x0000000000403095 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 299807, bug 299769, bug 299746, bug 299446, bug 299323.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-05-11 13:11:48 UTC

*** This bug has been marked as a duplicate of bug 286307 ***
Comment 2 Patrick Grimm 2012-05-11 17:37:00 UTC
Now kmail is crashing when I attempt to delete a messge with HTML content in the inbox. It is not all HTML content messages though. When the crash handler opens and I chose the option to "restart application" I get a message that Kmail is already running. Further investigation showed numerous kmailxxxxxxx.slave-socket processes running. I killed one (kill -9 pid) and they all went away. Restarting kmail and attempting to delete a message with HTML content has the same result. The crash handler leaves an orphaned .slave-socket process but the main kmail process is terminated. I have also noted that the HTML message displays in the reading pane but any attempt to open the message in a new window (double click on message) will result in a kmail crash as well.

I realized that I could delete other HTML messages and the offending message was the first item in my inbox. Sent myself a plain text email to push the HTML message down the list and I was then able to successfully delete the message. It appears specific to that message because sending a simple HTML messge to myself did not duplicate the top of the list issue.
Comment 3 volRot 2012-05-17 10:16:23 UTC
kmail2 ended in 4.8.2, 4.8.3 and 4.8.4 if you are html - mails deleted or moves. Sometimes exits kmail even when it starts and this one html - wants to open mail.
It's all very annoying to start kmail again and again.

greeting
Comment 4 Christophe Giboudeaux 2012-05-17 12:57:14 UTC

*** This bug has been marked as a duplicate of bug 286307 ***