Bug 299769 - KMail sometimes crashes after moving a mail
Summary: KMail sometimes crashes after moving a mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-10 20:42 UTC by Sunito
Modified: 2012-05-11 08:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sunito 2012-05-10 20:42:52 UTC
Application: kmail (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I moved a mail from one folder to another and kmail crashed. I have observed this pattern several times now,
with different folders, different mails (with and without attachments). 
Maybe this is caused by a problem with displaying the next mail (in the original folder, after the move),
but so far, I have not paid attention to this.
But most move-operations work just fine (about 97%).

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc7888967c0 (LWP 3131))]

Thread 3 (Thread 0x7fc766103700 (LWP 3957)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fc77ab90dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fc77ab90f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fc7836c2e9a in start_thread (arg=0x7fc766103700) at pthread_create.c:308
#4  0x00007fc785bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc7657fa700 (LWP 3958)):
#0  0x00007fc785be60bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fc77e4d788f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc77e49cabd in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc77e49cf96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc77e49d124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc78657e426 in QEventDispatcherGlib::processEvents (this=0x7fc7600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fc78654dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fc78654ded7 in QEventLoop::exec (this=0x7fc7657f9dc0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fc78644cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fc78644ffcb in QThreadPrivate::start (arg=0x1c90920) at thread/qthread_unix.cpp:298
#10 0x00007fc7836c2e9a in start_thread (arg=0x7fc7657fa700) at pthread_create.c:308
#11 0x00007fc785bf34bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc7888967c0 (LWP 3131)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x1e0af80, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fc784c28709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x1e0af80, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fc786568446 in QObject::event (this=0x1e0af80, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fc786a71894 in notify_helper (e=0x7fc704006ea0, receiver=0x1e0af80, this=0x13bf190) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x13bf190, receiver=0x1e0af80, e=0x7fc704006ea0) at kernel/qapplication.cpp:4531
#11 0x00007fc786a76713 in QApplication::notify (this=0x7ffff4559d00, receiver=0x1e0af80, e=0x7fc704006ea0) at kernel/qapplication.cpp:4420
#12 0x00007fc7882aab46 in KApplication::notify (this=0x7ffff4559d00, receiver=0x1e0af80, event=0x7fc704006ea0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007fc78654ee9c in QCoreApplication::notifyInternal (this=0x7ffff4559d00, receiver=0x1e0af80, event=0x7fc704006ea0) at kernel/qcoreapplication.cpp:876
#14 0x00007fc786552c6a in sendEvent (event=0x7fc704006ea0, receiver=0x1e0af80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x136a220) at kernel/qcoreapplication.cpp:1500
#16 0x00007fc78657df93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fc77e49cc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fc77e49d060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fc77e49d124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fc78657e3bf in QEventDispatcherGlib::processEvents (this=0x136bb00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fc786b19d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fc78654dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fc78654ded7 in QEventLoop::exec (this=0x7ffff4559be0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fc786552f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in main (argc=<optimized out>, argv=<optimized out>) at ../../kmail/main.cpp:145

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 299746, bug 299446, bug 299323, bug 299040, bug 298890.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-05-11 08:30:56 UTC

*** This bug has been marked as a duplicate of bug 286307 ***