Bug 299807 - KMail crashed when switching to a different folder (which is from a different account)
Summary: KMail crashed when switching to a different folder (which is from a different...
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-11 09:56 UTC by Gregor Petrin
Modified: 2012-05-11 12:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregor Petrin 2012-05-11 09:56:50 UTC
Application: kmail (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2) "release 494"
Qt Version: 4.8.1
Operating System: Linux 3.1.10-1.9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I wanted to switch my message list to a new folder that I have in my favorites area (this folder also belongs to a different account) and KMail crashed.

Both accounts are disconnected IMAP accounts, I also have a POP one configured though I rarely switch to it.

KMail has crashed before, though I can't remember if it was on folder switch or not.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd84e5d9780 (LWP 4181))]

Thread 7 (Thread 0x7fd83050f700 (LWP 5372)):
#0  0x00007fd849720e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd83fdbe9dc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7fd840775200) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007fd83fdbeb09 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007fd84971cf05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fd84b91710d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fd82fc0e700 (LWP 5373)):
#0  0x00007fd843aefb3b in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fd843af092d in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fd843af0f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fd84cf742e6 in QEventDispatcherGlib::processEvents (this=0x7fd8280008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fd84cf44012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd84cf44267 in QEventLoop::exec (this=0x7fd82fc0de00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fd84ce44547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fd84ce4756b in QThreadPrivate::start (arg=0xb7a970) at thread/qthread_unix.cpp:298
#8  0x00007fd84971cf05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fd84b91710d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fd7e65b1700 (LWP 1364)):
#0  0x00007fd843af0b50 in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fd843af0f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fd84cf742e6 in QEventDispatcherGlib::processEvents (this=0x7fd7d4004650, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#3  0x00007fd84cf44012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007fd84cf44267 in QEventLoop::exec (this=0x7fd7e65b0dd0, flags=...) at kernel/qeventloop.cpp:204
#5  0x00007fd84ce44547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#6  0x00007fd84cf23dff in QInotifyFileSystemWatcherEngine::run (this=0x4ac52c0) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007fd84ce4756b in QThreadPrivate::start (arg=0x4ac52c0) at thread/qthread_unix.cpp:298
#8  0x00007fd84971cf05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fd84b91710d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fd7d9548700 (LWP 1808)):
#0  0x00007fd8497211eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd84ce479df in wait (time=30000, this=0x1651ad0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1651a48, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fd84ce3adef in QThreadPoolThread::run (this=0x1652da0) at concurrent/qthreadpool.cpp:141
#4  0x00007fd84ce4756b in QThreadPrivate::start (arg=0x1652da0) at thread/qthread_unix.cpp:298
#5  0x00007fd84971cf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fd84b91710d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fd7bffff700 (LWP 1850)):
#0  0x00007fd8497211eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd84ce479df in wait (time=30000, this=0xcfe580) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xcfe4f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fd84ce3adef in QThreadPoolThread::run (this=0xd11430) at concurrent/qthreadpool.cpp:141
#4  0x00007fd84ce4756b in QThreadPrivate::start (arg=0xd11430) at thread/qthread_unix.cpp:298
#5  0x00007fd84971cf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fd84b91710d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fd7e762d700 (LWP 1855)):
#0  0x00007fd8497211eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd84ce479df in wait (time=30000, this=0xec3970) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xec3848, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fd84ce3adef in QThreadPoolThread::run (this=0x7fd7c40119b0) at concurrent/qthreadpool.cpp:141
#4  0x00007fd84ce4756b in QThreadPrivate::start (arg=0x7fd7c40119b0) at thread/qthread_unix.cpp:298
#5  0x00007fd84971cf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fd84b91710d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fd84e5d9780 (LWP 4181)):
[KCrash Handler]
#6  0x00007fd84a8dc04c in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x51be6e0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fd84a967909 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x51be6e0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fd84cf5e2b6 in QObject::event (this=0x51be6e0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007fd84c2ca0d4 in notify_helper (e=0x7fd7c0007750, receiver=0x51be6e0, this=0x66b300) at kernel/qapplication.cpp:4554
#10 QApplicationPrivate::notify_helper (this=0x66b300, receiver=0x51be6e0, e=0x7fd7c0007750) at kernel/qapplication.cpp:4526
#11 0x00007fd84c2cef53 in QApplication::notify (this=0x7fffd1be2b30, receiver=0x51be6e0, e=0x7fd7c0007750) at kernel/qapplication.cpp:4415
#12 0x00007fd84dff4886 in KApplication::notify (this=0x7fffd1be2b30, receiver=0x51be6e0, event=0x7fd7c0007750) at /usr/src/debug/kdelibs-4.8.2/kdeui/kernel/kapplication.cpp:311
#13 0x00007fd84cf4522c in QCoreApplication::notifyInternal (this=0x7fffd1be2b30, receiver=0x51be6e0, event=0x7fd7c0007750) at kernel/qcoreapplication.cpp:876
#14 0x00007fd84cf48aca in sendEvent (event=0x7fd7c0007750, receiver=0x51be6e0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b720) at kernel/qcoreapplication.cpp:1500
#16 0x00007fd84cf73e53 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x66e0f0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fd843af058d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007fd843af0d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007fd843af0f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fd84cf7427f in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fd84c36d76e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fd84cf44012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fd84cf44267 in QEventLoop::exec (this=0x7fffd1be2a10, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fd84cf48dc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402df3 in ?? ()
#27 0x00007fd84b85d23d in __libc_start_main () from /lib64/libc.so.6
#28 0x00000000004032d5 in _start ()

Possible duplicates by query: bug 299769, bug 299746, bug 299446, bug 299323, bug 299040.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-05-11 12:16:59 UTC

*** This bug has been marked as a duplicate of bug 286307 ***